Previous Thread
Next Thread
Print Thread
#109209 - 03/18/17 11:08 PM How to get plugins to work?  
Joined: Aug 2004
Posts: 1,308
Robbbert Online content
Very Senior Member
Robbbert  Online Content
Very Senior Member

Joined: Aug 2004
Posts: 1,308
In my standard MAME (exactly as in git, no modifications), if I go to the plugins menu, it is empty. Further, if plugin.ini was populated, it gets emptied out leaving a file of 3 bytes.

What have I done wrong?

#109211 - 03/18/17 11:47 PM Re: How to get plugins to work? [Re: Robbbert]  
Joined: Jan 2012
Posts: 643
crazyc Offline
Senior Member
crazyc  Offline
Senior Member

Joined: Jan 2012
Posts: 643
Plugins are enumerated by looking for plugin.json in subdirs of pluginspath. Also, noplugins can't be set although that probably isn't you problem as the plugin menu disappears in that case.

#109212 - 03/18/17 11:57 PM Re: How to get plugins to work? [Re: Robbbert]  
Joined: Aug 2004
Posts: 1,308
Robbbert Online content
Very Senior Member
Robbbert  Online Content
Very Senior Member

Joined: Aug 2004
Posts: 1,308
Yes, that was it. For some reason my pluginspath was pointing to a non-existing folder. Changing it back to "plugins" fixed it.

Thanks! smile


Who's Online Now
3 registered members (Phil Bennett, 2 invisible), 33 guests, and 4 spiders.
Key: Admin, Global Mod, Mod
Shout Box
Forum Statistics
Forums9
Topics8,317
Posts107,537
Members4,734
Most Online225
May 26th, 2014
Powered by UBB.threads™ PHP Forum Software 7.6.0
Page Time: 0.232s Queries: 14 (0.216s) Memory: 4.9371 MB (Peak: 5.1060 MB) Zlib enabled. Server Time: 2017-04-26 23:21:28 UTC