Previous Thread
Next Thread
Print Thread
Page 2 of 2 1 2
#111613 - 12/11/17 09:15 PM Re: 0.192 build failing on OS 10.13 [Re: Monotremata]  
Joined: Jul 2007
Posts: 187
Monotremata Offline
Senior Member
Monotremata  Offline
Senior Member

Joined: Jul 2007
Posts: 187
California
Ok so this is really weird.. Was making sure all my Xcode stuff was up to date, and I had all the command line tools installed, etc.. Clang itself is giving the error. I just tried to run clang on its own to check the version and got this:

Code
SHIVA:mame mothra$ clang
dyld: Symbol not found: __ZNKSt3_V214error_category10_M_messageB5cxx11Ei
  Referenced from: /usr/local/bin/clang
  Expected in: /usr/lib/libstdc++.6.0.9.dylib
 in /usr/local/bin/clang
Abort trap: 6


Yet Ive built other stuff since I first attempted MAME? Just built the latest svn of QMC2 about a minute ago with no trouble (but then again it looks like its using g++ and not clang to build).

#111614 - 12/11/17 10:24 PM Re: 0.192 build failing on OS 10.13 [Re: Monotremata]  
Joined: Mar 2001
Posts: 15,807
R. Belmont Online content
R. Belmont  Online Content

Very Senior Member

Joined: Mar 2001
Posts: 15,807
USA
G++ should just be a symlink to clang.

#111615 - 12/11/17 10:58 PM Re: 0.192 build failing on OS 10.13 [Re: Monotremata]  
Joined: Jul 2007
Posts: 187
Monotremata Offline
Senior Member
Monotremata  Offline
Senior Member

Joined: Jul 2007
Posts: 187
California
It turns out its something to do with my user account, and I have no idea what. I made a new account with admin rights, downloaded the 0.192 source and it built perfectly fine. Its only my account that is getting the error. Not sure where to go from here, I tried removing everything I had installed with homebrew (that was a pain) but that didnt work either. Unless someone has a suggestion Im just gonna start making a list of apps, and all my audio recording stuff I have to reinstall and probably wipe it and start over. Which reminds me I better do one last Time Machine backup so I can keep my Documents and Downloads folder intact!

Page 2 of 2 1 2

Moderated by  R. Belmont 

Who's Online Now
4 registered members (Duke, Olivier Galibert, IgorRus, Stiletto), 23 guests, and 2 spiders.
Key: Admin, Global Mod, Mod
Shout Box
Forum Statistics
Forums9
Topics8,480
Posts110,308
Members4,770
Most Online225
May 26th, 2014
Powered by UBB.threads™ PHP Forum Software 7.6.0
Page Time: 0.033s Queries: 14 (0.007s) Memory: 4.9473 MB (Peak: 5.1178 MB) Zlib enabled. Server Time: 2018-01-18 19:37:51 UTC