Previous Thread
Next Thread
Print Thread
Page 1 of 2 1 2
#111544 - 12/08/17 03:33 AM 0.192 build failing on OS 10.13  
Joined: Jul 2007
Posts: 187
Monotremata Offline
Senior Member
Monotremata  Offline
Senior Member

Joined: Jul 2007
Posts: 187
California
Wow haven't had a single snag ever since I ditched my 2006 Mac Pro last year and just did trying to build MAME 0.192. Keeps stopping with this error here:

Code
Creating ../../../../osx_clang/bin/x64/Release
Precompiling src/emu/emu.h...
dyld: Symbol not found: __ZNKSt3_V214error_category10_M_messageB5cxx11Ei
  Referenced from: /usr/local/bin/clang++
  Expected in: /usr/lib/libstdc++.6.0.9.dylib
 in /usr/local/bin/clang++
make[2]: *** [../../../../osx_clang/obj/x64/Release/emu.h.gch] Abort trap: 6
make[1]: *** [precompile] Error 2
make: *** [macosx_x64_clang] Error 2


Any ideas? 0.191 and everything before it went smooth as ever. I did just recently install the last two Xcode updates that came out in the last week or so if that matters.

#111554 - 12/08/17 12:45 PM Re: 0.192 build failing on OS 10.13 [Re: Monotremata]  
Joined: Mar 2001
Posts: 15,807
R. Belmont Online content
R. Belmont  Online Content

Very Senior Member

Joined: Mar 2001
Posts: 15,807
USA
That's weird. Did you try doing a make clean after installing the Xcode update? It's usually a good idea.

#111555 - 12/08/17 12:49 PM Re: 0.192 build failing on OS 10.13 [Re: Monotremata]  
Joined: May 2008
Posts: 4,865
qmc2 Offline
qmc2  Offline

Very Senior Member

Joined: May 2008
Posts: 4,865
Germany
I had a chance to build "latest" MAME on macOS High Sierra recently (a git revision from last week) and it worked fine for me. It was a clean build and I installed the latest XCode update before I tried.


A mind is like a parachute. It doesn't work unless it's open. [Frank Zappa]

We're searching for QMC2 translators and support for existing translations. Interested? See here!
#111564 - 12/08/17 08:45 PM Re: 0.192 build failing on OS 10.13 [Re: R. Belmont]  
Joined: Jul 2007
Posts: 187
Monotremata Offline
Senior Member
Monotremata  Offline
Senior Member

Joined: Jul 2007
Posts: 187
California
Originally Posted by R. Belmont
That's weird. Did you try doing a make clean after installing the Xcode update? It's usually a good idea.


What directory would I run that in though? This was a fresh download of 0.192, I even downloaded it twice just in case the first download somehow got corrupted. Just tried again and still the same error. I looked it up last night and apparently this trap error is related to something writing to a memory space thats already in use or something like that? Which makes no sense to me considering what Im doing. Tried closing everything that was running, rebooting to flush out RAM, everything I could think of. Just built a snapshot of Exult just to see if something was going on but that built perfectly fine. Im stumped.

#111568 - 12/09/17 10:21 AM Re: 0.192 build failing on OS 10.13 [Re: Monotremata]  
Joined: May 1999
Posts: 529
Carbon Offline
Senior Member
Carbon  Offline
Senior Member

Joined: May 1999
Posts: 529
Luxembourg
I had no trouble building 0.192 on my iMac 5k, either. But I always start with a fresh download when a new release happens.

#111580 - 12/09/17 11:00 PM Re: 0.192 build failing on OS 10.13 [Re: Carbon]  
Joined: Jul 2007
Posts: 187
Monotremata Offline
Senior Member
Monotremata  Offline
Senior Member

Joined: Jul 2007
Posts: 187
California
Originally Posted by Carbon
I had no trouble building 0.192 on my iMac 5k, either. But I always start with a fresh download when a new release happens.


Yeah same here. I even downloaded it twice just to make sure and it still wont work.

#111582 - 12/10/17 02:14 PM Re: 0.192 build failing on OS 10.13 [Re: Monotremata]  
Joined: Sep 2000
Posts: 194
will Offline
will  Offline

Senior Member

Joined: Sep 2000
Posts: 194
DC, USA
No trouble compiling 0.192 on my iMac 5K. I'm running 10.13.2 and have Xcode 9.2 installed. Have you tried a simple make command or are you adding a bunch of arguments to make?


=will=
#111610 - 12/11/17 07:56 PM Re: 0.192 build failing on OS 10.13 [Re: Monotremata]  
Joined: Jul 2007
Posts: 187
Monotremata Offline
Senior Member
Monotremata  Offline
Senior Member

Joined: Jul 2007
Posts: 187
California
make -j5 TOOLS=1 REGENIE=1 is it. Just make by itself doesn't work either.

#111611 - 12/11/17 08:38 PM Re: 0.192 build failing on OS 10.13 [Re: Monotremata]  
Joined: May 1999
Posts: 529
Carbon Offline
Senior Member
Carbon  Offline
Senior Member

Joined: May 1999
Posts: 529
Luxembourg
Is the REGENIE really necessary if you start from scratch?

#111612 - 12/11/17 08:43 PM Re: 0.192 build failing on OS 10.13 [Re: Monotremata]  
Joined: Mar 2001
Posts: 15,807
R. Belmont Online content
R. Belmont  Online Content

Very Senior Member

Joined: Mar 2001
Posts: 15,807
USA
Yes.

#111613 - 12/11/17 09:15 PM Re: 0.192 build failing on OS 10.13 [Re: Monotremata]  
Joined: Jul 2007
Posts: 187
Monotremata Offline
Senior Member
Monotremata  Offline
Senior Member

Joined: Jul 2007
Posts: 187
California
Ok so this is really weird.. Was making sure all my Xcode stuff was up to date, and I had all the command line tools installed, etc.. Clang itself is giving the error. I just tried to run clang on its own to check the version and got this:

Code
SHIVA:mame mothra$ clang
dyld: Symbol not found: __ZNKSt3_V214error_category10_M_messageB5cxx11Ei
  Referenced from: /usr/local/bin/clang
  Expected in: /usr/lib/libstdc++.6.0.9.dylib
 in /usr/local/bin/clang
Abort trap: 6


Yet Ive built other stuff since I first attempted MAME? Just built the latest svn of QMC2 about a minute ago with no trouble (but then again it looks like its using g++ and not clang to build).

#111614 - 12/11/17 10:24 PM Re: 0.192 build failing on OS 10.13 [Re: Monotremata]  
Joined: Mar 2001
Posts: 15,807
R. Belmont Online content
R. Belmont  Online Content

Very Senior Member

Joined: Mar 2001
Posts: 15,807
USA
G++ should just be a symlink to clang.

#111615 - 12/11/17 10:58 PM Re: 0.192 build failing on OS 10.13 [Re: Monotremata]  
Joined: Jul 2007
Posts: 187
Monotremata Offline
Senior Member
Monotremata  Offline
Senior Member

Joined: Jul 2007
Posts: 187
California
It turns out its something to do with my user account, and I have no idea what. I made a new account with admin rights, downloaded the 0.192 source and it built perfectly fine. Its only my account that is getting the error. Not sure where to go from here, I tried removing everything I had installed with homebrew (that was a pain) but that didnt work either. Unless someone has a suggestion Im just gonna start making a list of apps, and all my audio recording stuff I have to reinstall and probably wipe it and start over. Which reminds me I better do one last Time Machine backup so I can keep my Documents and Downloads folder intact!

Page 1 of 2 1 2

Moderated by  R. Belmont 

Who's Online Now
5 registered members (Olivier Galibert, IgorRus, Stiletto, Praxis, robcfg), 24 guests, and 3 spiders.
Key: Admin, Global Mod, Mod
Shout Box
Forum Statistics
Forums9
Topics8,480
Posts110,308
Members4,770
Most Online225
May 26th, 2014
Powered by UBB.threads™ PHP Forum Software 7.6.0
Page Time: 0.086s Queries: 14 (0.023s) Memory: 5.0447 MB (Peak: 5.3160 MB) Zlib enabled. Server Time: 2018-01-18 19:36:23 UTC