Previous Thread
Next Thread
Print Thread
Page 1 of 2 1 2
#111584 - 12/10/17 02:48 PM Can't turn off HLSL's "phosphor_life"  
Joined: Mar 2013
Posts: 250
ICEknight Offline
Senior Member
ICEknight  Offline
Senior Member

Joined: Mar 2013
Posts: 250
I was trying some fast scrolling games with the HLSL filter and noticed that they looked too blurry to be playable, so I went to disable the "phosphor_life" from QMC2's Options/Emulator/Global configuration/Direct3D HLSL/phosphor_life and... oddly enough, it turned out it already has a default value of "0", which is supposed to disable it. Using really low values like "0,00000001" can make it unnoticeable as a workaround, though.

Using latest versions of both QMC2 and MAME.


LCD artwork cleanups: https://mega.nz/#F!uFYSzK7S!U-lJon9jsqyoCX_3y7_KLA
#111586 - 12/10/17 04:20 PM Re: Can't turn off HLSL's "phosphor_life" [Re: ICEknight]  
Joined: May 2008
Posts: 4,892
qmc2 Offline
qmc2  Offline

Very Senior Member

Joined: May 2008
Posts: 4,892
Germany
MAME's default for the setting may have changed. Could you run "Tools" -> "Clean up" -> "Check template map" from the menu and send me the output that's printed to the front-end log? And which version of MAME is that?

Last edited by qmc2; 12/10/17 04:22 PM.

A mind is like a parachute. It doesn't work unless it's open. [Frank Zappa]

We're searching for QMC2 translators and support for existing translations. Interested? See here!
#111590 - 12/10/17 07:32 PM Re: Can't turn off HLSL's "phosphor_life" [Re: ICEknight]  
Joined: Mar 2013
Posts: 250
ICEknight Offline
Senior Member
ICEknight  Offline
Senior Member

Joined: Mar 2013
Posts: 250
I get this in the front-end log when doing that:
Quote
20:32:46.437: checking template configuration map against selected emulator
20:32:55.201: done (checking template configuration map against selected emulator)
20:32:55.202: check results: 0 differences


I'm using MAME 0.192.


LCD artwork cleanups: https://mega.nz/#F!uFYSzK7S!U-lJon9jsqyoCX_3y7_KLA
#111592 - 12/10/17 09:25 PM Re: Can't turn off HLSL's "phosphor_life" [Re: ICEknight]  
Joined: May 2008
Posts: 4,892
qmc2 Offline
qmc2  Offline

Very Senior Member

Joined: May 2008
Posts: 4,892
Germany
Thanks. Well, that means QMC2 is up-to-date and doing it right. That is, when the default is 0 and and you don't change the value, QMC2 will not pass it on the MAME command line. If the behavior is then not what you expect, it's a MAME related question, not front-end one. Or what do you think is wrong here?

Last edited by qmc2; 12/10/17 09:29 PM.

A mind is like a parachute. It doesn't work unless it's open. [Frank Zappa]

We're searching for QMC2 translators and support for existing translations. Interested? See here!
#111593 - 12/10/17 09:39 PM Re: Can't turn off HLSL's "phosphor_life" [Re: qmc2]  
Joined: Mar 2013
Posts: 250
ICEknight Offline
Senior Member
ICEknight  Offline
Senior Member

Joined: Mar 2013
Posts: 250
Originally Posted by qmc2
That is, when the default is 0 and and you don't change the value, QMC2 will not pass it on the MAME command line. If the behavior is then not what you expect, it's a MAME related question, not front-end one. Or what do you think is wrong here?

Well, QMC2 says:
Quote
Phosphorescence decay rate (0.0 is instant 1.0 is forever)

And 0.0 is not instant, but shows instead whatever values MAME has set by default (which are not 0.0).


LCD artwork cleanups: https://mega.nz/#F!uFYSzK7S!U-lJon9jsqyoCX_3y7_KLA
#111594 - 12/10/17 11:12 PM Re: Can't turn off HLSL's "phosphor_life" [Re: ICEknight]  
Joined: Aug 2004
Posts: 1,353
Robbbert Offline
Very Senior Member
Robbbert  Offline
Very Senior Member

Joined: Aug 2004
Posts: 1,353
If you don't pass a value on the command line, the next port of call is mame.ini (plus any other ini's mame may consider). Any of them may contain an incorrect value for phosphor_life. Only if there's no ini files, will mame then use its internal default (whatever that may be).

#111598 - 12/11/17 08:06 AM Re: Can't turn off HLSL's "phosphor_life" [Re: ICEknight]  
Joined: May 2008
Posts: 4,892
qmc2 Offline
qmc2  Offline

Very Senior Member

Joined: May 2008
Posts: 4,892
Germany
Yep. It could be mame.ini / <some>.ini in the way. That's why I recommend to disable "readconfig" if you want to be sure that QMC2 is the only instance configuring MAME.

There's an FAQ about this.


A mind is like a parachute. It doesn't work unless it's open. [Frank Zappa]

We're searching for QMC2 translators and support for existing translations. Interested? See here!
#111599 - 12/11/17 08:07 AM Re: Can't turn off HLSL's "phosphor_life" [Re: ICEknight]  
Joined: May 2008
Posts: 4,892
qmc2 Offline
qmc2  Offline

Very Senior Member

Joined: May 2008
Posts: 4,892
Germany
Originally Posted by ICEknight
Well, QMC2 says:
Quote
Phosphorescence decay rate (0.0 is instant 1.0 is forever)

And 0.0 is not instant, but shows instead whatever values MAME has set by default (which are not 0.0).

Well, QMC2 just repeats what "mame -showusage" said about the option at the time it was added wink.


A mind is like a parachute. It doesn't work unless it's open. [Frank Zappa]

We're searching for QMC2 translators and support for existing translations. Interested? See here!
#111605 - 12/11/17 12:01 PM Re: Can't turn off HLSL's "phosphor_life" [Re: qmc2]  
Joined: Mar 2013
Posts: 250
ICEknight Offline
Senior Member
ICEknight  Offline
Senior Member

Joined: Mar 2013
Posts: 250
Originally Posted by qmc2
Yep. It could be mame.ini / <some>.ini in the way.

There's no mame.ini in my MAME folder, I'm using a clean installation. The only *.ini files are those which come bundled with the official release, inside "ini/presets".

The problem here may be that QMC2 expects one single default value of 0.0, which MAME may have built in but won't use whenever HLSL is active, since MAME's automatically assigned preset ini files don't have a default value of 0.0 (they range between 0.25 to 0.65).

I think that the solution in this case could be for QMC2 to, whenever it finds a numerical value here, always send it to the command line even if it's MAME's theoretical 0.0 default (since, when HLSL is active, the real default value is never 0.0), and maybe use a "null" value for keeping the preset defaults? This would avoid having to disable readconfig and losing the rest of the settings in the automatic presets.


LCD artwork cleanups: https://mega.nz/#F!uFYSzK7S!U-lJon9jsqyoCX_3y7_KLA
#111606 - 12/11/17 03:10 PM Re: Can't turn off HLSL's "phosphor_life" [Re: ICEknight]  
Joined: May 2008
Posts: 4,892
qmc2 Offline
qmc2  Offline

Very Senior Member

Joined: May 2008
Posts: 4,892
Germany
No, the solution should be to disable "readconfig" in the global emulator configuration as I said above. Have you tried it? Or change the preset ini files if you don't like their default values. I cannot handle every possible combination here... for QMC2, the emulator's default value is the one that's printed when you run "mame -noreadconfig -showconfig".


A mind is like a parachute. It doesn't work unless it's open. [Frank Zappa]

We're searching for QMC2 translators and support for existing translations. Interested? See here!
Page 1 of 2 1 2

Moderated by  qmc2 

Who's Online Now
3 registered members (seanriddle, shattered, dxl), 27 guests, and 3 spiders.
Key: Admin, Global Mod, Mod
Shout Box
Forum Statistics
Forums9
Topics8,543
Posts111,677
Members4,795
Most Online225
May 26th, 2014
Powered by UBB.threads™ PHP Forum Software 7.6.0
Page Time: 0.029s Queries: 14 (0.010s) Memory: 5.0192 MB (Peak: 5.2495 MB) Zlib enabled. Server Time: 2018-06-20 18:46:00 UTC