Previous Thread
Next Thread
Print Thread
#112475 - 02/03/18 01:00 PM QMC2 v0.194 released yet for macOS?  
Joined: Aug 2015
Posts: 24
azoreseuropa Offline
Member
azoreseuropa  Offline
Member

Joined: Aug 2015
Posts: 24
I could compiled it for macOS but have a problem. Is this one: https://svn.code.sf.net/p/qmc2/code/trunk qmc2-code

or this one:

http://wiki.batcom-it.net/index.php?title=Building_Qt_on_Mac_OS_X

And should I follow this:

http://wiki.batcom-it.net/index.php?title=QMC2_FAQ#Mac_OS_X and if it is then it need to update because it is outdate, I think??

Last edited by azoreseuropa; 02/03/18 01:16 PM.
#112479 - 02/03/18 04:36 PM Re: QMC2 v0.194 released yet for macOS? [Re: azoreseuropa]  
Joined: May 2008
Posts: 4,888
qmc2 Offline
qmc2  Offline

Very Senior Member

Joined: May 2008
Posts: 4,888
Germany

This is about compiling Qt on Mac OS X (and it's likely outdated). It's not related to QMC2 in particular.


That's what you need to do to compile QMC2. It's current and recently tested successfully.

Regarding your question in the subject: No, there's no official QMC2 0.194 yet. I'm in the middle of some major changes that need to be finished first. Anyway, the latest released version works fine with current MAME.


A mind is like a parachute. It doesn't work unless it's open. [Frank Zappa]

We're searching for QMC2 translators and support for existing translations. Interested? See here!
#112481 - 02/03/18 10:10 PM Re: QMC2 v0.194 released yet for macOS? [Re: azoreseuropa]  
Joined: Aug 2015
Posts: 24
azoreseuropa Offline
Member
azoreseuropa  Offline
Member

Joined: Aug 2015
Posts: 24
Thank you.

#112487 - 02/04/18 06:06 PM Re: QMC2 v0.194 released yet for macOS? [Re: azoreseuropa]  
Joined: Jul 2007
Posts: 195
Monotremata Offline
Senior Member
Monotremata  Offline
Senior Member

Joined: Jul 2007
Posts: 195
California
Or just build the SVN branch if you want to stay on the 'latest and greatest'. Its now v0.194, and builds with no trouble now that the OS requirement was changed. All you really need is the SDL2 and Qt 4.8.7 frameworks along with XCode, type 'make' and you're good to go. The wiki says after OS 10.10 you have to build Qt with home-brew, but I still have the frameworks installed on 10.13 and they work fine. You shouldn't have to edit anything, on my Qt installation, the g++-macx.conf file was already set to 10.6, and I didn't have to build without Phonon either.

#112494 - 02/05/18 09:50 AM Re: QMC2 v0.194 released yet for macOS? [Re: Monotremata]  
Joined: May 2008
Posts: 4,888
qmc2 Offline
qmc2  Offline

Very Senior Member

Joined: May 2008
Posts: 4,888
Germany
Originally Posted by Monotremata
The wiki says after OS 10.10 you have to build Qt with home-brew, but I still have the frameworks installed on 10.13 and they work fine.

Ah, that's good to know. Well, I just documented what I've tested. But I will re-add the official Qt 4.8.7 framework as an alternative to the wiki! The major advantage to home-brew is that it includes Phonon support then wink.

EDIT: FAQ section revised!

Last edited by qmc2; 02/05/18 10:03 AM.

A mind is like a parachute. It doesn't work unless it's open. [Frank Zappa]

We're searching for QMC2 translators and support for existing translations. Interested? See here!

Moderated by  qmc2 

Who's Online Now
7 registered members (MarkBielman, R. Belmont, elcondor, Vas Crabb, Dorando, AJR, Edstrom), 23 guests, and 1 spider.
Key: Admin, Global Mod, Mod
Shout Box
Forum Statistics
Forums9
Topics8,496
Posts110,806
Members4,781
Most Online225
May 26th, 2014
Powered by UBB.threads™ PHP Forum Software 7.6.0
Page Time: 0.042s Queries: 14 (0.009s) Memory: 4.9591 MB (Peak: 5.1705 MB) Zlib enabled. Server Time: 2018-02-22 16:11:58 UTC