Previous Thread
Next Thread
Print Thread
#113306 - 05/01/18 11:24 AM Odd bgfx issue  
Joined: Apr 2015
Posts: 364
EoceneMiacid Offline
Senior Member
EoceneMiacid  Offline
Senior Member

Joined: Apr 2015
Posts: 364

Normally I use bgfx as the video output, in conjunction with the crt-geom-deluxe chain, which worked great up until the last release.

I both upgraded my OS (Kubuntu 18.04) and MAME (0.197) at the same time, and ever since MAME performs ... oddly. Using bgfx at least, opengl does not exhibit the problem. All the other apps/games I run behave as expected, too.

Disabling autoframeskip (-noafs) shows that MAME runs at 84% speed, no matter the driver. I renamed my mame.ini and created a new one with default settings, and now it's at 90%. Trying to narrow down what causes the difference.

Enabling autoframeskip causes the frameskip to jump up and down from 0-3 in regular intervals.

I don't use waitvsync. And even with no chain active, the performance limit is still there.

Any other Linux bgfx users here?...

I'm sure some of you will be quick to blame the OS upgrade but I don't have anything else that uses bgfx so I can't rule that out.

Last edited by EoceneMiacid; 05/01/18 11:26 AM.
#113309 - 05/02/18 04:37 AM Re: Odd bgfx issue [Re: EoceneMiacid]  
Joined: Dec 2011
Posts: 25
minireaper Offline
minireaper  Offline

Joined: Dec 2011
Posts: 25

i had something like this too after upgrade to 18.04.
i had no hardware gl support at all with nvidia card and had to enable the ubuntu-grapihics-drivers repo and reinstall nvidia-390
to make gl happy again. after that mame worked like a boss again.

Moderated by  R. Belmont 

Who's Online Now
2 registered members (Sune, Duke), 24 guests, and 0 spiders.
Key: Admin, Global Mod, Mod
Shout Box
Forum Statistics
Most Online225
May 26th, 2014
Powered by UBB.threads™ PHP Forum Software 7.6.0
Page Time: 0.034s Queries: 14 (0.015s) Memory: 4.9275 MB (Peak: 5.0889 MB) Zlib enabled. Server Time: 2018-05-22 15:32:12 UTC