Previous Thread
Next Thread
Print Thread
Page 7 of 14 1 2 5 6 7 8 9 13 14
#19466 - 09/28/04 08:05 PM Re: MacMAME 0.87b  
Joined: Jul 2000
Posts: 497
Brad Oliver Offline
Brad Oliver  Offline

MacMAME Author

Joined: Jul 2000
Posts: 497
Glendale, AZ
Quote:
Originally posted by hebbos:
I use XCode 1.5, I can see only one available target, does anyone know how to compile a "release" version, ie no debug info, no trace no whatever.
Switch the build style from Development to Deployment.

#19467 - 09/28/04 10:27 PM Re: MacMAME 0.87b  
Joined: Feb 2001
Posts: 141
Bakasama Offline
Member
Bakasama  Offline
Member

Joined: Feb 2001
Posts: 141
Quote:
Originally posted by arekkusu:
Hm, and these do exist in your tree? (they should)

I don't know what to say-- works fine here. You're not using UFS or something else funny, are you? (building over a network...?)
This puzzle me too, MacMAME 84 compiles just fine and 87b doesn't. The files are do exist but the just the headers and includes seem to be messed up. It seems like I have to disable all vector games just to compile this. I actually wouldn't be suprised if the next release "magically" fixes the problem.

#19468 - 09/29/04 12:36 AM Re: MacMAME 0.87b  
Joined: Oct 2001
Posts: 10
syndicman Offline
Junior Member
syndicman  Offline
Junior Member

Joined: Oct 2001
Posts: 10
Paris
Quote:
Originally posted by Brad Oliver:
I'm in the process of setting up a public Subversion server.
Great news ! (I love typing svn update in the shell cool )

And thanks for this wonderfull MacMAME version wink


syndicman - mac-emu.net
#19469 - 09/29/04 01:19 AM Re: MacMAME 0.87b  
Joined: Jul 2003
Posts: 487
seanraaron Offline
Senior Member
seanraaron  Offline
Senior Member

Joined: Jul 2003
Posts: 487
Glasgow, Scotland
I looked into this, and it turns out there was one line of code missing that caused the overlay textures read from disk to essentially be random values (could be all black, in which case you'd not see any game.) The built-in default overlay pattern ought to work-- if it's not, please tell me.

^^^^^^

Sorry I was mixing terminology. The OpenGL overlay works fine -- what does not work fine is trying to use any artwork (like Battlezone overlay or backglass artwork files). When I try to play a game with Artwork enabled where there is a corresponding file I just get a giant mess like a b&w tv set with a badly tuned channel, but no discernable game image.


Sean Aaron
#19470 - 09/29/04 01:46 AM Re: MacMAME 0.87b  
Joined: Feb 2004
Posts: 312
arekkusu Offline
Senior Member
arekkusu  Offline
Senior Member

Joined: Feb 2004
Posts: 312
Santa Clara, CA
Hm, the artwork works fine for me here. But I'll have access to an old Rage 128 iMac later this week, so I'll take a look at it there.

#19471 - 09/29/04 02:36 PM Re: MacMAME 0.87b  
Joined: Feb 2004
Posts: 312
arekkusu Offline
Senior Member
arekkusu  Offline
Senior Member

Joined: Feb 2004
Posts: 312
Santa Clara, CA
Quote:
Originally posted by arekkusu:
Any game that uses the ZN security chip will hang after loading.
I compared with the DOS build and, with help from R.Belmont and smf , ZN games now work with this patch . Hooray!

I tried DOA++ and it runs now, although the graphics are glitchy.

#19472 - 09/29/04 03:53 PM Re: MacMAME 0.87b  
Joined: Feb 2004
Posts: 270
John Hood Offline
Senior Member
John Hood  Offline
Senior Member

Joined: Feb 2004
Posts: 270
UK
Quote:
Originally posted by arekkusu:
Quote:
Originally posted by arekkusu:
[b] Any game that uses the ZN security chip will hang after loading.
I compared with the DOS build and, with help from R.Belmont and smf , ZN games now work with this patch . Hooray!

I tried DOA++ and it runs now, although the graphics are glitchy. [/b]
Excellent.

#19473 - 09/30/04 12:41 AM Re: MacMAME 0.87b  
Joined: Dec 2001
Posts: 233
Isaac Offline
Senior Member
Isaac  Offline
Senior Member

Joined: Dec 2001
Posts: 233
San Antonio, TX
The Capcom ZN-1/2, Taito FX-1, Tecmo ZN-1, and the Video System ZN-1 work now. I also tried Primal Rage 2 and that Boots up. Judge Dredd gives an HDLoad Error but thats probably normal.


Man, the RDF is so strong, it's now bending light!
#19474 - 09/30/04 02:23 AM Re: MacMAME 0.87b  
Joined: Nov 2003
Posts: 803
smf Offline
Senior Member
smf  Offline
Senior Member

Joined: Nov 2003
Posts: 803
Quote:
Originally posted by Fast Cash:
The Capcom ZN-1/2, Taito FX-1, Tecmo ZN-1, and the Video System ZN-1 work now. I also tried Primal Rage 2 and that Boots up. Judge Dredd gives an HDLoad Error but thats probably normal.
Judge Dredd should boot up to attract mode, you should even be able to start a game but the guns aren't hooked up yet.

Primal Rage 2 on the other hand isn't particularly happy about running well.

smf

#19475 - 09/30/04 07:55 AM Re: MacMAME 0.87b  
Joined: Feb 2004
Posts: 312
arekkusu Offline
Senior Member
arekkusu  Offline
Senior Member

Joined: Feb 2004
Posts: 312
Santa Clara, CA
Quote:
Originally posted by seanraaron:
When I try to play a game with Artwork enabled where there is a corresponding file I just get a giant mess like a b&w tv set with a badly tuned channel, but no discernable game image.
So, this looks like an out of memory error. On an 8 meg Rage 128, if the display is set to 1024x768 and the game is large (like any vector game) then the texture creation fails. If you play a smaller game with artwork (like, 1942) or set the display to Thousands of colors, or lower the display resolution, then it works. Can you confirm this happens for you too?

Page 7 of 14 1 2 5 6 7 8 9 13 14

Who's Online Now
3 registered members (Reznor007, Heihachi_73, 1 invisible), 16 guests, and 4 spiders.
Key: Admin, Global Mod, Mod
Shout Box
Forum Statistics
Forums9
Topics8,411
Posts108,903
Members4,757
Most Online225
May 26th, 2014
Powered by UBB.threads™ PHP Forum Software 7.6.0
Page Time: 0.033s Queries: 14 (0.012s) Memory: 5.0321 MB (Peak: 5.2502 MB) Zlib enabled. Server Time: 2017-09-20 21:56:16 UTC