Previous Thread
Next Thread
Print Thread
Page 1 of 2 1 2
#24589 - 11/12/06 09:11 AM Patch for 0.110u1  
Joined: Mar 2001
Posts: 15,654
R. Belmont Offline
R. Belmont  Offline

Very Senior Member

Joined: Mar 2001
Posts: 15,654
USA
Here are 2 new source files for 0.110u1. On the Mac only it should speed up OpenGL, significantly on Intel Macs using the GMA950 graphics chip (ie, Intel Minis) and maybe a tick or 2 on others.

There's a very good chance that some games will show in funky colors with this patch - if that occurs, please tell me which game(s).

Last edited by R. Belmont; 11/12/06 10:52 AM.
#24590 - 11/12/06 10:21 AM Re: Patch for 0.110u1 [Re: R. Belmont]  
Joined: Jul 2006
Posts: 99
r0ni Offline
Member
r0ni  Offline
Member

Joined: Jul 2006
Posts: 99
Detroit, MI
I think you posted the wrong link...

and now I see you fixed it wink

Last edited by r0ni; 11/12/06 12:47 PM.

SDLMAME OSX Intel Builds: http://sdlmame.lngn.net/
#24635 - 11/14/06 02:14 AM Re: Patch for 0.110u1 [Re: r0ni]  
Joined: Nov 2006
Posts: 52
Numbski Offline
Member
Numbski  Offline
Member

Joined: Nov 2006
Posts: 52
Hmm...this fails to build for me, though I can't say that it's due to the patch for sure.

I'm on an intel mac mini, and I get a long string of cpu build failures. Note that I build SDL apps relatively often, and I do indeed have the frameworks installed along with the latest XCode Tools.

The errors overflow my scrollback buffer in iTerm, but here's a sampling. They all seem be be building the same cpu core:

obj/mamepp/cpu/m68000/m68kops.c: In function 'm68k_op_unpk_16_mm_axy7':
obj/mamepp/cpu/m68000/m68kops.c:34508: error: 'CPU_TYPE' undeclared (first use in this function)
obj/mamepp/cpu/m68000/m68kops.c:34510: error: 'uint' undeclared (first use in this function)
obj/mamepp/cpu/m68000/m68kops.c:34510: error: parse error before 'src'
obj/mamepp/cpu/m68000/m68kops.c:34513: error: 'src' undeclared (first use in this function)
obj/mamepp/cpu/m68000/m68kops.c:34514: error: 'ea_dst' undeclared (first use in this function)
obj/mamepp/cpu/m68000/m68kops.c: In function 'm68k_op_unpk_16_mm':
obj/mamepp/cpu/m68000/m68kops.c:34526: error: 'CPU_TYPE' undeclared (first use in this function)
obj/mamepp/cpu/m68000/m68kops.c:34529: error: 'uint' undeclared (first use in this function)
obj/mamepp/cpu/m68000/m68kops.c:34529: error: parse error before 'src'
obj/mamepp/cpu/m68000/m68kops.c:34532: error: 'src' undeclared (first use in this function)
obj/mamepp/cpu/m68000/m68kops.c:34533: error: 'ea_dst' undeclared (first use in this function)
make: *** [obj/mamepp/cpu/m68000/m68kops.o] Error 1

#24636 - 11/14/06 02:20 AM Re: Patch for 0.110u1 [Re: R. Belmont]  
Joined: Jul 2006
Posts: 5
kineox Offline
Junior Member
kineox  Offline
Junior Member

Joined: Jul 2006
Posts: 5
France
Originally Posted By R. Belmont
Here are 2 new source files for 0.110u1. On the Mac only it should speed up OpenGL, significantly on Intel Macs using the GMA950 graphics chip (ie, Intel Minis) and maybe a tick or 2 on others.

There's a very good chance that some games will show in funky colors with this patch - if that occurs, please tell me which game(s).

Great improve on the Macbook too (of course, it's the same GPU).

rsgun shows funky colors.

#24657 - 11/14/06 09:35 AM Re: Patch for 0.110u1 [Re: kineox]  
Joined: Sep 2006
Posts: 124
nitrousoxide82 Offline
Senior Member
nitrousoxide82  Offline
Senior Member

Joined: Sep 2006
Posts: 124
Rio de Janeiro, Brazil
All Neo-Geo games have the so-called "funky colors". Saved snapshots have correct colors. By the way, this is on Linux with the latest NVIDIA binary driver (96.29). Here:
Screen:

F12-snap:


Off-topic: By the way, the old 16 bpp desktop issue seems to have been fixed. It's working (except for these "funky colors" games) as expected (and as Windows MAME does).

Last edited by nitrousoxide82; 11/14/06 09:39 AM.
#24660 - 11/14/06 11:31 AM Re: Patch for 0.110u1 [Re: nitrousoxide82]  
Joined: Mar 2001
Posts: 15,654
R. Belmont Offline
R. Belmont  Offline

Very Senior Member

Joined: Mar 2001
Posts: 15,654
USA
Thanks for the helpful reports and pictures, guys!

This new patch supercedes the previous one and it fixes the funky colors in NeoGeo and ST-V games (among others) for both the Mac and PC.

Numbski: Try and get the errors from the very beginning of the trace, it's clear something's horribly wrong with your setup, but I can't tell from that snippet.

Last edited by R. Belmont; 11/15/06 10:19 PM.
#24669 - 11/14/06 07:02 PM Re: Patch for 0.110u1 [Re: R. Belmont]  
Joined: Jul 2006
Posts: 56
Dryer Lint Offline
Junior Member
Dryer Lint  Offline
Junior Member

Joined: Jul 2006
Posts: 56
I had the same color problems earlier, it was this what I mentioned in the other thread! It was on SVC and also on Puyo Puyo 2 (the purple and red puyos were almost indistinguishable) and Haunted Castle. But I can't reproduce it anymore, but it's all good, I don't exactly miss those colors. smile

Now with the patch everything seems to be working fine!

#24676 - 11/14/06 10:49 PM Re: Patch for 0.110u1 [Re: Dryer Lint]  
Joined: Nov 2006
Posts: 52
Numbski Offline
Member
Numbski  Offline
Member

Joined: Nov 2006
Posts: 52
RBelmont - yeah, something was wrong. Haven't hunted it down yet. I don't know how familiar you are with the Mac, but I have fink loaded, and most of my build tools are installed by fink as a result (gcc - actually ccache, make, libtool, etc). Well, /sw/bin/make died. For grins, I tried /usr/bin/make (apple's make) and it worked fine. Very odd, considering it was still using mostly fink's environment. Hmm.

Anyhoo, false alarm, misconfig on my end. :\

#24678 - 11/14/06 11:14 PM Re: Patch for 0.110u1 [Re: Numbski]  
Joined: Mar 2001
Posts: 15,654
R. Belmont Offline
R. Belmont  Offline

Very Senior Member

Joined: Mar 2001
Posts: 15,654
USA
Ahh. I know about Fink, but I don't have much installed from it since OS X is a pretty comfy Unix environment out of the box :-)

#24684 - 11/15/06 01:37 PM Re: Patch for 0.110u1 [Re: R. Belmont]  
Joined: Sep 2006
Posts: 124
nitrousoxide82 Offline
Senior Member
nitrousoxide82  Offline
Senior Member

Joined: Sep 2006
Posts: 124
Rio de Janeiro, Brazil
Link to the patch is broken - it's redirecting me to Google!

Page 1 of 2 1 2

Moderated by  R. Belmont 

Who's Online Now
3 registered members (AJR, mixmaster, 1 invisible), 25 guests, and 3 spiders.
Key: Admin, Global Mod, Mod
Shout Box
Forum Statistics
Forums9
Topics8,381
Posts108,462
Members4,750
Most Online225
May 26th, 2014
Powered by UBB.threads™ PHP Forum Software 7.6.0
Page Time: 0.110s Queries: 15 (0.064s) Memory: 5.0151 MB (Peak: 5.2432 MB) Zlib enabled. Server Time: 2017-07-20 22:30:06 UTC