Page 2 of 486 < 1 2 3 4 485 486 >
Topic Options
#44687 - 09/13/08 04:31 PM Re: SVN builds - new driver flood [Re: R. Belmont]
Heihachi_73 Offline
Senior Member

Registered: 08/30/02
Posts: 328
Loc: Melbourne, Australia
Speaking of Master Systems, can someone test Bank Panic on their end? It seems to be broken on all versions except smsj. CRC of the tested ROM image is B4DFB825; works with Meka's built-in BIOS (unless it's just a 'watch the SEGA logo' before the game starts), and in Dega.

Tested in MESS 0.126 with the v1.3, Hang-on and Alex Kidd BIOS sets, both NTSC and PAL.

Top
#44688 - 09/13/08 05:41 PM Re: SVN builds - new driver flood [Re: Heihachi_73]
R. Belmont Offline

Very Senior Member

Registered: 03/17/01
Posts: 15435
Loc: USA
Maybe it's a Japanese-region cart? Non-MESS emulators tend to skip region checks.

Top
#44689 - 09/13/08 06:41 PM Re: SVN builds - new driver flood [Re: R. Belmont]
mattmess Offline
Member

Registered: 02/26/07
Posts: 13
Loc: Brasil
Bank Panic in Japan only for SG-1000.
The Master System cartridge was never released there, AFAIK.

And speaking of Master III again... Aren't the Masters from Tec Toy different from the others? They use PAL-M, not PAL. The games run faster on PAL-M.


Edited by mattmess (09/13/08 06:45 PM)

Top
#44690 - 09/13/08 07:48 PM Re: SVN builds - new driver flood [Re: mattmess]
Heihachi_73 Offline
Senior Member

Registered: 08/30/02
Posts: 328
Loc: Melbourne, Australia
Looks like the version I've had for years is a bad dump. The [a1] set works fine. Old set is now exterminated!

Update (prior to posting) - Strangely though, the only differences in both ROMs were the last two bytes at 0x7FFE - 2020 (old version) versus 004C (a1 version).

Top
#44704 - 09/14/08 09:53 AM Re: SVN builds - new driver flood [Re: Anna Wu]
Anna Wu Offline
Very Senior Member

Registered: 07/28/07
Posts: 4572
SVN 3254
Windows binary
GUI
Properties - Miscellaneous

It seems one checkbox is superimposed .


_________________________
Anna's Playground for QMC2

Top
#44705 - 09/14/08 10:04 AM Re: SVN builds - new driver flood [Re: Heihachi_73]
judge Offline
Very Senior Member

Registered: 04/13/04
Posts: 1549
Originally Posted By Heihachi_73
Speaking of Master Systems, can someone test Bank Panic on their end? It seems to be broken on all versions except smsj. CRC of the tested ROM image is B4DFB825; works with Meka's built-in BIOS (unless it's just a 'watch the SEGA logo' before the game starts), and in Dega.

Tested in MESS 0.126 with the v1.3, Hang-on and Alex Kidd BIOS sets, both NTSC and PAL.


Together with your next post this sounds like a checksum issue. The japanese bioses never calculate and match the checksums reported by a cartridge. The old sg1000 games did not have the checksum byte in their headers, so to keep backwards compatible sega removed the checksum checking from the japanese bios code. The euro and us bioses do calcuate and check the checksum however.

So, the sg1000 image that works on a euro/us bios is actually a checksum-fixed version of the original rom image.


Top
#44714 - 09/15/08 09:34 AM Re: SVN builds - new driver flood [Re: Anna Wu]
Anna Wu Offline
Very Senior Member

Registered: 07/28/07
Posts: 4572
SVN 3266

Othello Multivision driver

ROM check : not found
Maybe need change to : None required like for SG-1000

Othello Multivision cartridges are working with omv driver.


Edited by Anna Wu (09/15/08 09:36 AM)
_________________________
Anna's Playground for QMC2

Top
#44716 - 09/15/08 09:53 AM Re: SVN builds - new driver flood [Re: Anna Wu]
etabeta78 Offline
Very Senior Member

Registered: 01/27/06
Posts: 3684
Loc: Trondheim, Norway
No, as you can see in the source, a BIOS is possibly missing because no omv unit has been dumped yet. The message is correct.

Top
#44717 - 09/15/08 09:59 AM Re: SVN builds - new driver flood [Re: Anna Wu]
Anna Wu Offline
Very Senior Member

Registered: 07/28/07
Posts: 4572
r3261
[JUPITER] Fixed regression; driver works again.

I can load game cartridges (.ace), but i am not able after loading to start/control with the keyboard (Joystick is not available). Is this ok ?
Made a double check with the EightyOne emu, here i can start all my .ace files.

Another question :
The device view show me " Cartridge " for files with the .ace extension.
Other websites and emulators call this format "snapshot".
MESS not show me the device view for snapshots. Why ?


Edited by Anna Wu (09/15/08 10:57 AM)
_________________________
Anna's Playground for QMC2

Top
#44718 - 09/15/08 10:04 AM Re: SVN builds - new driver flood [Re: etabeta78]
Anna Wu Offline
Very Senior Member

Registered: 07/28/07
Posts: 4572
Originally Posted By etabeta78
No, as you can see in the source, a BIOS is possibly missing because no omv unit has been dumped yet. The message is correct.


Has the original SG-1000 a bios ? If yes, why no required compare to omv ?


Edited by Anna Wu (09/15/08 11:00 AM)
_________________________
Anna's Playground for QMC2

Top
Page 2 of 486 < 1 2 3 4 485 486 >

Who's Online
1 registered (seanriddle), 12 Guests and 4 Spiders online.
Key: Admin, Global Mod, Mod
Shout Box

Forum Stats
4,719 Registered Members
9 Forums
8,258 Topics
106,640 Posts

Most users ever online: 225 @ 05/26/14 05:34 PM