Page 35 of 35 < 1 2 33 34 35
Topic Options
#106462 - 07/10/16 03:05 AM Re: Can't compile latest MESS? READ THIS THREAD [Re: Just Desserts]
Robbbert Offline
Very Senior Member

Registered: 08/20/04
Posts: 1297
works for me...

'rm' is an unknown command on my system. Perhaps you could try 'rd /s/q build' instead.

Top
#106478 - 07/11/16 08:08 AM Re: Can't compile latest MESS? READ THIS THREAD [Re: Just Desserts]
Edstrom Offline
Senior Member

Registered: 08/11/15
Posts: 294
I checked out an earlier SHA at 0175+ somewhere and there it works fine. I haven't had the time to track down exact where the problem started, it seems to be a clean build that is the problem and changes has been made in both build system and around the avi recorder. I suspect a missing dependency of some sort
_________________________
https://frakaday.blogspot.se/

Top
#106626 - 07/25/16 07:01 PM Re: Can't compile latest MESS? READ THIS THREAD [Re: Just Desserts]
xinyingho Offline
Member

Registered: 12/22/13
Posts: 81
I'm trying to compile MAME (master branch as of today) with Visual Studio 2015 Update 3 on Windows 10/64-bit.

I've downloaded the official MingW pack and launched "make vs2015 PYTHON_EXECUTABLE=c:/msys64/mingw64/bin/python.exe" to generate the default VS project file. Then I launched mame.vln, changed the config to Debug/x64, and ran Build.

The build command always raised this error:
LNK1210 exceeded internal ILK size limit; link with /INCREMENTAL:NO

Is there a way to fix this?

Edit: I don't get this error when selecting Debug/Win32. It shouldn't be a RAM issue as I have 16 GB of RAM on my computer. But then I don't know how to raise the internal ILK size limit.


Edited by xinyingho (07/25/16 08:20 PM)
_________________________
www.babelsoft.net/products/negatron.htm

Top
#107368 - 09/21/16 03:26 PM Re: Can't compile latest MESS? READ THIS THREAD [Re: Just Desserts]
Breiztiger Offline
Member

Registered: 11/01/10
Posts: 59
Loc: Rennes (35) FRANCE
hi

i get that error with last svn when i try to build it

1 [main] make (1544) S:\msys64\usr\bin\make.exe: *** fatal error - cygheap base mismatch detected - 0x1802FE408/0xE5E408.
This problem is probably due to using incompatible versions of the cygwin DLL.
Search for cygwin1.dll using the Windows Start->Find/Search facility
and delete all but the most recent version. The most recent version *should*
reside in x:\cygwin\bin, where 'x' is the drive on which you have
installed the cygwin distribution. Rebooting is also suggested if you
are unable to find another cygwin DLL.
2 [main] make 1572 fork: child -1 - forked process 1544 died unexpectedly, retry 0, exit code 0xC0000142, errno 11
make: fork: Resource temporarily unavailable
make: *** Waiting for unfinished jobs....

i have made a good build on 15 september

what can i modify to succes building mame again ?

thanks in advance


Edited by Breiztiger (09/21/16 03:26 PM)

Top
#108353 - 01/05/17 05:38 PM Re: Can't compile latest MESS? READ THIS THREAD [Re: Just Desserts]
Breiztiger Offline
Member

Registered: 11/01/10
Posts: 59
Loc: Rennes (35) FRANCE
hi

another error with gcc 6.2

In file included from S:/src/mame/3rdparty/bx/include/bx/simd_t.h:364:0,
from S:/src/mame/3rdparty/bx/include/bx/float4x4_t.h:9,
from S:/src/mame/3rdparty/bgfx/src/bgfx_p.h:129,
from ../../../../../3rdparty/bgfx/src/bgfx.cpp:13:
S:/src/mame/3rdparty/bx/include/bx/simd256_avx.inl:41:23: error: 'simd256_avx_t_t' does not name a type
BX_SIMD_FORCE_INLINE simd256_avx_t_t simd_splat(float _a)
^~~~~~~~~~~~~~~
S:/src/mame/3rdparty/bx/include/bx/simd256_avx.inl:47:23: error: 'simd256_avx_t_t' does not name a type
BX_SIMD_FORCE_INLINE simd256_avx_t_t simd_isplat(uint32_t _a)
^~~~~~~~~~~~~~~
S:/src/mame/3rdparty/bx/include/bx/simd256_avx.inl:56:23: error: 'simd256_avx_t_t' does not name a type
BX_SIMD_FORCE_INLINE simd256_avx_t_t simd_itof(simd256_avx_t_t _a)
^~~~~~~~~~~~~~~
S:/src/mame/3rdparty/bx/include/bx/simd256_avx.inl:65:23: error: 'simd256_avx_t_t' does not name a type
BX_SIMD_FORCE_INLINE simd256_avx_t_t simd_ftoi(simd256_avx_t_t _a)
^~~~~~~~~~~~~~~

last good build i've made from 01/01/2017

i use this for option
set _OptCompil=TOOLS=1 OPTIMIZE=3 -j6 USE_NETWORK=1 ARCHOPTS="-march=native -msse4.2"

thanks in advance


Edited by Breiztiger (01/05/17 06:03 PM)

Top
#108357 - 01/06/17 08:10 AM Re: Can't compile latest MESS? READ THIS THREAD [Re: Just Desserts]
Breiztiger Offline
Member

Registered: 11/01/10
Posts: 59
Loc: Rennes (35) FRANCE
hi

with only TOOLS=1 in compil option gcc build lastest sources

sorry

Top
Page 35 of 35 < 1 2 33 34 35

Who's Online
1 registered (seanriddle), 12 Guests and 4 Spiders online.
Key: Admin, Global Mod, Mod
Shout Box

Forum Stats
4,719 Registered Members
9 Forums
8,258 Topics
106,640 Posts

Most users ever online: 225 @ 05/26/14 05:34 PM