Thread Like Summary
Just Desserts
Total Likes: 1
Original Post (Thread Starter)
#119198 05/17/2021 11:37 AM
by retrolou
retrolou
Hi,
Was wondering if anyone has come across snes not working on Mame running on a raspberry pi? I have the snes bios (tries as snes folder or snes.zip) The same roms work on the same pi inside Retroarch. The same roms also work on mame running on x86/64 linux as well. I have tried numerous bios, also have tried mame 32bit, 64bit. Have tested numerous mame versions (.185, .196, .213, .225, .228, .230) Also have tried raspberry pi 32bit and 64bit. Its very strange. The behavior i am seeing is when the rom launches I get one of 2 scenarios based on the rom itself.
1. Solid black screen showing with the bezel
2. Initially get a Nintendo Logo, then black screen with the bezel like in #1.

The same behaviors happen if I run either from the Mame UI or straight from cli

This happens in every snes rom I have tried on the pi using mame. Other systems like NES, Sega and reg Arcade have no issues. Any thoughts ideas?
Liked Replies
by kmg
kmg
Hey retrolou, it's manna from heaven! This patch from plgDavid seems to have fixed the problem with MAME's snes driver on Pi—and it looks like he was trying to fix something else outside of MAME! The patch has been integrated so either get the next release, 0.234, at the end of the month or grab the latest tree if you want to test it out.
1 member likes this
Who's Online Now
1 members (Dorando), 20 guests, and 1 robot.
Key: Admin, Global Mod, Mod
ShoutChat
Comment Guidelines: Do post respectful and insightful comments. Don't flame, hate, spam.
Forum Statistics
Forums9
Topics9,071
Posts118,945
Members5,014
Most Online890
Jan 17th, 2020
Our Sponsor
These forums are sponsored by Superior Solitaire, an ad-free card game collection for macOS and iOS. Download it today!

Superior Solitaire
Forum hosted by www.retrogamesformac.com