Thread Like Summary
mochamame
Total Likes: 1
Original Post (Thread Starter)
#121043 06/20/2022 5:55 PM
by Vas Crabb
Vas Crabb
I’m not overly familiar with the Mac drivers, so I’m not sure if this is me doing something wrong, known limitations, or bugs.

If I try running Mac II booted from a hard disk with two hard disks connected, ADB locks up after the desktop appears. For example if I use this command, the mouse/keyboard won’t respond after the desktop appears:
Code
mamed macii -ui_active -nb9 spec8s3 -hard1 mac711 -scsi:2 harddisk -hard2 SuperMac.hdv

However, if I boot from a floppy, I can browse both hard disks and copy files between them without ADB locking up. For example, this works:
Code
mamed macii -ui_active -nb9 spec8s3 -hard1 mac711 -scsi:2 harddisk -hard2 SuperMac.hdv -flop mac_flop:sys608

I occasionally get stuck keys, so I guess this is just ADB HLE weirdness?

Weirder than that though is that System 7.1 doesn’t see some files on the hard disk while System 6 does.

With that previous command (booting from System 6.0.8 on floppy with the System 7.1.1 Pro hard disk attached), I can see the PowerTalk Folder, System 7 Pro Read Me folder, TeachText, etc. as well as any other stuff I add myself.

However, if I boot from System 7 itself, I only see the System Folder in the root folder of the hard disk. For example this only shows the System Folder:
Code
mamed macii -ui_active -nb9 spec8s3 -hard1 mac711

I tried rebuilding the desktop file on the hard disk, but it didn’t improve the situation.

This was all with debug builds, I haven’t tried a release build. Is there something I’m doing wrong?
Liked Replies
#121053 Jun 23rd a 11:13 AM
by Vas Crabb
Vas Crabb
Originally Posted by mochamame
Just playing around with this on Linux with Mame 0.243.

$ mame macii mac711 -window -ramsize 8M -effect none -video opengl -nomaximize -nounevenstretch -nb9 48gc -nba cb264 -nbb cb264 -nbc cb264 -noautosave

This boots up with 4 monitors like R. Belmont was saying (I assume this is what you meant by "a 48gc and 3 cb264s"). The 48gc card can be put into a color mode with no problem. Mame crashes as soon as I try to put any of the cb264 monitors into a color mode.

Ignoring MAME exception: cb264: unknown video mode 50529027

Fatal error: cb264: unknown video mode 50529027
Didn’t ArBee already fix that in master?
1 member likes this
Who's Online Now
1 members (judge), 25 guests, and 3 robots.
Key: Admin, Global Mod, Mod
ShoutChat
Comment Guidelines: Do post respectful and insightful comments. Don't flame, hate, spam.
Forum Statistics
Forums9
Topics9,103
Posts119,277
Members5,019
Most Online890
Jan 17th, 2020
Our Sponsor
These forums are sponsored by Superior Solitaire, an ad-free card game collection for macOS and iOS. Download it today!

Superior Solitaire
Forum hosted by www.retrogamesformac.com