Home Page
I'm finding this to be very tedious if at all successful. I've gotten (what I believe should be) the BIOS etc ROMS for a few models, and the machines boot (I'm working mainly with the XT5160), however the keyboard mappings are corrupted it seems, and i'm mired in 1701/601 hard drive failures, even when connecting with a blank chd file made with chdman. I can boot a few of the machines off a DOS 622 img floppy, but again, with the mangled keyboard mappings, there's little I can do. If anyone has any advice at all, I'd appreciate it a lot.

(I also have another topic on getting a hard drive made out of a folder containing a file for file copy dump, but this should probably be my starting point)

thanks in advance.
If you pick one that is marked as working, it will boot off a hard drive chd (containing an operating system).

Some old-school dos games will work (such as Alley Cat, and Lemmings CGA version).

Don't attempt to run Windows in the emulation, not only does it have issues, but it can corrupt your chd.
I was able to boot the ibm5150 from floppy, but not the ibm5160...
The ibm5160 booted into the BASIC ROM instead, even though the floppy was enabled.
I don't have a boot floppy, always used hard drives.
Just tried booting from a floppy (dos 3.3 and king's quest 1) and they both worked in ibm5160.

Keyboard is working fine too. Try deleting any old .cfg files you might have.
Originally Posted By judge
Just tried booting from a floppy (dos 3.3 and king's quest 1) and they both worked in ibm5160.

Keyboard is working fine too. Try deleting any old .cfg files you might have.


I deleted the config files, and retried with rev 5416 and rev 7596 on Linux x86 and Mac OS ppc. On both, ibm5150 booted fine from floppy, ibm5160 booted to rom basic with the same floppy inserted (MS Dos 3.3, 5 1/4 360k DSDD, .img format)
I generally have more success with the generic "pc" driver than with the IBM models.
Since Judge's rework, it's actually the opposite for me - the genuine IBMs are more reliable for me than the clones. On older MESSes, the reverse was certainly true though.
Thanks for all the helpful input folks. For the record, I'm just trying to get past keyboard issues at this point. I'll worry about the hard drive issues after that. I'm using a Dell laptop (e6500) however, I've run a fair amount of other emulators and VMs with no issues character mapping, and it's a standard qwerty keyboard. Windows 7, and I've tried both mess 0131 and 0137.

Here's an example. This is starting the generic pc-cga (the one I get the farthest with,) loading a DOS622 floppy with no hard drive. At the prompt, I'm typing "help me please!!!" I think this goes beyond mapping and into basic hw interpretation!



I should also mention that I've tried both natural and emulation keyboard modes, and the Input maps seem to match up as best they can. Also, the trash-80 (as my brother called them when we were kids) works just fine, so it seems to be limited to the IBM PCs. I'll try getting rid of some .cfg files, maybe give it a shot in XP as well.

Another question - could this be cause by having bad / incorrect ROMS? I've found two lists on the web that I've been grabbing from. I'm not sure if they're MESS version specific or not.

and for the record as far as copyrighting goes, my original IBM 5160 is sitting in my basement, albeit not working, but I own it nonetheless, so there! cool
update - keyboard's working in XP on a desktop...now to get a hard drive to be recognized!
That's interesting - HIMEM.SYS doesn't use protected mode that I'm aware of so it should work. Are we not emulating the A20 gate? smile
Well, A20 is a 286 feature and that's an 8088 driver so....
in the ibm5170 driver the a20 line should be driven correctly by the system board keyboard controller.
What was the keyboard problem?

I am struggling with the hard disk chd file.
I can't get fdisk to on the drive in the emulation, when I type fdisk, the cursor just drops down one line and blinks at me... frown
One likely possibility for the keyboard problem is that the driver has a .cfg file from back before the keytronic keyboard had its dipswitch set to the correct default. try deleting /cfg/ibm5160.cfg and try again with latest svn or latest release.

LN
I don't have a keyboard problem myself I was just curious.
I can't run fdisk to setup the hard disk, that's my problem... :-)
Sorry for my delay in getting back to people;

HIMEM.SYS was on the DOS startup floppy that I'm using. Not on purpose, just needed a command prompt on the machine to run fdisk.

As for the keyboard problem, it happened from time to time, but I found cleaning out the cfg files helped fix this most of the time.

As for the chd issues (Barry...) I never got it to work. After trying unsuccessfully to fdisk virtual drives I gave up, as it's been reported that MESS has problems with hard drive emulation for the IBM pcs. FDISK would run, create a partition, but upon reboot nothing stuck - back to square one. FDISK would also crash back to a prompt from time to time as well. Barry, if you ever get it working, i'd love to know!

pkemble(a t)gmail.com
© Forums