Home Page
Posted By: Sembei HLSL does not load parameters - 02/25/21 09:06 PM
hello, I am new to Mame and am having difficulty with HLSL. I don't understand what I'm doing wrong. I'm loading a game (Mushihime sama in this case). I press the key to bring up the parameters of HLSL. I have the mask which is displayed, I can adjust the strength, round the corners of the screen, blur the image etc ... Then I note all its parameters in the MAME.INI which is in the main folder MAME, I save the file and yet when I restart my game it doesn't work. The corners are not rounded none of the parameters are loaded. I read the documentation correctly but there is mention of arcade.ini (which I could not find anywhere in the file). I also saw that people on tutorials several years old were talking about raster.ini (I found it in the .ini folder) I changed the HLSL settings in it but it didn't change anything either. All the tutorials on the net are not clear or do not address the issue and the interfaces are completely different. Can you explain to me what I'm doing wrong. Thank you

I am using windows 10 with the latest version of mame
Posted By: R. Belmont Re: HLSL does not load parameters - 02/25/21 09:36 PM
The HLSL settings don't currently save. You can edit the .json files in bgfx\chains to set the defaults.
Posted By: Sembei Re: HLSL does not load parameters - 02/25/21 10:01 PM
"The HLSL settings don't currently save".

OK, so that means that you shouldn't change the settings in the mame.ini file ??? weird in all the advice it seemed to me that it said you have to manually change the settings in this file.

"You can edit the .json files in bgfx\chains to set the defaults."


I come in this file and as you can see it to my astonishment the setting of the corner rounding is on 0.5 [img]https://ibb.co/XCWMDp3[/img] (although I have not touched anything in this file) but in game it has absolutely no effect [img]https://ibb.co/6sWxTQz[/img]. Can you explain to me what is wrong?
Posted By: Robbbert Re: HLSL does not load parameters - 02/26/21 12:22 AM
Since you're using windows, there's 2 ways of using hlsl. The first is the old original way, that requires that you've installed directx9 from microsoft.

>mame <game> -hlsl

You make your slider adjustments, write them down and put them into the game's ini file. So, if you ran pacman, you'd enter the settings into ini\pacman.ini

The other way is to use bgfx

>mame <game> -video bgfx -bgfx_screen_chains hlsl

Again, make your adjustments, but this time the settings go into the .json files as R.Belmont said. See this link for more: https://docs.mamedev.org/advanced/bgfx.html
Posted By: Sembei Re: HLSL does not load parameters - 02/26/21 05:12 PM
Ah ... ok I finally succeeded today in showing the HLSL config on the games.

First of all, thank you for the leads you communicated to me.

For those who encounter the same difficulty as me, here is step by step how I proceeded.

I specify that I am on MAME 0.229.

1. I downloaded a clean archive of MAME from the official site.

2. I launched the MAME.EXE and saved my preferences to create the MAME.INI file which then appeared in the main folder.

3. I wrote down all my HLSL preferences by taking a photo of all the settings I wanted to change. (for the details of the activation see the documentation of MAME) (on the AZERTY keyboard it is not the key ~ but the key ²)

4.I have manually changed the HLSL settings in the MAME.INI file.

5. I copied the MAME.INI file and pasted it into the INI folder.

6. I renamed the MAME.INI file with the same name as the game zip file (not the real name of the game).

7. I launched the game and YES, it works !!!

I will continue to explore the intricacies of MAME.
I don't know if we have the possibility to mark the subject as resolved?
© Forums