Home Page

Macintosh OS X OpenGL Experience™

Posted By: M. Twitty

Macintosh OS X OpenGL Experience™ - 06/17/09 09:07 AM

RB or anyone, is there any way you're aware of to correct the half screen videodisc playback under opengl on an iMac with an X1600 card?

I'd be willing to take semi-extraordinary steps to get it working, but so far I haven't been able to figure it out, and my search for a solution has come up empty.

Thanks in advance.
Posted By: R. Belmont

Re: Macintosh OS X OpenGL Experience™ - 06/17/09 01:32 PM

Err, I disabled the APPLE YUV path ages ago and everyone agreed it fixed the problem? Does -video soft work?
Posted By: M. Twitty

Re: Macintosh OS X OpenGL Experience™ - 06/18/09 02:55 AM

-video soft displays the video correctly, albeit at about 1/10 speed. -video opengl displays the video at full speed, but only fills the left half of the screen.

The only LD game I have is Cube Quest, and I only noticed this problem when it was released. I posted about this a couple of months ago, but it wasn't critical at the time because I had access to a Windows box where it worked. But that box got repurposed into a server when my old server died.
Posted By: M. Twitty

Re: Macintosh OS X OpenGL Experience™ - 06/20/09 03:35 AM

Is there a version that has LD support which still had the YUV path enabled that I can use to test this? I have sources back to forever...

Thanks.
Posted By: will

Re: Macintosh OS X OpenGL Experience™ - 06/20/09 11:55 PM

Twitty, how about if you edit your mame.ini and change gl_vbo to 0 ?

See if that works. With APPLE YUV enabled, my Mac Pro with NVIDIA GeForce 8800 GT card didn't produce any OpenGL video at all for Cube Quest. With YUV disabled, it works fine both on my MacBook Pro ATI Mobility Radeon X1600 and the Mac Pro.

Not sure what's up with your iMac. Which OS are you running? I'm on 10.5.7. Have you done all the appropriate EFI, SMC and graphics firmware updates?
Posted By: M. Twitty

Re: Macintosh OS X OpenGL Experience™ - 06/21/09 03:33 AM

Tried gl_vbo 0 and I still get half-screen video.

My iMac is a white 20", 2.33GHz, core2duo running 10.5.7 with every available firmware update applied.

Thanks for the suggestion. I'll keep banging on it, and welcome any more advice (besides getting a new computer, of course).
Posted By: Vas Crabb

Re: Macintosh OS X OpenGL Experience™ - 06/21/09 03:45 AM

try turning off PBO
Posted By: R. Belmont

Re: Macintosh OS X OpenGL Experience™ - 06/21/09 06:39 AM

Will: that was because NVidia cards don't support APPLE_YUV, only ATI does.
Posted By: M. Twitty

Re: Macintosh OS X OpenGL Experience™ - 06/24/09 01:58 AM

Duh.

Prescale must be set to 1. I never use glsl and didn't think of prescale until I set glsl 1 and got the "OpenGL: GLSL supported, but disabled due to: prescale !=1" message.

So I now have full screen LD output, although a bit choppy.

Thanks to everyone for your help.
© 2019 Forums