Home Page
last time i used mame (quite a while back) this feature was not implemented, or at least was not default.
i poked around the options and mame's config file but can't find how to disable this behavior...
Posted By: R. Belmont Re: Disable autoloading save states? - 02/18/11 10:13 PM
I don't understand. Autoloading save states is something you explicitly have to enable, it doesn't happen by default.
Posted By: etabeta78 Re: Disable autoloading save states? - 02/18/11 10:25 PM
in mame.ini

autosave 0

double check that you don't have conflicting ini files somewhere
Posted By: echoes Re: Disable autoloading save states? - 02/18/11 10:51 PM
autosave is disabled guys. must be another config file somewhere, like etabeta78 said.
Posted By: echoes Re: Disable autoloading save states? - 02/18/11 11:10 PM
ok, there was a default ini shipped (that i was unaware of) apparently by the packager.

any how, i deleted that and it solved my autoloading of save states problem.

now, if i could only solve my cheats problem...

i have the latest version of pugsy's cheat file (cheat.zip {version 0.141} with the xml files in it) placed in my ~/.mame directory and the location is set properly in my mame.ini file and cheats are set to '1' yet they don't show up for a game i KNOW for a fact is supported.

i have read another report of cheats not working at all (not showing up in the menu) with 0.141. can anyone confirm this?

or perhaps something has changed regarding cheats i'm unaware of?
Posted By: Tafoid Re: Disable autoloading save states? - 02/18/11 11:27 PM
If you are pointing to the MAME directory for cheats, they will not be seen by default. I'm guessing you are setting your .ini "cheatpath" folder to "~/.mame" and not what is required "~/.mame/cheat" ? The cheat.zip acts like an additional CHEAT folder as it retains the folder structure it was compressed with.

Posted By: echoes Re: Disable autoloading save states? - 02/19/11 01:59 AM
Originally Posted By Tafoid
If you are pointing to the MAME directory for cheats, they will not be seen by default. I'm guessing you are setting your .ini "cheatpath" folder to "~/.mame" and not what is required "~/.mame/cheat" ? The cheat.zip acts like an additional CHEAT folder as it retains the folder structure it was compressed with.

i suspected that after a while but hadn't tried it yet. thank you Tafoid!

UPDATE:
i changed it to that path (the correct one) and it still doesn't work! cheats ARE enabled and the cheatpath is set to ~/.mame/cheat...
Posted By: Tafoid Re: Disable autoloading save states? - 02/19/11 02:50 AM
Try not giving it a literal location. Just try "cheat" and see if that helps. Is this other .ini you mentioned above possibly influencing the settings? Someone who is familiar with linux folder structure might need to help further.

Posted By: echoes Re: Disable autoloading save states? - 02/19/11 02:59 AM
Originally Posted By Tafoid
Try not giving it a literal location. Just try "cheat" and see if that helps. Is this other .ini you mentioned above possibly influencing the settings? Someone who is familiar with linux folder structure might need to help further.

no. i already mentioned that i deleted the other one. although, for future reference, my frontend (QMC2) does have (by default) some of the same settings in its own ini file as mame's ini which was confusing before i realized it. (and yes it is pointed to the correct path and cheats are enabled in QMC2's ini file).
after reading your suggestion, i remembered that my mame package (from the Packman repository) has a default directory structure (just like it has a default ini file):
Quote:
rpm -q -l mame
/etc/mame
/etc/mame/mame.ini <-- (this is the conflicting ini i deleted)
/usr/bin/mame
/usr/share/doc/packages/mame
/usr/share/doc/packages/mame/docs
/usr/share/doc/packages/mame/docs/config.txt
/usr/share/doc/packages/mame/docs/license.txt
/usr/share/doc/packages/mame/docs/mame.txt
/usr/share/doc/packages/mame/docs/newvideo.txt
/usr/share/doc/packages/mame/docs/windows.txt
/usr/share/doc/packages/mame/whatsnew.txt
/usr/share/mame
/usr/share/mame/artwork
/usr/share/mame/chds
/usr/share/mame/cheats
/usr/share/mame/crosshair
/usr/share/mame/ctrlr
/usr/share/mame/effects
/usr/share/mame/fonts
/usr/share/mame/keymaps
/usr/share/mame/roms
/usr/share/mame/samples
/usr/share/man/man6/mame.6.gz


if i take your suggestion, won't it just point it to the (empty) directory in bold above? (i keep the files that would go in those directories in my mame directory in ~/).
Posted By: echoes Re: Disable autoloading save states? - 02/19/11 03:26 AM
ok, finally got this squared away.
there were two problems.
first of all, even though my download of pugsy's mame cheat.zip (from his site) completed normally, it wasn't the right size.
i re-downloaded it, extracted the root zip file which solved the first problem.
the second problem was, i misunderstood Tafoid's comment of "The cheat.zip acts like an additional CHEAT folder as it retains the folder structure it was compressed with." which was stupid on my part. i thought he meant that cheat.zip now had to be placed in its own cheat folder in the mame directory (~/.mame/cheat).
after solving the first problem, i then realized what he meant and placed the cheat file in the mame root directory and i now have cheats working.
thanks for the help & pointers everyone.
Posted By: etabeta78 Re: Disable autoloading save states? - 02/19/11 05:45 AM
as a general rule of thumb (and for future reference), for MAME and MESS a zipfile is nothing else than a folder in disguise, and both emu treat zipfiles as directoryies for any needed access

this is the reason you can keep roms zipped in romset.zip or unzipped in a romset/ folder wink
© Forums