Home Page
Posted By: M. Twitty sdlmess Compile Problem... - 01/18/14 06:31 AM
I'm not actually sure where this goes, being as I compile sdlmess, but I'm hoping you can answer.

I haven't been able to compile sdlmess since 150, and I've just tried with svn and I'm getting:

Code:
In file included from src/mess/machine/p1_hdc.c:12:
src/mess/machine/p1_hdc.h:46:8: error: private field 'm_ram' is not used [-Werror,-Wunused-private-field]
        UINT8 m_ram[0x800];
              ^
1 error generated.
make: *** [obj/sdl64/mess/machine/p1_hdc.o] Error 1
make: *** Waiting for unfinished jobs....


I'm not sure if that's the same error I've been getting since 150, but that's where it's dying now. Is this me, or a known problem? I still have a working version, but I like to keep the programs in sync. So it's not a crisis, I was just wondering.

Thanks all.
Posted By: Osso Re: sdlmess Compile Problem... - 01/18/14 07:28 AM
In current SVN that line is commented out.
Posted By: R. Belmont Re: sdlmess Compile Problem... - 01/18/14 02:15 PM
Yeah, that was fixed a while ago in SVN, and I believe it was fixed prior to 0.152.
© Forums