Home Page
Posted By: retrolou mame on raspberry pi and snes - 05/17/21 11:37 AM
Hi,
Was wondering if anyone has come across snes not working on Mame running on a raspberry pi? I have the snes bios (tries as snes folder or snes.zip) The same roms work on the same pi inside Retroarch. The same roms also work on mame running on x86/64 linux as well. I have tried numerous bios, also have tried mame 32bit, 64bit. Have tested numerous mame versions (.185, .196, .213, .225, .228, .230) Also have tried raspberry pi 32bit and 64bit. Its very strange. The behavior i am seeing is when the rom launches I get one of 2 scenarios based on the rom itself.
1. Solid black screen showing with the bezel
2. Initially get a Nintendo Logo, then black screen with the bezel like in #1.

The same behaviors happen if I run either from the Mame UI or straight from cli

This happens in every snes rom I have tried on the pi using mame. Other systems like NES, Sega and reg Arcade have no issues. Any thoughts ideas?
Posted By: R. Belmont Re: mame on raspberry pi and snes - 05/17/21 12:11 PM
I assume this is a self-compile on a Pi 4? Barring a compiler bug, it should work just as it does on PC.
Posted By: retrolou Re: mame on raspberry pi and snes - 05/17/21 12:13 PM
Yes self compile and pi4b, but a buddy saw same behavior on 3 as well. I even cross compiled. But even the mame that gets installed by retropie shows the same behavior.
Posted By: retrolou Re: mame on raspberry pi and snes - 05/17/21 12:36 PM
On the pi itself, i compiled using this:
make -j3 NOWERROR=1 ARCHOPTS=-U_FORTIFY_SOURCE PYTHON_EXECUTABLE=python3

Cross compiled (which is amazing to knock off a lot of time, i used this:
https://stickfreaks.com/misc/cross-compile-mame-for-raspberry-pi
Posted By: kmg Re: mame on raspberry pi and snes - 05/17/21 07:20 PM
I noticed the same thing, retrolou. Sounds like you've done way more testing than what I tried though. FYI, I'm on Pi4 with 64-bit beta PiOS and self-compiled 0.231 (and it took forever with -j1 which I used after figuring out the GCC memory issue mentioned in your link!). Anyway, the few games I tried all did #1, black screen (I have no bezels). No other machine I've tried exhibits this behavior so far except SNES.

Side topic: have you had issues with sound completely stopping in MAME on the Pi? It seems for every system, regardless of what sound devices are being emulated, the sound completely ceases at some random point but the machine continues to run fine otherwise. I chalked it up to beta 64-bit OS (didn't happen on 32-bit OS) + self-compile + general Pi flakiness. The only thing I could see that might be related from -verbose and -log is sound buffer overflow/underflows. Not sure at what point overflow/underflow causes permanent breakage though.
Posted By: retrolou Re: mame on raspberry pi and snes - 05/17/21 11:21 PM
Glad to hear you see the same with snes. I have spoke to a fw others, and all see the same. But its not really mentioned anywhere i can see about how to fix it. No audio issues. I actually prefer the RPIOS 64bit. thats what I am using with a USB3 argon m.2 case. I wouldn't even try this on a SD card.. For my pi4 I have it really overclocked, as well as the mame.ini modded for lesser sample rate and video accel enabled/.
Posted By: retrolou Re: mame on raspberry pi and snes - 05/18/21 10:54 AM
Anyone have any ideas or config/tweaks to try?
Posted By: kmg Re: mame on raspberry pi and snes - 07/15/21 01:38 AM
Hey retrolou, it's manna from heaven! This patch from plgDavid seems to have fixed the problem with MAME's snes driver on Pi—and it looks like he was trying to fix something else outside of MAME! The patch has been integrated so either get the next release, 0.234, at the end of the month or grab the latest tree if you want to test it out.
© Forums