Home Page
Posted By: Carbon MAME doesn't recognise Apple 2 gs disks - 04/13/22 07:55 PM
I'm trying to load an Apple 2gs disk (.woz or .2mg). I'm using the -flop3 as they were 3.5" disks, but I always get the "Fatal error: Device 5.25" single density floppy drive load failed: Incompatible image format or corrupted data" error message. Why does MAME display Device 5.25" here?

I also tried with -flop1 through -flop4, with always the same result. The Apple // driver works fine.

Do I need to add a disk device on the command line? I'm on macOS 12.3.1 with the latest MAME (0.242).
What is your actual full command line?
Posted By: Carbon Re: MAME doesn't recognise Apple 2 gs disks - 04/13/22 09:38 PM
Found the problem: if I specify the complete path like this:
Code
./MAME apple2gs -flop3 /Applications/Emulation/MAME/Disks/Apple2gs/arkanoid2.woz
it doesn't work (I have MAME inside an Emulation folder inside my Applications folder; therein is a Disks folder with a folder for different systems, e.g. apple2gs for the Apple 2gs). But if I copy the file into the MAME folder, the following command line works:
Code
./MAME apple2gs -flop3 arkanoid2.woz
But it'd be nice not having to copy the image to the MAME folder.
Then you have a permissions error or something.
Posted By: Carbon Re: MAME doesn't recognise Apple 2 gs disks - 04/13/22 10:19 PM
Just verified: the current user has read/write access on all the files and folders, administrators only read access. After changing those to read/write, too, I'm still getting the same error when trying to access the images from the deeper nested folders.
And I just confirmed that MAME does mount floppies from arbitrary paths outside the current directory. So unless it’s a macOS-specific bug, which I kinda doubt as it’s pretty much identical code to Linux and ArBee would most likely have noticed by now, it’s something environmental on your system.
Arbitrary paths works for me on my Mac too. I did suspect briefly that could be a problem since both AJR and OG have been fiddling in those areas.
Posted By: Carbon Re: MAME doesn't recognise Apple 2 gs disks - 04/14/22 04:03 PM
Found out what was going on. In my first try to run a game with the Apple 2gs driver, I used the flop1 paramter (which expects an 5.25" disl) and also used an -inipath parameter. This changed the floppydisk1 line in the ini file, but never cleared it, even when I subsequently used the -flop3 parameter, so the first disk it encounters were effectively in the wrong format. when I omitted the -inipath, it worked. Here is an excerpt from the ini file:

Code
#
# IMAGE DEVICES
#
floppydisk1               "/Applications/Emulation/MAME/Disks/Apple2gs/Paintworks.zip/Arkanoid2.woz"
floppydisk2               
floppydisk3               "/Applications/Emulation/MAME/Disks/Apple2gs/Paintworks.zip/Paintworks.2mg"
floppydisk4               

As soon as I cleared the floppydisk1 parameter, everything worked as expected, even with the -inipath parameter present.

Thanks for your help.
© Forums