Previous Thread
Next Thread
Print Thread
Page 2 of 4 1 2 3 4
#14003 01/13/06 05:36 AM
Joined: May 1999
Posts: 576
Senior Member
Offline
Senior Member
Joined: May 1999
Posts: 576
I have updated my machine to Mac OS X 10.4.4 and Quicktime 7.0.4 with MacMAME 0.103u2 still running perfectly!

#14004 01/13/06 05:40 AM
Joined: Dec 2005
Posts: 6
D
Member
Offline
Member
D
Joined: Dec 2005
Posts: 6
Quote:
Originally posted by Bakasama:
After I updated the following on my Mac that runs 10.3.9 with:

QuickTime 7.0.4
iTunes 6.0.2
Bakasama, since you're (also) running 10.3.9, check something if you would: open Disk Utlity and try to repair your permissions. There appears to be a problem with iTunes 6.0.2 running on 10.3.9, where Disk Utility crashes out partway through the permission repair, referencing something in the iTunes package, the "i386" architecture, and "can't byteswap it".

Downgrading iTunes to 6.0.1 again solved that problem, and the newest MacMAME runs fine for me with that and QT7.0.4 installed.


Dave H.
#14005 01/13/06 08:08 AM
Joined: Feb 2004
Posts: 2,217
Likes: 5
Very Senior Member
Online Content
Very Senior Member
Joined: Feb 2004
Posts: 2,217
Likes: 5
Can confirm the problem happens for me with QT7.0.4 on Mac OS X 10.3.9, but didn't happen before I updated Quicktime. PITA, as QT7.0.4 fixes a security vulnerability.

Note that this doesn't only affect the newest MacMAME. Older versions crash as well.

#14006 01/14/06 02:06 AM
Joined: Jul 2000
Posts: 497
MacMAME Author
Offline
MacMAME Author
Joined: Jul 2000
Posts: 497
Quote:
Originally posted by rp:
Same problem. From console.app:


dyld: /Users/********/Applications/MacMAME/MacMAME.app/Contents/MacOS/MacMAME multiple definitions of symbol __ZSt17__throw_bad_allocv
/Users/********/Applications/MacMAME/MacMAME.app/Contents/MacOS/MacMAME definition of __ZSt17__throw_bad_allocv
/usr/lib/libstdc++.6.dylib(single module) definition of __ZSt17__throw_bad_allocv
Is everyone who has this problem running 10.3.9 or are some of you using a version of 10.4?

#14007 01/14/06 03:35 AM
Joined: May 2005
Posts: 5
L
Junior Member
OP Offline
Junior Member
L
Joined: May 2005
Posts: 5
I was using 10.3.9 when it started. I recently upgraded to 10.4.4 and after that it still wasn't working. Then as a previous member suggested, I trashed the prefs file, and it seemed to run fine.

#14008 01/14/06 04:15 AM
Joined: Aug 2001
Posts: 26
Senior Member
Offline
Senior Member
Joined: Aug 2001
Posts: 26
It works perfectly here, under 10.4.4 and QT 7.0.4 installed.

But San Francisco is giving me this alert: "MacMAME has encountered a prolem. i386: Invalid opcode FF at 00000004". If I look into the mini-audit, I am apparently missing something, maybe a CHD, but there was no CHD alert.

Also, if a ROM is corrupted, you can see it in the list fine, but whenever you switch to the mini-audit, MacMAME hangs: I must force-quit it.


Merry *XMas* (even Santa Klaus has dropped Classic support ...)
#14009 01/14/06 04:48 AM
Joined: Feb 2001
Posts: 141
B
Member
Offline
Member
B
Joined: Feb 2001
Posts: 141
I get that alert with Senkyu but it's a little different:

i386: Invalid opcode FF at 00000002

#14010 01/14/06 08:03 AM
Joined: Feb 2004
Posts: 2,217
Likes: 5
Very Senior Member
Online Content
Very Senior Member
Joined: Feb 2004
Posts: 2,217
Likes: 5
The multiply defined symbol problem only occurs with 10.3.9/QT7.0.4 for me. Tiger is fine with any Quicktime and 10.3.9 is fine with QT7.0.3 or earlier.

#14011 01/16/06 03:23 AM
Joined: Oct 2001
Posts: 10
Junior Member
Offline
Junior Member
Joined: Oct 2001
Posts: 10
On mac-emu.net forum, users with 10.3.9 and the last quicktime update can't launch MacMAME (although 0.77fr seems to work). I told them to use the link given by rp, thanks smile


syndicman - mac-emu.net
#14012 01/16/06 05:58 PM
Joined: Sep 2000
Posts: 286
Senior Member
Offline
Senior Member
Joined: Sep 2000
Posts: 286
Quote:
Originally posted by Brad Oliver:
Is everyone who has this problem running 10.3.9 or are some of you using a version of 10.4?
0.103u2 is running fine here on MacOS X 10.3.9 / QT 7.0.3 / iTunes 6.0.1

Brad, If you want me to update QT and / or iTunes and test, just say so.

Page 2 of 4 1 2 3 4

Link Copied to Clipboard
Who's Online Now
1 members (1 invisible), 54 guests, and 2 robots.
Key: Admin, Global Mod, Mod
ShoutChat
Comment Guidelines: Do post respectful and insightful comments. Don't flame, hate, spam.
Forum Statistics
Forums9
Topics8,879
Posts116,775
Members4,958
Most Online890
Jan 17th, 2020
Forum Host
These forums are hosted by www.retrogamesformac.com
Forum hosted by www.retrogamesformac.com