Previous Thread
Next Thread
Print Thread
Page 1 of 2 1 2
#37342 01/12/08 05:22 PM
Joined: Dec 2004
Posts: 111
P
Senior Member
OP Offline
Senior Member
P
Joined: Dec 2004
Posts: 111

Joined: Apr 2006
Posts: 722
Senior Member
Offline
Senior Member
Joined: Apr 2006
Posts: 722
It amazing that as busy as he has been with MAME Tester Stuff he still has time to update lists packs and BridgeM1. Go Fujix, go!
It's true what he told me though, the Game/Title window when both scrolling look like a nice stock ticker smile





Joined: Mar 2001
Posts: 16,613
R
Very Senior Member
Offline
Very Senior Member
R
Joined: Mar 2001
Posts: 16,613
MAME's going to start using a real issue tracking system soon (Fujix will admin), but the existing MAMETesters site is going away and the MT board at MW will be un-official-ized. So he should be able to give us a much better Bridge (or whatever he wants to do).

Joined: Oct 2006
Posts: 988
S
Senior Member
Offline
Senior Member
S
Joined: Oct 2006
Posts: 988
although last I heard, the existing site would be replaced with a differently designed site, not that it's "going away". Maybe you know different.

Joined: Mar 2001
Posts: 16,613
R
Very Senior Member
Offline
Very Senior Member
R
Joined: Mar 2001
Posts: 16,613
The existing site is a front page and the current clunky "database", so replacing the database with an actual system on mamedev.org would tend to make that the least ambitious redesign in interweb history wink

Last edited by R. Belmont; 01/14/08 01:55 PM.
Joined: Aug 2003
Posts: 122
T
Senior Member
Offline
Senior Member
T
Joined: Aug 2003
Posts: 122
Playing Sega Rally Championship, song: 01 Getting Muddy, after it ends it won't loop or go to the next song in the list. Yet, if I play VF2, song: Enbu... It does loop and/or go to the next song. <:-/

Maybe it's a problem with a list or xml? *shrugs*

Last edited by Tom Braider; 01/22/08 09:35 PM.

Dear Mod/Admin, Please let me know why you had to delete this post. Thanks.
Joined: Apr 2006
Posts: 722
Senior Member
Offline
Senior Member
Joined: Apr 2006
Posts: 722
Re: Sega Championship Rally, Track #1.

I can duplicate that particular issue in both BridgeM1 and M1.exe (command-line) by:

BridgeM1: Load game with a srally.LST file, but have the "List Mode" unchecked, track #2 is the starting track of the LST file. Hit "-" to access track #1 - let it play and when it ends, it does not continue to track #2.

M1.exe: Load game with "m1 srally" without a LST file. Since the only reference M1 can find is the XML which has a default track of #1, it starts to play at #1. When the song completes, M1 does not advance the track. I just sits there with CPU whirling.

Maybe RB knows something right off about what might be causing the problem.




Joined: Mar 2001
Posts: 16,613
R
Very Senior Member
Offline
Very Senior Member
R
Joined: Mar 2001
Posts: 16,613
M1 does not ASS-ume anything - if you want it to auto-advance, you have to have a .LST file with play times included for the tracks.

Last edited by R. Belmont; 01/22/08 11:22 PM.
Joined: Apr 2006
Posts: 722
Senior Member
Offline
Senior Member
Joined: Apr 2006
Posts: 722
My bad. That's me ASS-uming that the command-line M1 auto-detected end, which is doesn't. That would make the problem lie in something else on the BridgeM1 side - could it be a mismatch of the XML/LST default track numbers?




Joined: Mar 2001
Posts: 16,613
R
Very Senior Member
Offline
Very Senior Member
R
Joined: Mar 2001
Posts: 16,613
As long as there's a LST file with timed tracks and list mode is on ("album mode" for the commandline M1, which is the default there) it should advance fine.

Page 1 of 2 1 2

Moderated by  R. Belmont 

Link Copied to Clipboard
Who's Online Now
2 members (crazyc, 1 invisible), 50 guests, and 3 robots.
Key: Admin, Global Mod, Mod
ShoutChat
Comment Guidelines: Do post respectful and insightful comments. Don't flame, hate, spam.
Forum Statistics
Forums9
Topics8,836
Posts116,222
Members4,921
Most Online890
Jan 17th, 2020
Powered by UBB.threads™ PHP Forum Software 7.7.5