Previous Thread
Next Thread
Print Thread
Joined: May 2008
Posts: 8
H
hamelg Offline OP
Member
OP Offline
Member
H
Joined: May 2008
Posts: 8
Hello,

When I run sdlmame the first time on a freshly X session and move the mouse, Xserver crashes with this error :

Fatal server error:
bogus pointer event from ddx

The crash happens only the first time but not every time. If it doesn't happen the first time, it never happens.

Here is my configuration :
Linux kernel 2.6.25
sdlmame 0.125u1
xorg-server 1.4.2

Is it a sdl or xorg issue ?

Thank you

Joined: May 2008
Posts: 4,899
Q
Very Senior Member
Offline
Very Senior Member
Q
Joined: May 2008
Posts: 4,899
I'd assume it's an xorg issue... although maybe "triggered" by SDLMAME. It could be triggered by any application if the underlying X server is somewhat "instable"... moving the mouse cursor shouldn't be critical at all.


A mind is like a parachute. It doesn't work unless it's open. [Frank Zappa]

We're searching for QMC2 translators and support for existing translations. Interested? See here!
Joined: May 2008
Posts: 8
H
hamelg Offline OP
Member
OP Offline
Member
H
Joined: May 2008
Posts: 8
Originally Posted By qmc2
It could be triggered by any application if the underlying X server is somewhat "instable"...


When crash occurs, Xserver is dedicated to sdlmame. Here is my .xsession :
xrandr -s 1024x768 -r 85
wahcade

Joined: May 2008
Posts: 4,899
Q
Very Senior Member
Offline
Very Senior Member
Q
Joined: May 2008
Posts: 4,899
Maybe, but it still does not sound as an SDLMAME issue...

Try google'ing for "bogus pointer event from ddx"... I found this probable cause (and solution) related to "evdev" for example:

http://www.chrisweldon.net/2007/01/19/xorg-71-and-evdev-problems-solved

Of course this only applies if you are using "evdev" as the mouse driver... could you post the full xorg-log (at least the parts related to the mouse pointer)?

Joined: Mar 2001
Posts: 16,677
Likes: 4
R
Very Senior Member
Offline
Very Senior Member
R
Joined: Mar 2001
Posts: 16,677
Likes: 4
Yeah, that's an X problem, not an SDLMAME thing.

Joined: May 2008
Posts: 8
H
hamelg Offline OP
Member
OP Offline
Member
H
Joined: May 2008
Posts: 8
Originally Posted By qmc2

Of course this only applies if you are using "evdev" as the mouse driver... could you post the full xorg-log (at least the parts related to the mouse pointer)?


$ grep -i mouse Xorg.0.log.old
(**) |-->Input Device "Mouse0"
(II) LoadModule: "mouse"
(II) Loading /usr/lib/xorg/modules/input//mouse_drv.so
(II) Module mouse: vendor="X.Org Foundation"
(==) NVIDIA(0): Silken mouse enabled
(**) Mouse0: Device: "/dev/input/mice"
(**) Mouse0: Protocol: "auto"
(**) Mouse0: always reports core events
(==) Mouse0: Emulate3Buttons, Emulate3Timeout: 50
(**) Mouse0: ZAxisMapping: buttons 4 and 5
(**) Mouse0: Buttons: 9
(**) Mouse0: Sensitivity: 1
(II) evaluating device (Mouse0)
(II) XINPUT: Adding extended input device "Mouse0" (type: MOUSE)
(--) Mouse0: PnP-detected protocol: "ExplorerPS/2"
(II) Mouse0: ps2EnableDataReporting: succeeded
(II) Mouse0: ps2EnableDataReporting: succeeded
(II) evaluating device (Mouse0)
(II) Mouse0: ps2EnableDataReporting: succeeded
(II) Mouse0: ps2EnableDataReporting: succeeded

Here is the related section in my xorg.conf :

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
EndSection

This issue occurs only when running sdlmame. I'll try to force protocol to IMPS/2 via device /dev/psaux.

I saw here https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-input-evdev/+bug/97643, that specify
InputDevice "mouse" "SendCoreEvents"
in xorg.conf may help. But,I think it's already enabled by default like the log file says (**) Mouse0: always reports core events.


Joined: May 2008
Posts: 8
H
hamelg Offline OP
Member
OP Offline
Member
H
Joined: May 2008
Posts: 8
Force protocol to imps/2 fixes nothing.
I have the same behavior whatever the mouse driver used.

I've found out that the crash doesn't happen if I start sdlmame on a fresh X server.
The workaround is to force the X session manager to kill and restart the X server each time I logoff. So, I have inserted this line in stanza [X-:*-Core] in my kdmrc file :

TerminateServer=true

and now, all work like a charm !

Last edited by hamelg; 06/25/08 07:09 PM.

Moderated by  R. Belmont 

Link Copied to Clipboard
Who's Online Now
5 members (belegdol, Olivier Galibert, ICEknight, 2 invisible), 55 guests, and 2 robots.
Key: Admin, Global Mod, Mod
ShoutChat
Comment Guidelines: Do post respectful and insightful comments. Don't flame, hate, spam.
Forum Statistics
Forums9
Topics8,879
Posts116,764
Members4,957
Most Online890
Jan 17th, 2020
Forum Host
These forums are hosted by www.retrogamesformac.com
Forum hosted by www.retrogamesformac.com