Previous Thread
Next Thread
Print Thread
Page 532 of 536 1 2 530 531 532 533 534 535 536
Joined: Nov 2016
Posts: 56
P
Member
Offline
Member
P
Joined: Nov 2016
Posts: 56
Work on the Sony NWS-3260 portable (similar to this: bignews) is progressing. We now have basic video and hle keyboard.

Interrupts, DMA and SCSI remain to be tackled, but since networking is already up, I'm going to see if I can get it to boot diskless first.

[Linked Image from i.imgur.com]

Joined: Nov 2016
Posts: 56
P
Member
Offline
Member
P
Joined: Nov 2016
Posts: 56
Sony NEWS NWS-3260 (MIPS R3000-based portable) is working now. It'll boot and run NEWS-OS from a hard disk image, including X.

The only significant remaining TODO's are:
  • font rom dumps
  • sound hardware
  • figure out how to make a NEWS-OS boot/install floppy image


[Linked Image from i.imgur.com]

Joined: Apr 2005
Posts: 591
Senior Member
Offline
Senior Member
Joined: Apr 2005
Posts: 591
Oh wow this is awesome!

Joined: Mar 2001
Posts: 16,859
Likes: 51
R
Very Senior Member
Online Content
Very Senior Member
R
Joined: Mar 2001
Posts: 16,859
Likes: 51
That's super cool!

Joined: Jan 2012
Posts: 877
Likes: 7
C
Senior Member
Offline
Senior Member
C
Joined: Jan 2012
Posts: 877
Likes: 7
Got around to dump my qx10 char rom.
[Linked Image from i.imgur.com]

Used to look like

[Linked Image from i.imgur.com]

Joined: Nov 2016
Posts: 56
P
Member
Offline
Member
P
Joined: Nov 2016
Posts: 56
Nice.

Joined: Jun 2020
Posts: 3
D
Member
Offline
Member
D
Joined: Jun 2020
Posts: 3
Anyone knows the state of Sun3 emulation in MAME?
I got no luck booting SunOS 4.1.1 installation media.
Here is what I did
1) started MAME as mame64 sun3_60 -ramsize 24M -cdrom /tmp/sun/munix_sun3
2) pressed L1+a to abort network boot
3) entered "b sd(0,30,4)" at PROM - at this step MAME crashes with SIGSEGV

Sources:
https://www.sun3arc.org/install/install.phtml
https://www.sun3arc.org/BootTapes/Sun3x/

Perhaphs I need to make a proper CDROM image? Anyone have one?

Joined: Apr 2005
Posts: 591
Senior Member
Offline
Senior Member
Joined: Apr 2005
Posts: 591
Try renaming the CDROM image to .iso, I remember there were problems in the past when the file format was not detected correctly by MAME if the extension didn't match.

The Sun3 is still marked as MACHINE_NOT_WORKING so you probably won't get very far even when/if ISO loading works. It probably doesn't even boot SunOS correctly at this point

Joined: Jun 2020
Posts: 3
D
Member
Offline
Member
D
Joined: Jun 2020
Posts: 3
This is complicated because machine is from tape pre-cdrom era smile Unfortunately renaming trick didn't help. I still stand I need a proper image at first

TBH I never looked at MACHINE_NOT_WORKING as this for e.g. marked as MACHINE_NOT_WORKING but actually work fine
https://github.com/mamedev/mame/blob/master/src/mame/drivers/hp9k_3xx.cpp#L520
https://wiki.mamedev.org/index.php/Driver:HP300

Last edited by dukzcry; 06/10/20 12:22 PM.
Joined: May 2009
Posts: 2,003
Likes: 40
J
Very Senior Member
Offline
Very Senior Member
J
Joined: May 2009
Posts: 2,003
Likes: 40
That's not a reasonable assumption to make. The developers elect to mark something as MACHINE_NOT_WORKING when they either know that it won't, or aren't confident that it will, work as intended.

Page 532 of 536 1 2 530 531 532 533 534 535 536

Link Copied to Clipboard
Who's Online Now
2 members (gspat, 1 invisible), 29 guests, and 3 robots.
Key: Admin, Global Mod, Mod
ShoutChat
Comment Guidelines: Do post respectful and insightful comments. Don't flame, hate, spam.
Forum Statistics
Forums9
Topics9,019
Posts118,457
Members5,011
Most Online890
Jan 17th, 2020
Forum Host
These forums are hosted by www.retrogamesformac.com
Forum hosted by www.retrogamesformac.com