Previous Thread
Next Thread
Print Thread
Page 2 of 529 1 2 3 4 528 529
Re: SVN builds - new driver flood [Re: R. Belmont] #44687 09/13/08 03:31 PM
Joined: Aug 2002
Posts: 354
H
Heihachi_73 Online Content
Senior Member
Online Content
Senior Member
H
Joined: Aug 2002
Posts: 354
Speaking of Master Systems, can someone test Bank Panic on their end? It seems to be broken on all versions except smsj. CRC of the tested ROM image is B4DFB825; works with Meka's built-in BIOS (unless it's just a 'watch the SEGA logo' before the game starts), and in Dega.

Tested in MESS 0.126 with the v1.3, Hang-on and Alex Kidd BIOS sets, both NTSC and PAL.

Re: SVN builds - new driver flood [Re: Heihachi_73] #44688 09/13/08 04:41 PM
Joined: Mar 2001
Posts: 16,394
R
R. Belmont Offline
Very Senior Member
Offline
Very Senior Member
R
Joined: Mar 2001
Posts: 16,394
Maybe it's a Japanese-region cart? Non-MESS emulators tend to skip region checks.

Re: SVN builds - new driver flood [Re: R. Belmont] #44689 09/13/08 05:41 PM
Joined: Feb 2007
Posts: 13
M
mattmess Offline
Member
Offline
Member
M
Joined: Feb 2007
Posts: 13
Bank Panic in Japan only for SG-1000.
The Master System cartridge was never released there, AFAIK.

And speaking of Master III again... Aren't the Masters from Tec Toy different from the others? They use PAL-M, not PAL. The games run faster on PAL-M.

Last edited by mattmess; 09/13/08 05:45 PM.
Re: SVN builds - new driver flood [Re: mattmess] #44690 09/13/08 06:48 PM
Joined: Aug 2002
Posts: 354
H
Heihachi_73 Online Content
Senior Member
Online Content
Senior Member
H
Joined: Aug 2002
Posts: 354
Looks like the version I've had for years is a bad dump. The [a1] set works fine. Old set is now exterminated!

Update (prior to posting) - Strangely though, the only differences in both ROMs were the last two bytes at 0x7FFE - 2020 (old version) versus 004C (a1 version).

Re: SVN builds - new driver flood [Re: Anna Wu] #44704 09/14/08 08:53 AM
Joined: Jul 2007
Posts: 4,625
A
Anna Wu Offline OP
Very Senior Member
OP Offline
Very Senior Member
A
Joined: Jul 2007
Posts: 4,625
SVN 3254
Windows binary
GUI
Properties - Miscellaneous

It seems one checkbox is superimposed .



Re: SVN builds - new driver flood [Re: Heihachi_73] #44705 09/14/08 09:04 AM
Joined: Apr 2004
Posts: 1,554
J
judge Offline
Very Senior Member
Offline
Very Senior Member
J
Joined: Apr 2004
Posts: 1,554
Originally Posted By Heihachi_73
Speaking of Master Systems, can someone test Bank Panic on their end? It seems to be broken on all versions except smsj. CRC of the tested ROM image is B4DFB825; works with Meka's built-in BIOS (unless it's just a 'watch the SEGA logo' before the game starts), and in Dega.

Tested in MESS 0.126 with the v1.3, Hang-on and Alex Kidd BIOS sets, both NTSC and PAL.


Together with your next post this sounds like a checksum issue. The japanese bioses never calculate and match the checksums reported by a cartridge. The old sg1000 games did not have the checksum byte in their headers, so to keep backwards compatible sega removed the checksum checking from the japanese bios code. The euro and us bioses do calcuate and check the checksum however.

So, the sg1000 image that works on a euro/us bios is actually a checksum-fixed version of the original rom image.


Re: SVN builds - new driver flood [Re: Anna Wu] #44714 09/15/08 08:34 AM
Joined: Jul 2007
Posts: 4,625
A
Anna Wu Offline OP
Very Senior Member
OP Offline
Very Senior Member
A
Joined: Jul 2007
Posts: 4,625
SVN 3266

Othello Multivision driver

ROM check : not found
Maybe need change to : None required like for SG-1000

Othello Multivision cartridges are working with omv driver.

Last edited by Anna Wu; 09/15/08 08:36 AM.
Re: SVN builds - new driver flood [Re: Anna Wu] #44716 09/15/08 08:53 AM
Joined: Jan 2006
Posts: 3,687
etabeta78 Offline
Very Senior Member
Offline
Very Senior Member
Joined: Jan 2006
Posts: 3,687
No, as you can see in the source, a BIOS is possibly missing because no omv unit has been dumped yet. The message is correct.

Re: SVN builds - new driver flood [Re: Anna Wu] #44717 09/15/08 08:59 AM
Joined: Jul 2007
Posts: 4,625
A
Anna Wu Offline OP
Very Senior Member
OP Offline
Very Senior Member
A
Joined: Jul 2007
Posts: 4,625
r3261
[JUPITER] Fixed regression; driver works again.

I can load game cartridges (.ace), but i am not able after loading to start/control with the keyboard (Joystick is not available). Is this ok ?
Made a double check with the EightyOne emu, here i can start all my .ace files.

Another question :
The device view show me " Cartridge " for files with the .ace extension.
Other websites and emulators call this format "snapshot".
MESS not show me the device view for snapshots. Why ?

Last edited by Anna Wu; 09/15/08 09:57 AM.
Re: SVN builds - new driver flood [Re: etabeta78] #44718 09/15/08 09:04 AM
Joined: Jul 2007
Posts: 4,625
A
Anna Wu Offline OP
Very Senior Member
OP Offline
Very Senior Member
A
Joined: Jul 2007
Posts: 4,625
Originally Posted By etabeta78
No, as you can see in the source, a BIOS is possibly missing because no omv unit has been dumped yet. The message is correct.


Has the original SG-1000 a bios ? If yes, why no required compare to omv ?

Last edited by Anna Wu; 09/15/08 10:00 AM.
Page 2 of 529 1 2 3 4 528 529

Who's Online Now
4 registered members (Dorando, Carbon, 2 invisible), 178 guests, and 1 spider.
Key: Admin, Global Mod, Mod
ShoutChat Box
Comment Guidelines: Do post respectful and insightful comments. Don't flame, hate, spam.
Forum Statistics
Forums9
Topics8,722
Posts114,651
Members4,873
Most Online510
Aug 26th, 2019
Powered by UBB.threads™ PHP Forum Software 7.7.3