Previous Thread
Next Thread
Print Thread
Joined: Jun 2009
Posts: 3
M
Member
OP Offline
Member
M
Joined: Jun 2009
Posts: 3
Hello. I could really use some input and advice regarding Netplay.

I'm suddenly running into a problem with Netplay that I simply cannot figure out. I'm absolutely stumped, so figured I would turn to the experts here in the Forum. Maybe somebody has some insight and could shed some light in regards to the problem I'm running into? Any help would be greatly appreciated.

I've been successfully using Netplay with (Nestopia/Snes9x/Genesis Plus) for quite sometime now, and I've never once had a problem. Netplay has been working flawlessly for me when using Emulator Enhancer v2.1 along with (Nestopia v1.3.4/Snes9x v1.5/Genesis Plus v1.2.8).

My cousin introduced me to Emulator ROMS and Netplay, and we've been having a blast playing all the old games online together. He's got a much older PowerMac G4 running 10.4 Tiger and he lives in Illinois, and I've got newer Mac Pro running 10.5 Leopard and I'm located in California.

Then just recently my cousin purchased a brand new Intel Mac mini (and using all the same software versions as before) we can no longer connect via Netplay. We receive the following error messages....

----

Error message received on the HOST side of Netplay:

Fatal Assesertion Failure

Condition: (network_latency >=3) &&(network_latency <=15)
File: ce_network.c
Line: 341

Please e-mail me with this error message so that I can figure out what caused it

Error message received on the JOIN side of Netplay:

Unable to receive keys

An error occurred while receiving dta from the other player.
Network play will now cease.

-----

So I thought well I'd do some troubleshooting...

My sister has a brand new Intel iMac and we are on the same local area network together, and when we try to connect using on Netplay using her iMac and my Mac Pro, we run into the same exact problem (as above). And so then I tried using my Macbook Pro and Mac Pro together (on the same local area network), and still the same problem.

On the surface it seems that having two Apple Intel machines, both running OS X 10.5 Leopard is somehow causing a problem when trying to use Netplay. But why would Netplay work when using an older PowerPC and and Apple Intel machine together? This has me absolutely puzzled!!!

When running two Apple Intel machines together, using Netplay, I've tried just about every combination of Emulator Enhancer and Nestopia (i.e. different version numbers from bannister.org/software), and cannot find any combination that will actually work with Netplay, when using two Apple Intel machines running 10.5 Leopard.

Am I missing something simple here? I have searched high and low on google, and cannot seem to find any info regarding this Netplay issue that I'm running into. I've got to believe that somebody else has encountered this same problem, or has experienced similar issues such as this?

Any insight you might be able to provide would be greatly appreciated!

Thanks for your time.

MetalGods



Joined: Dec 1969
Posts: 917
Likes: 3
R
Senior Member
Offline
Senior Member
R
Joined: Dec 1969
Posts: 917
Likes: 3
Looks like you've found a bug.

Try replacing your Emulator Enhancer.bundle file with this one:

http://www.esatclear.ie/~bannister/eetest.zip

Can you try PPC-Intel and PPC-PPC with this one too by any chance?

Joined: Jun 2009
Posts: 3
M
Member
OP Offline
Member
M
Joined: Jun 2009
Posts: 3
Hey Richard,

Looks like that did the trick! Thank you! I really appreciate your help.

Thus far I have only tested Intel-Intel, but it works like a charm.

I will try and test PPC-Intel sometime soon, and at some point I should also be able to test PPC-PPC as well. I will add onto this thread as soon as I've had a chance to test the other combinations.

Thanks again,

MetalGods

Joined: Dec 1969
Posts: 917
Likes: 3
R
Senior Member
Offline
Senior Member
R
Joined: Dec 1969
Posts: 917
Likes: 3
Thank you for your detailed explanation. It's such a nice change to get something that pinpoints the problem so quickly. I'm more used to e-mails saying something along the lines of "its not working" without specifying either a) what or b) which program!

Joined: Jun 2009
Posts: 3
M
Member
OP Offline
Member
M
Joined: Jun 2009
Posts: 3
I just finished testing PPC-Intel and that seems to work fine as well. PowerMac G4 running Tiger, and Mac Pro running Leopard. Everything is running smoothly with the patched up version of Emulator Enhancer that you provided.

The latest versions of Nestopia, Snes9x, and Genesis Plus were all tested with Emulator Enahancer, and all ran without a hitch when using Netplay. Same thing with the Intel-Intel scenario as well.

Sometime next week I should be able to test PPC-PPC, and I'll provide an update on those results as well. I've got access to a couple of PowerMac G4 towers, both running Tiger.

Thanks again for your help. It's nice to be up and running on Netplay again.




Joined: Dec 1969
Posts: 917
Likes: 3
R
Senior Member
Offline
Senior Member
R
Joined: Dec 1969
Posts: 917
Likes: 3
Thanks

Joined: Dec 2000
Posts: 45
G
Member
Offline
Member
G
Joined: Dec 2000
Posts: 45
Hey MetalGods. How is the speed of Netplay for you and your cousin? Maybe we could play a game sometime. smile

Joined: Apr 2010
Posts: 2
W
Member
Offline
Member
W
Joined: Apr 2010
Posts: 2
Sorry to revive a relatively old thread, but I am currently experiencing the same issue with the current releases of Nestopia (1.4.1), BSNES (0.5.0), and Emulator Enhancer (2.3). I'd love to play some games online with my girlfriend and what metalgods says in this thread makes it sound exactly like what I'm looking for.

EDIT: Connection's between two 13in MacBook Pros running Snow Leopard, if it matters.

Last edited by winged2point0; 04/05/10 10:24 AM.
Joined: Apr 2010
Posts: 2
W
Member
Offline
Member
W
Joined: Apr 2010
Posts: 2
If this has fallen under the radar, I'd like to reaffirm that I'm still interested in finding the solution to the issue and that I have not found any workaround or solution.


Moderated by  Marty, R. Belmont 

Link Copied to Clipboard
Who's Online Now
1 members (robcfg), 20 guests, and 3 robots.
Key: Admin, Global Mod, Mod
ShoutChat
Comment Guidelines: Do post respectful and insightful comments. Don't flame, hate, spam.
Forum Statistics
Forums9
Topics9,112
Posts119,407
Members5,024
Most Online890
Jan 17th, 2020
Our Sponsor
These forums are sponsored by Superior Solitaire, an ad-free card game collection for macOS and iOS. Download it today!

Superior Solitaire
Forum hosted by www.retrogamesformac.com