Previous Thread
Next Thread
Print Thread
Page 2 of 2 1 2
Joined: Jan 2005
Posts: 54
B
Member
Offline
Member
B
Joined: Jan 2005
Posts: 54
m+gui 1.4.9 crash on Mac OS X 10.6.1 (Intel 64) with sdlmame 0.134u4...

Process: mamepgui [76118]
Path: /Giochi/mamepgui/mamepgui.app/Contents/MacOS/mamepgui
Identifier: com.yourcompany.mamepgui
Version: ??? (???)
Code Type: X86 (Native)
Parent Process: launchd [672]

Date/Time: 2009-10-25 19:13:28.914 +0100
OS Version: Mac OS X 10.6.1 (10B504)
Report Version: 6

Interval Since Last Report: 3814346 sec
Crashes Since Last Report: 29
Per-App Interval Since Last Report: 143818 sec
Per-App Crashes Since Last Report: 5
Anonymous UUID: A4773186-A3DD-4FF7-8F20-C4444E96648F

Exception Type: EXC_BAD_ACCESS (SIGBUS)
Exception Codes: KERN_PROTECTION_FAILURE at 0x0000000000000004
Crashed Thread: Unknown

Backtrace not available

Unknown thread crashed with X86 Thread State (32-bit):
eax: 0x00000000 ebx: 0x000304d9 ecx: 0xbfffe310 edx: 0x00e47350
edi: 0xbfffe310 esi: 0x00000001 ebp: 0xbfffe2e8 esp: 0xbfffe2d0
ss: 0x0000001f efl: 0x00010282 eip: 0x004aa50a cs: 0x00000017
ds: 0x0000001f es: 0x0000001f fs: 0x00000000 gs: 0x00000037
cr2: 0x00000004

Joined: Mar 2001
Posts: 16,613
R
Very Senior Member
Offline
Very Senior Member
R
Joined: Mar 2001
Posts: 16,613
Yeah, that's a completely useless report. What were you doing when it crashed?

Joined: Aug 2008
Posts: 14
N
Member
Offline
Member
N
Joined: Aug 2008
Posts: 14
i'm on os x leopard 10.5.8, mamepgui 1.4.9 won't even finish loading (window looks as if gui elements aren't even loaded properly). trying to close it results in "application unexpectedly closed" dialog. i'd post screenshots, but there's no upload function in these reply boxes & it's rather late for me to be doing uploads to other sites.

using sdlmame 0.135u4 64-bit on 10.5.8 intel.

Joined: Mar 2001
Posts: 16,613
R
Very Senior Member
Offline
Very Senior Member
R
Joined: Mar 2001
Posts: 16,613
Attempting to run a 64-bit SDLMAME binary on 10.5.x or earlier will indeed crash in a spectacular manner. 64-bit SDLMAME requires 10.6 Snow Leopard. (This is not me conspiring with Apple to make you upgrade; 10.5 doesn't have the plumbing to support 64-bit applications that aren't character-mode Internet servers. Anything with graphics and sound that's 64-bit therefore requires the newer OS).

Joined: Jun 2007
Posts: 223
B
Senior Member
Offline
Senior Member
B
Joined: Jun 2007
Posts: 223
The links for this have been broken for a few days, and after a brief discussion with Google I still can't find a place to download the source. Help?

EDIT: Doh! Never mind. I see these must have been taken down -- the ones in this topic are OK:
http://www.bannister.org/forums/ubbthreads.php?ubb=showflat&Number=57272#Post57272

Last edited by billb; 12/28/09 03:44 PM.
Joined: Dec 2009
Posts: 1
K
Member
Offline
Member
K
Joined: Dec 2009
Posts: 1
I've done some research and I can't figure it out for the life of me (probably easy to)
I figured I'd post here:

What do you do w/ the QT Program exactly? I'm not sure what to (build/run?) or where to issue the command that was provided by the OP....if anyone can help even slightly, it'd be greatly appreciated, thank you!

Page 2 of 2 1 2

Moderated by  R. Belmont 

Link Copied to Clipboard
Who's Online Now
5 members (Pernod, Olivier Galibert, Golden Child, AJR, pmackinlay), 31 guests, and 3 robots.
Key: Admin, Global Mod, Mod
ShoutChat
Comment Guidelines: Do post respectful and insightful comments. Don't flame, hate, spam.
Forum Statistics
Forums9
Topics8,836
Posts116,222
Members4,921
Most Online890
Jan 17th, 2020
Powered by UBB.threads™ PHP Forum Software 7.7.5