Previous Thread
Next Thread
Print Thread
Page 2 of 2 1 2
Joined: Feb 2007
Posts: 549
S
Senior Member
Offline
Senior Member
S
Joined: Feb 2007
Posts: 549
Awesome, thanks Emuman.

Joined: Sep 2000
Posts: 463
Likes: 1
M
Senior Member
Offline
Senior Member
M
Joined: Sep 2000
Posts: 463
Likes: 1
One small issue (something to look at for the next release) -

I've been trying to play with the command line options (without success, I'm afraid), and I believe I've found the cause in this version...

It seems that the command line option does not deal well with spaces in file/folder names (I keep my ROM Sets, artwork, samples, etc. in a folder called 'MAME Support Files').

When attempting to launch a game with the command line option, M+GUI gets confused by the spaces in my support files folder, and the game refuses to launch (Launching without the command line option works fine).


The following statement is true...
The preceding statement is false.
Joined: Sep 2000
Posts: 286
Senior Member
Offline
Senior Member
Joined: Sep 2000
Posts: 286
Originally Posted By MAMEBase
It seems that the command line option does not deal well with spaces in file/folder names (I keep my ROM Sets, artwork, samples, etc. in a folder called 'MAME Support Files').
Confirmed.
I had to copy/paste my ROMs + CHDs + LD paths directly in the mame.ini file to make it work

Joined: Nov 2007
Posts: 106
E
Emuman Offline OP
Senior Member
OP Offline
Senior Member
E
Joined: Nov 2007
Posts: 106
>When attempting to launch a game with the command line option, M+GUI gets confused by the spaces in my support files folder, and the game refuses to launch
thanks. it's easy to fix. for now manually add a pair of quotation marks around the path.

>I had to copy/paste my ROMs + CHDs + LD paths directly in the mame.ini file to make it work
no you dont have to do this, mamepgui handles paths fine, whether it contains space or Unicode chars. MAMEBase is talking about "File - Play with Options - Command Line"


MAME Plus Team
Joined: Nov 2009
Posts: 13
C
Member
Offline
Member
C
Joined: Nov 2009
Posts: 13
Awesome, many thanks Emuman.

Joined: Sep 2000
Posts: 463
Likes: 1
M
Senior Member
Offline
Senior Member
M
Joined: Sep 2000
Posts: 463
Likes: 1
Emuman -

Thanks for the suggestion, but I'm afraid I'm still having trouble...

This is the command line I've set with your suggested modification -

Code:
asteroid -artpath "/MAME Support Files/artwork" -autoframeskip -beam 4.00 -cheat -cheatpath "/MAME Support Files/cheat" -crosshairpath "/MAME Support Files/Crosshairs" -flicker 0.00 -mouse -rompath "/MAME Support Files/Roms" -samplepath "/MAME Support Files/samples" -skip_gameinfo -nosleep -snapshot_directory "/MAME Support Files/snap" -video opengl


I then click 'OK', and the error dialog pops up informing me
"Error: unknown option: Support"

I may simply be missing something obvious (wouldn't be the first time... wink ), and I'm less concerned now that you're aware of the problem.

Incidentally, one of the reasons I'm playing with this option is that the slider in the 'Beam Width' section of 'Core Vector Preferences' still only goes from 0 to 1, incrementing by 0.01 (it should go from 1 to 10, incrementing by 0.1).

The 'Flicker' slider should go from 0 to 100, incrementing by 1.0.

Last edited by MAMEBase; 01/07/10 06:24 PM.

The following statement is true...
The preceding statement is false.
Joined: Dec 2006
Posts: 54
F
Member
Offline
Member
F
Joined: Dec 2006
Posts: 54
replace "/MAME Support Files" by "/MAME\ Support\ Files/"

smile

Last edited by Foul; 01/10/10 04:11 PM.
Joined: Jan 2010
Posts: 2
G
Member
Offline
Member
G
Joined: Jan 2010
Posts: 2
Seams something is messed up with my Mac 1.4.9e version. It worked for some time with 136u1 but now it just comes up and freezes. I'm sure it's a corrupt config file somewhere but I can't find out where they are stored. Even a quick quit of the program generates a crash. Anyone?

Joined: Nov 2007
Posts: 106
E
Emuman Offline OP
Senior Member
OP Offline
Senior Member
E
Joined: Nov 2007
Posts: 106
the configuration files are
$HOME/.mamepgui/cache/gamelist.cache
$HOME/.mamepgui/mamepgui.ini

BEFORE DELETING THEM, PLEASE BACKUP AND SEND ME (lanewu_at_hotmail.com) your config file, so i can fix it. thanks.


MAME Plus Team
Joined: Jan 2010
Posts: 2
G
Member
Offline
Member
G
Joined: Jan 2010
Posts: 2
Thanks.. fixed and I'm sending the files...

Page 2 of 2 1 2

Moderated by  R. Belmont 

Link Copied to Clipboard
Who's Online Now
4 members (AJR, MrBogi, Pernod, 1 invisible), 35 guests, and 2 robots.
Key: Admin, Global Mod, Mod
ShoutChat
Comment Guidelines: Do post respectful and insightful comments. Don't flame, hate, spam.
Forum Statistics
Forums9
Topics8,921
Posts117,205
Members4,989
Most Online890
Jan 17th, 2020
Forum Host
These forums are hosted by www.retrogamesformac.com
Forum hosted by www.retrogamesformac.com