Previous Thread
Next Thread
Print Thread
Page 5 of 10 1 2 3 4 5 6 7 9 10
Joined: Sep 2008
Posts: 37
K
Member
Offline
Member
K
Joined: Sep 2008
Posts: 37
c0d3h4x0r, any chance of fixing the below bug in your unofficial release? This exists in 1.40 official too. On Windows XP SP3:

- Use windowed mode
- Options -> Timing -> Synchronize to refresh rate (enable)
- Options -> Timing -> Vsync (enable)
- Options -> Preferences -> Run in background (enable)
- Cover the entire Nestopia drawing surface with another window (so there's absolutely no DirectX content being shown)

The emulator then runs as fast as possible and CPU usage hits 100% for that core (e.g. 25% on a 4-core system).

Disabling Vsync fixes this problem. Shouldn't be too hard to fix.


Making life hard for others since 1977.
Joined: Aug 2010
Posts: 2
N
Member
Offline
Member
N
Joined: Aug 2010
Posts: 2
Thanks for taking the time to update nestopia. Unfortunately, like a few previous posters, I am still suffering from input lag when vsync is enabled, and disabling vsync causes annoying tearing. This is so frustrating.

EDIT: Also, FWIW, if I change my TV's refresh rate from 60 Hz to 59 Hz, and then set nestopia to 59 Hz as well, the input lag disappears when I enable vsync, but the screen tearing still occurs. I'm not sure if this sheds light on the situation at all. This vsync/input lag problem has been driving me crazy for months.

Last edited by nyijedi; 08/30/10 01:30 AM.
Joined: Jun 2008
Posts: 5
X
Member
Offline
Member
X
Joined: Jun 2008
Posts: 5
i wonder,why with screen set @75hz the emu,when it switch the resolution in full screen @60,dosen't lag :?

maybe the emulator force the 60hz,and so try to sub timing at all the inputs? (if you force the timing of the emulator on 75hx,everything speed up O_o)

hope to help,good luck,we're all with you ^_^

Last edited by xam925; 09/01/10 12:24 AM.
Joined: Jul 2010
Posts: 3
B
Member
Offline
Member
B
Joined: Jul 2010
Posts: 3
For those still suffering from the input lag issue - give VirtuaNES a try. I don't see any issue with vsync and input lag with it and works great. I'm using that while we wait for a true fix for the input lag issue.

Joined: Jun 2008
Posts: 5
X
Member
Offline
Member
X
Joined: Jun 2008
Posts: 5
thanks for the hint,but virtuanes didn't have so many option like nestopia,ex (datach system,if you wanna "resolve" the input lag issue,just set,for now,your refresh screet at 75hz ^_^

hope someone resolve the bug,anyway =)

Joined: Aug 2010
Posts: 2
N
Member
Offline
Member
N
Joined: Aug 2010
Posts: 2
Unfortunately I use nestopia on my HDTV, which doesn't go up to 75 Hz. Are there any other workarounds that anyone knows about?

Joined: May 2009
Posts: 12
T
Member
Offline
Member
T
Joined: May 2009
Posts: 12
registered to thank original poster. it's so refreshing to find that someone else out there is bothered by input lag enough to actually do something about it.

unfortunately, i'm still experiencing a noticeable amount of input lag with vsync on in your release of nestopia, but at least you're on the right track.

i don't understand why vsync and input lag have to be related in so many different programs. it seems like very few people in the gaming industry have any interest whatsoever in rectifying the problem.

Joined: Sep 2010
Posts: 2
S
Member
Offline
Member
S
Joined: Sep 2010
Posts: 2
I just wanted to report a bug in movie recording. I am using Nestopia 1.40 and haven't changed any settings or anything.

I have used the movie recording feature successfully on several games, but I have found one it refuses to work with. That game is Metal Gear. I tried it with Metal Gear (E) (!) and now with Metal Gear (U) and the result is the same.

If I record a movie, the playback is always completely screwed up (ie: character doing things I didn't do, game pausing and un-pausing and other senseless actions). If I try to export to AVI, it gives me a "File is Corrupt!" error followed by an AVI recording error and no file is saved. I immediately tried it with a random game (Baseball Simulator 1000) and it worked fine, but another try with Metal Gear (both versions) do the exact same thing.

Should be easy enough to reproduce. Just record the first 10 seconds of gameplay and see for yourself. This is the only game I have found to have this problem.

Joined: Mar 2009
Posts: 7
C
Member
Offline
Member
C
Joined: Mar 2009
Posts: 7
Why not set the "TV Aspect" to be 4:3 ?
I hate 290x240 !

Joined: Nov 2010
Posts: 1
R
Member
Offline
Member
R
Joined: Nov 2010
Posts: 1
In case anyone still has problems with Nestopia and their X-Fi card:
I solved the chopped-up sound by using ALchemy (Creative's DSound->OpenAL wrapper).
I set buffers to 4, duration to 1, and with a Nestopia sound latency setting of 1, I don't get any crackling or chopped-up sound anymore.

Seems like the wrapped dsound works better than native dsound, which is kinda hilarious.

Last edited by regha; 11/18/10 09:58 AM.
Page 5 of 10 1 2 3 4 5 6 7 9 10

Moderated by  Marty, R. Belmont 

Link Copied to Clipboard
Who's Online Now
3 members (Golden Child, R. Belmont, Duke), 33 guests, and 2 robots.
Key: Admin, Global Mod, Mod
ShoutChat
Comment Guidelines: Do post respectful and insightful comments. Don't flame, hate, spam.
Forum Statistics
Forums9
Topics8,924
Posts117,253
Members4,991
Most Online890
Jan 17th, 2020
Forum Host
These forums are hosted by www.retrogamesformac.com
Forum hosted by www.retrogamesformac.com