Previous Thread
Next Thread
Print Thread
Page 6 of 10 1 2 4 5 6 7 8 9 10
Joined: Apr 2010
Posts: 16
G
Member
Offline
Member
G
Joined: Apr 2010
Posts: 16
Well, I'll be damned: Using ALchemy actually works and fixed the choppy sound here completely, too. Great find, regha! Finally, I can again enjoy the best NES emulator as it was meant to be smile

Last edited by gummybear; 11/20/10 11:26 PM.
Joined: Apr 2010
Posts: 2
S
Member
Offline
Member
S
Joined: Apr 2010
Posts: 2
Sorry if this has been covered already

I'm trying to use 1.41 on a Dell Inspiron 5100 laptop running Win XP SP 3. When I put Nestopia in full screen mode, I lose the ability to use any input devices. The program continues to run, but I can't actually do anything. I don't have this problem with Nestopia 1.40 official on the same screen, strangely enough. I also have no issues with my desktop running 1.41 in full screen (Intel Quad Core, Win 7 64 bit)

I tried copying my 1.41 config to my 1.40 directory and everything works fine so it's not an issue there.

Any help would be greatly appreciated

Joined: Dec 2010
Posts: 8
M
Member
Offline
Member
M
Joined: Dec 2010
Posts: 8
Hello,

Having the same choppy/skippy sound issue as well with Windows 7 64-bit and Nestopied v .139-.141. I have a Sound Blaster Audigy SE sound card, NVidia Evga 8800 GTS OC @ 640MB video card, Gigabyte GA-MA790GP-UD4H Motherboard, 4GB Corsair Dominator RAM @ 1066mhz 5-5-5-15, and AMD Phenom II X4 940 Deneb 3.0Ghz.

In Nestopia my settings are:
Device: NVIDIA GeForce...
Mode: 1024x768
Filter: Standard (rest default)

Sound:
Device: Primary Sound Driver
Output 44100 1 bit Mono
Latency - 1
Rest default

Timing:
Synchronize to refresh rate
Use hih-preceisiojn timer enable
Enable triple buffering enabled
Vsync enabled
Rest default

Anyone have any suggestions? Nestopia is the most compatible and best functioning emulator, I only have an issue with sound and a bit of input lag...I would greatly appreciate any help!

Thanks

Mike

I should mention I've tried different drivers for my Audigy SE sound card (both from Creative site and from Windows Update) to no avail. Not sure it's a driver issue at this point. Currently I have driver version 5.12.1.2016 installed...I've also tried with version .2020 with the same results).

Last edited by mbard20; 12/06/10 11:12 PM.
Joined: Feb 2007
Posts: 267
Senior Member
Offline
Senior Member
Joined: Feb 2007
Posts: 267
just a shot in the dark here mbard20, but have you tried adjusting the latency?

Joined: Dec 2010
Posts: 8
M
Member
Offline
Member
M
Joined: Dec 2010
Posts: 8
Hello,

Thank you for responding. Unfortunately I have tried adjusting the latency (both up and down) and it does not seem to make a difference. This emulator would be absolutely perfect if I could get this issue resolved in the input lag wasn't present smile

I used Nestopia build 140 on the same box when running XP 32-bit and didn't have any issues with sound or input lag...very strange.

Mike

Joined: Apr 2006
Posts: 728
Senior Member
Offline
Senior Member
Joined: Apr 2006
Posts: 728
Try setting the processor affinity for the application to use only 1 core and see if that helps. This is, assuming, you are using a 64-bit 2 or more core processor. I've had it help other emulators using older compile tools - so you might have some luck with it.








Joined: Dec 2010
Posts: 8
M
Member
Offline
Member
M
Joined: Dec 2010
Posts: 8
Hi Tafoid,

Thanks very much for the suggestion. I will give that a try tonight when I get home.

Mike

Joined: Dec 2010
Posts: 8
M
Member
Offline
Member
M
Joined: Dec 2010
Posts: 8
Tried setting affinity to use only one processor (I have a quad-core processor and tried using 2 different ones) and unfortunately I have the same results. I read that using "ALchemy" seemed to work...I do have this installed but cannot figure out how to force the emu to use these settings. Does anyone have any input on this? I may try to disable my SB Audigy sound card and see if I can find Win7 64-bit drivers for my onboard sound card if the problem goes away...

Joined: Sep 2008
Posts: 37
K
Member
Offline
Member
K
Joined: Sep 2008
Posts: 37
Regarding sound latency: Things to try, one at a time:

* Options->Sound -- Adjust the Latency slider (increase it or decrease it one notch). It sounds like you've already tried this though.
* Options->Video -- Turn off High Precision Timer
* Options->Video -- Turn off Triple Buffering
* Options->Video -- Disable Vsync

You may need to try all the combinations of these to find something that works. I'm familiar with XP, not Windows 7. I also use an SB Audigy series card in my system w/out any audio skipping (Latency slider is set to 2), but again, I use XP. Windows 7's audio layer is *significantly* different, and this isn't just tech forum l33tg4m3rd00d nonsense I'm stating.

Last edited by koitsu; 01/14/11 06:37 AM.

Making life hard for others since 1977.
Joined: Dec 2010
Posts: 8
M
Member
Offline
Member
M
Joined: Dec 2010
Posts: 8
Hi koitsu,

Thanks for the suggestions. I have played with triple buffering and vsync with no luck (I actually need vsync bc I have an lcd monitor I I get pretty bad screen tearing w/out it). However not sure I've tried messing with the timer option. I will def play with this. I also have not had a chance to test my onboard card yet so I have a few things to play with. With the same hardware on winxp 32bit I had 0 problems, which is why this is so frustrating! Thanks again.

Mike

Page 6 of 10 1 2 4 5 6 7 8 9 10

Moderated by  Marty, R. Belmont 

Link Copied to Clipboard
Who's Online Now
1 members (Pernod), 32 guests, and 0 robots.
Key: Admin, Global Mod, Mod
ShoutChat
Comment Guidelines: Do post respectful and insightful comments. Don't flame, hate, spam.
Forum Statistics
Forums9
Topics8,924
Posts117,253
Members4,991
Most Online890
Jan 17th, 2020
Forum Host
These forums are hosted by www.retrogamesformac.com
Forum hosted by www.retrogamesformac.com