Previous Thread
Next Thread
Print Thread
Page 17 of 42 1 2 15 16 17 18 19 41 42
Joined: Mar 2001
Posts: 16,784
Likes: 32
R
Very Senior Member
Offline
Very Senior Member
R
Joined: Mar 2001
Posts: 16,784
Likes: 32
Looks like you need a "make clean", as the devices in the error messages recently got moved.

Joined: Aug 2012
Posts: 67
Member
Offline
Member
Joined: Aug 2012
Posts: 67
Nope. Just tried a make clean and I got the same error.

Joined: May 2004
Posts: 1,672
H
Very Senior Member
Offline
Very Senior Member
H
Joined: May 2004
Posts: 1,672
I was having trouble compiling a plain MAME due to the same devices earlier, I think something has been set up incorrectly.

Joined: Jan 2006
Posts: 3,690
Very Senior Member
Offline
Very Senior Member
Joined: Jan 2006
Posts: 3,690
are e05a03.* files still in mess/machine? if so, they shall probably be moved to emu/machine...

I'm not in the position to compile the source, though

Joined: Apr 2006
Posts: 729
Senior Member
Offline
Senior Member
Joined: Apr 2006
Posts: 729
yeah, there is an issue on the MESS side, even with using 'make depend', 'make depend TARGET=mess', I still get that error.

EDIT: Fixed in r30944




Joined: Jul 2009
Posts: 78
Member
Offline
Member
Joined: Jul 2009
Posts: 78
Can't compile revision 31475:

Code:
$ make TARGET=mess

…

Compiling src/osd/sdl/sdlmain.c...
In file included from src/osd/sdl/sdlmain.c:49:
In file included from src/osd/sdl/input.h:15:
In file included from src/osd/sdl/window.h:20:
In file included from src/osd/sdl/osd_opengl.h:32:
/Library/Frameworks/SDL.framework/Headers/SDL_opengl.h:3124:22: error: typedef redefinition with
      different types ('unsigned int' vs 'void *')
typedef unsigned int GLhandleARB;       /* shader object handle */
                     ^
/System/Library/Frameworks/OpenGL.framework/Headers/gltypes.h:65:15: note: previous definition is here
typedef void *GLhandleARB;
              ^
1 error generated.
make: *** [obj/sdl64/osd/sdl/sdlmain.o] Error 1

Joined: Mar 2001
Posts: 16,784
Likes: 32
R
Very Senior Member
Offline
Very Senior Member
R
Joined: Mar 2001
Posts: 16,784
Likes: 32
That appears to be Mac OS X, but 31475 builds fine on my machine here (10.9 "Mavericks", latest Xcode 5 updates).

Are you doing anything unusual?

Joined: Jul 2009
Posts: 78
Member
Offline
Member
Joined: Jul 2009
Posts: 78
Not that I'm aware of.

My OS X is 10.9.4, My Xcode is 3.2.4.

Edit: I'll install a newer Xcode and try again.

Last edited by Ensjo; 07/31/14 04:23 AM.
Joined: Mar 2001
Posts: 16,784
Likes: 32
R
Very Senior Member
Offline
Very Senior Member
R
Joined: Mar 2001
Posts: 16,784
Likes: 32
Using Xcode 3 on 10.9 (or 10.8, for that matter) is definitely unusual smile

Tip: with newer Xcodes, you'll need to install the command-line tools in the Downloads pane of the Preferences dialog.

Last edited by R. Belmont; 07/31/14 04:34 AM.
Joined: Jul 2009
Posts: 78
Member
Offline
Member
Joined: Jul 2009
Posts: 78
Installed a new Xcode.

Hm, didn't find anything about command-line tools in Downloads.

But in Locations I have:

Quote:
Command Line Tools: Xcode 5.1.1 (5B1008)
(There is a combo box, but that is the only value in the list.)

Anyway, running $make TARGET=mess I still get the same error as before.

Page 17 of 42 1 2 15 16 17 18 19 41 42

Link Copied to Clipboard
Who's Online Now
2 members (Pernod, Praxis), 32 guests, and 2 robots.
Key: Admin, Global Mod, Mod
ShoutChat
Comment Guidelines: Do post respectful and insightful comments. Don't flame, hate, spam.
Forum Statistics
Forums9
Topics8,957
Posts117,736
Members4,994
Most Online890
Jan 17th, 2020
Forum Host
These forums are hosted by www.retrogamesformac.com
Forum hosted by www.retrogamesformac.com