Previous Thread
Next Thread
Print Thread
Page 229 of 268 1 2 227 228 229 230 231 267 268
Re: PC/XT/AT (inside) WIP topic [Re: Kale] #94060 04/26/14 01:22 AM
Joined: Aug 2011
Posts: 499
M
MikeAbson Offline
Senior Member
Offline
Senior Member
M
Joined: Aug 2011
Posts: 499
I couldn't find that code in at.c, but in pc_joy.c. I've changed return 0xf0; to return 0xff; but it hasn't quite fixed the problem. Super Karts still detects the joystick at start up, but no longer hangs there, so I can get in to the menu now. NBA Jam TE won't go any further because it wants me to calibrate it, Wolfenstein 3D still detects it, as does Quake and Need For Speed. If I don't specify a sound card before starting MESS, the problem goes away. In my INI files, I've got Joystick set to 0.

Re: PC/XT/AT (inside) WIP topic [Re: Kale] #94130 04/28/14 06:38 PM
Joined: Jun 2001
Posts: 262
M
Malice Offline
Senior Member
Offline
Senior Member
M
Joined: Jun 2001
Posts: 262
I think i found one of the likely reasons at586 has trouble with some OS's. The ESCD is not being updated BIOS needs the ability to update this table.



Board 2 & 3 are fine there the PCI bridge and IDE controller. But board 1 is a sound card and board 4 is a video card. Which are not installed this can cause serious chaos.


The video card that is not installed happens to be a S3 Virge DX coincidentally smile



Re: PC/XT/AT (inside) WIP topic [Re: Kale] #94131 04/28/14 07:29 PM
Joined: Sep 2009
Posts: 239
D
Dr. Spankenstein Offline
Senior Member
Offline
Senior Member
D
Joined: Sep 2009
Posts: 239
Can anyone get Wolfenstein 3D to load on the 'at386' driver?

I am using MESS [r 30071] Windows 7 64-bit with the following command:

mess64 at386 -ramsize 15728640 -isa2 gus -harddisk1 "hd.chd".

The game executable 'WOLF3D.EXE' will run and get stuck instantly on a black screen.

The same game runs fine on the 'at486' driver but not at full speed with the sound enabled.

Re: PC/XT/AT (inside) WIP topic [Re: MikeAbson] #94143 04/30/14 08:57 AM
Joined: Nov 2003
Posts: 804
S
smf Offline
Senior Member
Offline
Senior Member
S
Joined: Nov 2003
Posts: 804
Originally Posted By MikeAbson
In my INI files, I've got Joystick set to 0.


That is completely irrelevant. That setting just tells MESS not to use real joysticks, it's nothing to do with emulating joysticks.

Re: PC/XT/AT (inside) WIP topic [Re: Dr. Spankenstein] #94147 04/30/14 09:50 AM
Joined: Aug 2011
Posts: 499
M
MikeAbson Offline
Senior Member
Offline
Senior Member
M
Joined: Aug 2011
Posts: 499
Originally Posted By Dr. Spankenstein
Can anyone get Wolfenstein 3D to load on the 'at386' driver?

I am using MESS [r 30071] Windows 7 64-bit with the following command:

mess64 at386 -ramsize 15728640 -isa2 gus -harddisk1 "hd.chd".

The game executable 'WOLF3D.EXE' will run and get stuck instantly on a black screen.

The same game runs fine on the 'at486' driver but not at full speed with the sound enabled.


I tried this as well and I've got the same issue on the 386 driver, although it should fine on the 486 driver with sound. Have you tried REMing out your EMM386 line and disabling vsync? That will really speed things up a bit.

Re: PC/XT/AT (inside) WIP topic [Re: smf] #94148 04/30/14 09:50 AM
Joined: Aug 2011
Posts: 499
M
MikeAbson Offline
Senior Member
Offline
Senior Member
M
Joined: Aug 2011
Posts: 499
Originally Posted By smf
Originally Posted By MikeAbson
In my INI files, I've got Joystick set to 0.


That is completely irrelevant. That setting just tells MESS not to use real joysticks, it's nothing to do with emulating joysticks.


My bad. Hopefully the rest was relevant enough.

Re: PC/XT/AT (inside) WIP topic [Re: MikeAbson] #94162 04/30/14 05:45 PM
Joined: Sep 2009
Posts: 239
D
Dr. Spankenstein Offline
Senior Member
Offline
Senior Member
D
Joined: Sep 2009
Posts: 239
Originally Posted By MikeAbson

Have you tried REMing out your EMM386 line and disabling vsync? That will really speed things up a bit.


I have done both. However, the GUS sound card doesn't appear to be detected properly by Wolfenstein with EMM disabled?

Originally Posted By MikeAbson

I tried this as well and I've got the same issue on the 386 driver


Has this bug been reported/logged via the correct channels?

Re: PC/XT/AT (inside) WIP topic [Re: Dr. Spankenstein] #94166 04/30/14 10:43 PM
Joined: Dec 2006
Posts: 528
M
mahlemiut Online Content
Senior Member
Online Content
Senior Member
M
Joined: Dec 2006
Posts: 528
Originally Posted By Dr. Spankenstein
I have done both. However, the GUS sound card doesn't appear to be detected properly by Wolfenstein with EMM disabled?


Wolfenstein 3D does not support the GUS. To get any sound, you'll need to run SBOS.


- Barry Rodewald
Re: PC/XT/AT (inside) WIP topic [Re: Kale] #94331 05/17/14 05:58 AM
Joined: Jun 2001
Posts: 262
M
Malice Offline
Senior Member
Offline
Senior Member
M
Joined: Jun 2001
Posts: 262
If any of the dev's are interested in emulating PNP monitor detection there maybe a simple way to reverse engineer it. There's a DOS port of a unix utility to read the edid table. And it works on the Diamond [S3 Virge DX] based card emulated by MESS, at least it works on real hardware with that card. Apparently some VESA 2 BIOS's implement the necessary functions.

http://www.polypux.org/projects/read-edid/

I have a few sample edid tables if needed. It is also possible to get your own edid table from the Windows registry.

http://www.sendspace.com/file/jwbfnk

Re: PC/XT/AT (inside) WIP topic [Re: Kale] #94333 05/17/14 01:04 PM
Joined: Mar 2001
Posts: 16,522
R
R. Belmont Online Content
Very Senior Member
Online Content
Very Senior Member
R
Joined: Mar 2001
Posts: 16,522
EDID should be fairly well documented. The problem is making monitors a slot device separate from the video output.

Page 229 of 268 1 2 227 228 229 230 231 267 268

Who's Online Now
1 registered members (Pernod), 50 guests, and 0 spiders.
Key: Admin, Global Mod, Mod
ShoutChat Box
Comment Guidelines: Do post respectful and insightful comments. Don't flame, hate, spam.
Forum Statistics
Forums9
Topics8,782
Posts115,562
Members4,908
Most Online890
Jan 17th, 2020
Powered by UBB.threads™ PHP Forum Software 7.7.3