Previous Thread
Next Thread
Print Thread
Joined: Jul 2013
Posts: 10
L
Member
OP Offline
Member
L
Joined: Jul 2013
Posts: 10
Hello everyone,

I think I found a bug in the vectrex emulation with mess / ume.
And this bug is present since at least version 147 (the oldest version I tested).

The bug occurs when I play with minestorm 2.
I made a video of these bugs: http://www.jammaplay.com/en/video-4KXRJP

As you can see, at 2m35, 5m23 and 6m22, the game freezes, the screen goes black and sound bugs occur.
And if I make no input during this time, the game continues normally.

But this is very frustrating: on the original hardware these bugs do not exist.

I do not know what may be causing the problem, but I am ready to help by doing all the tests that you ask me to do.

For information, I'm on linux and I compile myself my own version of EMU.

And from what I'm reading on the source code, Mathis Rosenhauer wrote the vectrex driver, but I can not find his email address.
Do you know where I can contact him ? Or does he visit this forum? Or someone knows him ?

Thank you very much.

PS : INP file url => http://www.filedropper.com/minestr2

Last edited by LA GLOBULE; 09/02/13 02:37 PM.
Joined: May 2004
Posts: 1,704
Likes: 2
H
Very Senior Member
Offline
Very Senior Member
H
Joined: May 2004
Posts: 1,704
Likes: 2
I think there might be some 6809 bugs still lurking. There are reports of some crashes / hangs with Qix, and now this..

to be expected when a CPU gets redone completely, try to find a version before the CPU core was rewritten (can't remember the version #)


Joined: Mar 2001
Posts: 16,910
Likes: 56
R
Very Senior Member
Offline
Very Senior Member
R
Joined: Mar 2001
Posts: 16,910
Likes: 56
0.147 is from September of 2012; the cycle-exact 6809 landed mid-March of 2013.

Joined: May 2004
Posts: 1,704
Likes: 2
H
Very Senior Member
Offline
Very Senior Member
H
Joined: May 2004
Posts: 1,704
Likes: 2
ah, yeah, can't be that then, I forgot our version number increased so slowly these days ;-)

Joined: Apr 2006
Posts: 733
D
Senior Member
Offline
Senior Member
D
Joined: Apr 2006
Posts: 733
I remember it flashes and that sound playing. I thought it the way it meant to be. I never own any of these games. Anyway thanks for reporting this issue.


Windows 10 Home 64-bit / AMD Radeon RX 5700 XT / AMD Ryzen 7 3700X 8-Core 3.59 GHz / RAM 16 GB

Link Copied to Clipboard
Who's Online Now
0 members (), 26 guests, and 1 robot.
Key: Admin, Global Mod, Mod
ShoutChat
Comment Guidelines: Do post respectful and insightful comments. Don't flame, hate, spam.
Forum Statistics
Forums9
Topics9,085
Posts119,077
Members5,014
Most Online890
Jan 17th, 2020
Our Sponsor
These forums are sponsored by Superior Solitaire, an ad-free card game collection for macOS and iOS. Download it today!

Superior Solitaire
Forum hosted by www.retrogamesformac.com