Previous Thread
Next Thread
Print Thread
Joined: Sep 2000
Posts: 231
W
will Offline OP
Senior Member
OP Offline
Senior Member
W
Joined: Sep 2000
Posts: 231
Noticed I am not getting any background video with the laserdisc games like Cube Quest and Us Vs Them with default OpenGL rendering. Software rendering works. Is anybody else seeing this? I'm on a new iMac Retina with AMD Radeon R9 M295X and wondering if it's a video driver issue?


=will=
Joined: Mar 2001
Posts: 16,614
R
Very Senior Member
Online Content
Very Senior Member
R
Joined: Mar 2001
Posts: 16,614
This is a known problem for -video opengl. -video soft works, as you said.

On SDL2 builds -video accel will also show laserdisc video correctly and even allows your GPU to accelerate it a little if the right OpenGL features are present.

Joined: Oct 2004
Posts: 93
Member
Offline
Member
Joined: Oct 2004
Posts: 93
Not always, most of the time I have a green dominant in OS X build.

Joined: Sep 2000
Posts: 231
W
will Offline OP
Senior Member
OP Offline
Senior Member
W
Joined: Sep 2000
Posts: 231
OK yes with -video accel the background video shows up but the normally blacked out sides of the screen flash black and white like crazy.

How is -video accel different from OpenGL? Aren't they both GPU accelerated?

I posted a video here. Anybody else having this? My old Mac Pro does it too.

http://youtu.be/bm4h7G-O4Mw


=will=
Joined: Oct 2004
Posts: 93
Member
Offline
Member
Joined: Oct 2004
Posts: 93
My late iMac 2009 doesn't show the video at all with OpenGL, work fine with last release and video -accel.

UME64 SDL2

Joined: Jan 2007
Posts: 213
M
Senior Member
Offline
Senior Member
M
Joined: Jan 2007
Posts: 213
I confirm that on my PowerMac G4 MDD (with ATI Radeon X800XT) the "-video accel" option allow the laserdisc stream to be displayed with the latest SDLmame 0.156 build.
The first couple of seconds is plagued by a flashing green dominant that completely disappear for the rest of gameplay. It happens on all lasergames supported in Mame.
On the other side my MacPro equipped with a ATI Radeon HD5870 and latest official SDL 2.0.3 intel framework does not exhibit any issue from the beginning of the gameplay.


Moderated by  R. Belmont 

Link Copied to Clipboard
Who's Online Now
1 members (Duke), 43 guests, and 2 robots.
Key: Admin, Global Mod, Mod
ShoutChat
Comment Guidelines: Do post respectful and insightful comments. Don't flame, hate, spam.
Forum Statistics
Forums9
Topics8,837
Posts116,231
Members4,921
Most Online890
Jan 17th, 2020
Powered by UBB.threads™ PHP Forum Software 7.7.5