Previous Thread
Next Thread
Print Thread
Page 4 of 4 1 2 3 4
Re: Atari 2600 with MAME controls issue. Joyport? [Re: Miah] #105558 05/13/16 11:34 AM
Joined: Oct 2014
Posts: 11
T
Tauwasser Offline
Member
Offline
Member
T
Joined: Oct 2014
Posts: 11
Clearly that's a pro-user feature, not an evil bug.


Re: Atari 2600 with MAME controls issue. Joyport? [Re: Miah] #105564 05/14/16 12:18 AM
Joined: Oct 2015
Posts: 26
M
Miah Offline OP
Member
OP Offline
Member
M
Joined: Oct 2015
Posts: 26
An example of a bug is that Golden Tee 2006 Complete stopped working in 173, as soon as you swing the club the game freezes.

But I'm not here looking for help with that smile

Last edited by Miah; 05/14/16 12:32 AM.
Re: Atari 2600 with MAME controls issue. Joyport? [Re: Miah] #105565 05/14/16 12:34 AM
Joined: Mar 2001
Posts: 16,522
R
R. Belmont Online Content
Very Senior Member
Online Content
Very Senior Member
R
Joined: Mar 2001
Posts: 16,522
Have you tried mapping the fire button in the Tab menu when you've switched to paddles?

Re: Atari 2600 with MAME controls issue. Joyport? [Re: Miah] #105566 05/14/16 02:05 AM
Joined: Apr 2006
Posts: 719
Tafoid Offline
Senior Member
Offline
Senior Member
Joined: Apr 2006
Posts: 719
Originally Posted By Miah
An example of a bug is that Golden Tee 2006 Complete stopped working in 173, as soon as you swing the club the game freezes.


MIPS issues should be fixed now for iteagle and other drivers which use it. MAME 0.173 went out the door with, unfortunately, some MIPS changes which were not fixed/reverted before the release day.




Re: Atari 2600 with MAME controls issue. Joyport? [Re: Miah] #105571 05/14/16 05:17 PM
Joined: Oct 2015
Posts: 26
M
Miah Offline OP
Member
OP Offline
Member
M
Joined: Oct 2015
Posts: 26
I appreciate the replies and help, but this is where I left off: http://forums.bannister.org/ubbthreads.php?ubb=showflat&Number=103830&page=all#Post105125

And if it's me I would appreciate knowing what I'm doing wrong. If it is indeed just still not working, that's cool, I just don't know.

Re: Atari 2600 with MAME controls issue. Joyport? [Re: Miah] #107846 11/07/16 06:01 PM
Joined: Oct 2015
Posts: 26
M
Miah Offline OP
Member
OP Offline
Member
M
Joined: Oct 2015
Posts: 26
Any updates on this?

Re: Atari 2600 with MAME controls issue. Joyport? [Re: Miah] #107849 11/07/16 09:14 PM
Joined: Dec 2015
Posts: 114
A
AJR Offline
Senior Member
Offline
Senior Member
A
Joined: Dec 2015
Posts: 114
Well, it seems that my impression that the ctrl_default feature hadn't actually been added to any MAME software lists was mistaken, as several entries in sms.xml include it. It worked exactly as designed from the command line, but not from the internal UI. I did a little testing to see what was the matter there, and I may be committing a fix soon.

Re: Atari 2600 with MAME controls issue. Joyport? [Re: AJR] #109956 06/20/17 10:32 PM
Joined: Oct 2015
Posts: 26
M
Miah Offline OP
Member
OP Offline
Member
M
Joined: Oct 2015
Posts: 26
Originally Posted by AJR
Well, it seems that my impression that the ctrl_default feature hadn't actually been added to any MAME software lists was mistaken, as several entries in sms.xml include it. It worked exactly as designed from the command line, but not from the internal UI. I did a little testing to see what was the matter there, and I may be committing a fix soon.


Been a while, just checking in again.

Page 4 of 4 1 2 3 4

Who's Online Now
1 registered members (Pernod), 50 guests, and 0 spiders.
Key: Admin, Global Mod, Mod
ShoutChat Box
Comment Guidelines: Do post respectful and insightful comments. Don't flame, hate, spam.
Forum Statistics
Forums9
Topics8,782
Posts115,562
Members4,908
Most Online890
Jan 17th, 2020
Powered by UBB.threads™ PHP Forum Software 7.7.3