Previous Thread
Next Thread
Print Thread
Page 2 of 3 1 2 3
Joined: Jun 2001
Posts: 63
O
Member
Offline
Member
O
Joined: Jun 2001
Posts: 63
will: do you have the "shaders" directory and its contents? Otherwise bgfx will segfault.

Joined: Dec 2011
Posts: 25
M
Member
Offline
Member
M
Joined: Dec 2011
Posts: 25
i kinda figured out what is going on.

usually my mame64 binary is located in /usr/local/bin
and all my mame related files are located in /media/emu/mame
and the mame.ini and ui.ini is located in $HOME/.mame

this way mame64 insta segfaults.

if i move mame64 binary to the rest of the mame related files into /media/emu/mame
and open a console and change to that directory mame64 starts and works like a charm with -video bgfx

putting /media/emu/mame into the search path and have mame64 binary in /usr/local/bin leads to insta segfault again

putting mame64 binary in /usr/local/bin and move everything from /media/emu/mame into /home/.mame lead into insta segfault again

why mame behaves like this, i dont know but since scenario 1 makes mame work like expected im fine now smile


edit: typos

Last edited by minireaper; 02/18/16 08:51 PM.
Joined: Mar 2007
Posts: 238
T
Senior Member
Offline
Senior Member
T
Joined: Mar 2007
Posts: 238
Cool stuff... it seems that having mt enabled with bgfx driver is necessary to achieve the performance gains it boasts, so shouldn't that boolean default to enabled now inside mame unless specifically disabled?

Code:
$ mame64 -video opengl -resolution0 1280x960 -resolution1 1280x960 -nothrottle -str 50 tbowl
Average speed: 120.04% (49 seconds)

$ mame64 -video bgfx -resolution0 1280x960 -resolution1 1280x960 -nothrottle -str 50 tbowl
Average speed: 100.00% (49 seconds)

$ mame64 -video bgfx -mt -resolution0 1280x960 -resolution1 1280x960 -nothrottle -str 50 tbowl
Average speed: 1200.42% (49 seconds)

And where do I go to find how to use the bgfx effects and shaders? I must be blind. confused

Joined: Apr 2006
Posts: 728
D
Senior Member
Offline
Senior Member
D
Joined: Apr 2006
Posts: 728
I think there aren't any shaders for the bgfx yet.

Last edited by R. Belmont; 03/31/16 11:12 PM. Reason: False. Pointing out errors.

Windows 10 Home 64-bit / AMD Radeon RX 5700 XT / AMD Ryzen 7 3700X 8-Core 3.59 GHz / RAM 16 GB
Joined: Aug 2015
Posts: 40
C
Member
Offline
Member
C
Joined: Aug 2015
Posts: 40
I just got it working.

Code:
./mamearcade64 -video bgfx -bgfx_backend opengl -bgfx_screen_chains hlsl blktiger

Then hit tab and go down to slider options and enable a screen to mess around with it.

Now all I need are some good settings and a way to save that

hlsl_enable in mame.ini doesn't do it

Last edited by ChoccyHobNob; 03/31/16 10:10 PM.
Joined: Mar 2001
Posts: 16,892
Likes: 51
R
Very Senior Member
Offline
Very Senior Member
R
Joined: Mar 2001
Posts: 16,892
Likes: 51
Arrrrgh.

1) BGFX has shaders built-in. You don't need to add any. -bgfx_screen_chains selects the effects: see http://docs.mamedev.org/advanced/bgfx.html for full details.
2) -mt is bad. We had voted to remove it but somehow that didn't make it into the shipping version. If your computer rm -rf / 's with it on, we warned you.
3) bgfx_path lets you set where to find the BGFX support files.

Last edited by R. Belmont; 03/31/16 11:17 PM.
Joined: Mar 2007
Posts: 238
T
Senior Member
Offline
Senior Member
T
Joined: Mar 2007
Posts: 238
Yeah, -mt is gone, good. My posting predates 0.172 release. whistle
Thanks for the link and the incredulous work done in this release. smile

Last edited by The Flying Ape; 04/01/16 12:45 AM.
Joined: Feb 2004
Posts: 2,344
Likes: 61
Very Senior Member
OP Online Content
Very Senior Member
Joined: Feb 2004
Posts: 2,344
Likes: 61
My ageing notebook's NVIDIA GT330M isn't up to running the hlsl screen chain without massive frameskip, either. But it's wicked fast on my dual Quadro workstation, far better than D3D HLSL ever was.

Joined: Jul 2010
Posts: 23
Z
Member
Offline
Member
Z
Joined: Jul 2010
Posts: 23
I am testing 0.172 version with BGFX and my experience is:

With puckman (no throttle) perfomance drops from 540% to 50% when I enable adjustments.
With OpenGL I get 1780% without shaders and 209% with old glsl (CRT-geom-halation)

Also NTSC does not work here (black screen).

My computer runs Arch Linux with NVIDIA GT620 and I am using NVIDIA's proprietary driver 361.28. (With Nouveau drivers perfomance is worse as expected)

Does anybody gets the same (more or less) perfomance on Linux?

Joined: Aug 2015
Posts: 40
C
Member
Offline
Member
C
Joined: Aug 2015
Posts: 40
I'm getting similar results on a Mid 2013 Macbook Air (1.7 Core i7, 8GB)
Code:
 ./mame64 -video opengl -resolution0 1440x900 -nothrottle -str 50 puckman
Average speed: 450.85% (49 seconds)

and
Code:
 ./mame64 -video bgfx -resolution0 1440x900 -nothrottle -str 50 puckman
Average speed: 130.31% (49 seconds)

Page 2 of 3 1 2 3

Moderated by  R. Belmont 

Link Copied to Clipboard
Who's Online Now
2 members (MAMEBase, Carbon), 12 guests, and 2 robots.
Key: Admin, Global Mod, Mod
ShoutChat
Comment Guidelines: Do post respectful and insightful comments. Don't flame, hate, spam.
Forum Statistics
Forums9
Topics9,070
Posts118,935
Members5,014
Most Online890
Jan 17th, 2020
Our Sponsor
These forums are sponsored by Superior Solitaire, an ad-free card game collection for macOS and iOS. Download it today!

Superior Solitaire
Forum hosted by www.retrogamesformac.com