Previous Thread
Next Thread
Print Thread
Page 3 of 3 1 2 3
Re: Compile fails for MAME 0.202 on macOS 10.14 Mojave [Re: Carbon] #114009 09/28/18 02:52 PM
Joined: May 1999
Posts: 575
Carbon Offline OP
Senior Member
OP Offline
Senior Member
Joined: May 1999
Posts: 575
Yep, I can confirm it builds fine now. Thanks!

Re: Compile fails for MAME 0.202 on macOS 10.14 Mojave [Re: R. Belmont] #114010 09/28/18 03:07 PM
Joined: May 2016
Posts: 31
L
Llaffer Offline
Member
Offline
Member
L
Joined: May 2016
Posts: 31
Originally Posted by R. Belmont
Here's the change: https://github.com/mamedev/mame/commit/bb2eaa50ffe2bfbfc8db30be78170e80f843aa1e

As you can see, it's a simple search-and-replace of "10.4" to "10.6" (Mojave removed the ability to build 32-bit and so the minimum target OS available bumped up from Tiger to Snow Leopard). This should work all the way back to Snow Leopard, compiler permitting.

Thanks. I've been following this thread since I had the same problem smile

Re: Compile fails for MAME 0.202 on macOS 10.14 Mojave [Re: Carbon] #114012 09/29/18 03:57 AM
Joined: Jul 2007
Posts: 220
M
Monotremata Offline
Senior Member
Offline
Senior Member
M
Joined: Jul 2007
Posts: 220
Weird I was about to chime in and say mine built just fine yesterday thinking I was up to date on everything.. When I went to check the version, it seems Xcode has somehow completely disappeared from my system, yet the command line tools are installed and .202 built just fine over here??

Page 3 of 3 1 2 3

Who's Online Now
1 registered members (Pernod), 50 guests, and 0 spiders.
Key: Admin, Global Mod, Mod
ShoutChat Box
Comment Guidelines: Do post respectful and insightful comments. Don't flame, hate, spam.
Forum Statistics
Forums9
Topics8,782
Posts115,562
Members4,908
Most Online890
Jan 17th, 2020
Powered by UBB.threads™ PHP Forum Software 7.7.3