Previous Thread
Next Thread
Print Thread
Page 31 of 40 1 2 29 30 31 32 33 39 40
Re: Can't compile latest MESS? READ THIS THREAD [Re: Just Desserts] #103715 01/18/16 09:31 PM
Joined: Aug 2015
Posts: 381
Edstrom Offline
Senior Member
Offline
Senior Member
Joined: Aug 2015
Posts: 381
RB: Thanks for the tip! :-)

For the interested reader I can point out that the layout_filename really IS the unquoted symbolname created by concatenating "layout_" and the prefix of the layout filename, in my case layout_mp68a and layout_md6802. The symbol is created by the make system by parsing the layout file into the .lh file. There is no compile error trying a string or some other ignorance. The next thing to lookout for is the -debug switch that seems to block the late binding of the 7seg IF more than one machine driver is provided in the build and the selection menu appears. Then you need to explicit say which driver to debug on the command line, for example:

Code:
./didact64d mp68a -window -debug

Re: Can't compile latest MESS? READ THIS THREAD [Re: Just Desserts] #103716 01/18/16 10:00 PM
Joined: Mar 2001
Posts: 16,390
R
R. Belmont Offline
Very Senior Member
Offline
Very Senior Member
R
Joined: Mar 2001
Posts: 16,390
Yeah. Single-driver builds are more accurately single-driver file builds; you get all the drivers in the driver .cpp so you still have to specify the game name on the command line.

Re: Can't compile latest MESS? READ THIS THREAD [Re: Breiztiger] #103758 01/22/16 05:18 PM
Joined: Nov 2010
Posts: 84
Breiztiger Online Content
Member
Online Content
Member
Joined: Nov 2010
Posts: 84
sorry for my ignorance but ...

i got a

'head' n'est pas reconnu en tant que commande interne
ou externe, un programme exécutable ou un fichier de commandes.
GCC 4.9.1 detected
Building configurations...

...

makefile:830: recipe for target 'windows_x64' failed
make: *** [windows_x64] Error 2

with mingw env

my last good compilation is from 3 january 2016

can someone tell me what i can change to compil again ;-)

thanks in advance

Re: Can't compile latest MESS? READ THIS THREAD [Re: Just Desserts] #103759 01/22/16 05:30 PM
Joined: Mar 2001
Posts: 16,390
R
R. Belmont Offline
Very Senior Member
Offline
Very Senior Member
R
Joined: Mar 2001
Posts: 16,390
You aren't using the latest Windows tools, which are GCC 5.3.1.

Re: Can't compile latest MESS? READ THIS THREAD [Re: Just Desserts] #103760 01/22/16 05:51 PM
Joined: Jan 2012
Posts: 814
C
crazyc Online Content
Senior Member
Online Content
Senior Member
C
Joined: Jan 2012
Posts: 814
Even with the newest tools I've found win32 make sometimes fails for no reason. If there was no other error just try running make again and see if it finishes.

Re: Can't compile latest MESS? READ THIS THREAD [Re: Just Desserts] #103790 01/24/16 09:13 AM
Joined: Nov 2010
Posts: 84
Breiztiger Online Content
Member
Online Content
Member
Joined: Nov 2010
Posts: 84
hi

thanks for the reply

i'd go from mingw to msys64, after some path tweak of my batch, compilation work again ;-)

i have sometime also make errors but retry and pass like crazyc

thanks a lot !!!

Re: Can't compile latest MESS? READ THIS THREAD [Re: Just Desserts] #103817 01/26/16 01:31 PM
Joined: Aug 2012
Posts: 65
arcadefan Offline
Member
Offline
Member
Joined: Aug 2012
Posts: 65
I'm also having trouble compiling.
I get the following with the current build tools:

Code:
make -j9 USE_NETWORK=1 sse4=1 PTR64=1 NOWERROR=1


Code:
../../../../../src/emu/luaengine.cpp: In member function 'void lua_engine::start_console()':
../../../../../src/emu/luaengine.cpp:1026:2: error: 'thread' is not a member of 'std'
  std::thread th(::serve_lua, this);
  ^
../../../../../src/emu/luaengine.cpp:1027:2: error: 'th' was not declared in this scope
  th.detach();
  ^
../../../../../src/emu/luaengine.cpp: At global scope:
../../../../../src/emu/luaengine.cpp:864:14: warning: 'void* serve_lua(void*)' defined but not used [-Wunused-function]
 static void *serve_lua(void *param)
              ^
make[2]: *** [../../../../mingw-gcc/obj/x64/Release/src/emu/luaengine.o] Error 1
make[1]: *** [emu] Error 2


Near the beginning I notice this:

Code:
emu.make:1286: recipe for target '../../../../mingw-gcc/obj/x64/Release/src/emu/luaengine.o' failed

Re: Can't compile latest MESS? READ THIS THREAD [Re: Just Desserts] #103822 01/26/16 07:29 PM
Joined: Aug 2012
Posts: 65
arcadefan Offline
Member
Offline
Member
Joined: Aug 2012
Posts: 65
bump

Re: Can't compile latest MESS? READ THIS THREAD [Re: arcadefan] #103823 01/26/16 07:40 PM
Joined: Jun 2001
Posts: 44
O
Osso Offline
Member
Offline
Member
O
Joined: Jun 2001
Posts: 44
you have outdated build tools. Download the latest from https://github.com/mamedev/buildtools

Re: Can't compile latest MESS? READ THIS THREAD [Re: Just Desserts] #104236 02/24/16 09:15 PM
Joined: Aug 2012
Posts: 65
arcadefan Offline
Member
Offline
Member
Joined: Aug 2012
Posts: 65
Using the commandline:

Code:
make -j9 NOWERROR=1 PTR64=1 sse4=1 USE_NETWORK=1


I get the following when it tries to link the executable:

Code:
Linking mame64.exe...
../../../../mingw-gcc/bin/x64/Release/mame_mame/libseibu.a: file not recognized: File format not recognized
collect2.exe: error: ld returned 1 exit status
mame.make:228: recipe for target '../../../../../mame64.exe' failed
make[2]: *** [../../../../../mame64.exe] Error 1
Makefile:952: recipe for target 'mame' failed
make[1]: *** [mame] Error 2
makefile:847: recipe for target 'windows_x64' failed
make: *** [windows_x64] Error 2


Any ideas?

Page 31 of 40 1 2 29 30 31 32 33 39 40

Who's Online Now
1 registered members (Pernod), 179 guests, and 2 spiders.
Key: Admin, Global Mod, Mod
ShoutChat Box
Comment Guidelines: Do post respectful and insightful comments. Don't flame, hate, spam.
Forum Statistics
Forums9
Topics8,722
Posts114,633
Members4,873
Most Online510
Aug 26th, 2019
Powered by UBB.threads™ PHP Forum Software 7.7.3