Previous Thread
Next Thread
Print Thread
Page 53 of 55 1 2 51 52 53 54 55
Re: 8bit Apples - Apple I, II, /// and the 16 bit GS [Re: rfka01] #116892 02/20/20 08:02 AM
Joined: Jan 2012
Posts: 1,077
rfka01 Offline OP
Very Senior Member
OP Offline
Very Senior Member
Joined: Jan 2012
Posts: 1,077
I've read that one generation of these GTAC ("General Taiwanese Apple Clone") boards omits slot 4 to signal that the Z80 is mapped there.


NCR DMV- DEC Rainbow- Siemens PCD- ITT 3030-Oly People- Acorn A5000- Olivetti M20
Re: 8bit Apples - Apple I, II, /// and the 16 bit GS [Re: rfka01] #117010 03/08/20 04:31 AM
Joined: Mar 2001
Posts: 16,523
R
R. Belmont Offline
Very Senior Member
Offline
Very Senior Member
R
Joined: Mar 2001
Posts: 16,523
GSPlus-compatible host file I/O is starting to work in the IIgs driver for the ProDOS 8 version of the protocol. Here's BASIC.SYSTEM CATALOGing MAME's src/devices/bus directory.

[Linked Image from rbelmont.mameworld.info]

Re: 8bit Apples - Apple I, II, /// and the 16 bit GS [Re: rfka01] #117272 04/26/20 06:25 PM
Joined: Mar 2001
Posts: 16,523
R
R. Belmont Offline
Very Senior Member
Offline
Very Senior Member
R
Joined: Mar 2001
Posts: 16,523
Just missed the 0.221 branch, but monochrome output for all 8 bit Apple II video modes is now fixed to be correct and compatible with the NTSC decoder in our HLSL shader (both the original and BGFX versions).

To use it, run -video bgfx, change the system configuration monitor type to Black and White.

Next, go to the Sliders menu, change the screen effect to HLSL, set NTSC A and B Value to 0, set NTSC Scanline Duration to 39.1, and set Enable NTSC to On.

That will change this

[Linked Image from rbelmont.mameworld.info]

into this

[Linked Image from rbelmont.mameworld.info]

Re: 8bit Apples - Apple I, II, /// and the 16 bit GS [Re: rfka01] #117273 04/26/20 07:20 PM
Joined: Mar 2002
Posts: 1,155
H
hap Offline
Very Senior Member
Offline
Very Senior Member
H
Joined: Mar 2002
Posts: 1,155
They must have used some gfx tool for it, but still that's nice trickery =)

Re: 8bit Apples - Apple I, II, /// and the 16 bit GS [Re: rfka01] #117274 04/26/20 07:29 PM
Joined: Mar 2001
Posts: 16,523
R
R. Belmont Offline
Very Senior Member
Offline
Very Senior Member
R
Joined: Mar 2001
Posts: 16,523
There were paint programs that did 16-color double-hi-res (what's shown here) back in the day, as long as you had an NTSC color monitor.

This wasn't like the CGA situation where you could manipulate it for fun; artifact color was the only color on the 8-bit Apple IIs.

Re: 8bit Apples - Apple I, II, /// and the 16 bit GS [Re: rfka01] #117276 04/27/20 08:37 AM
Joined: Feb 2004
Posts: 2,152
Vas Crabb Online Content
Very Senior Member
Online Content
Very Senior Member
Joined: Feb 2004
Posts: 2,152
Yeah, something a lot of people don’t seem to realise is that the 8-bit Apple IIs didn’t actually produce colour video as such. They produced monochrome with the horizontal resolution selected so you could produce something close enough to the NTSC colour subcarrier frequency using patterns of alternating black and white pixels. It’s the kind of hardware minimising trick Woz loved to do.

Anyway, it’s been cherry-picked for 0.221, so you won’t have to wait an extra month if you work with tagged releases.

Re: 8bit Apples - Apple I, II, /// and the 16 bit GS [Re: rfka01] #117277 04/27/20 11:41 AM
Joined: Mar 2001
Posts: 16,523
R
R. Belmont Offline
Very Senior Member
Offline
Very Senior Member
R
Joined: Mar 2001
Posts: 16,523
Thanks Vas, I appreciate it smile

Re: 8bit Apples - Apple I, II, /// and the 16 bit GS [Re: R. Belmont] #117395 05/31/20 11:22 PM
Joined: Oct 2015
Posts: 21
R
robj Offline
Member
Offline
Member
R
Joined: Oct 2015
Posts: 21
Originally Posted by R. Belmont
Great. I've checked in a fix that should prevent the debugger from stomping most of the read-activated soft switches.


I noticed something when trying to do some debugging with the Apple /// recently, seems the C100-C4FF slot roms are not working correctly. Looks like its just returning 0xff always when debugging.

Re: 8bit Apples - Apple I, II, /// and the 16 bit GS [Re: rfka01] #117396 06/01/20 03:31 AM
Joined: Mar 2001
Posts: 16,523
R
R. Belmont Offline
Very Senior Member
Offline
Very Senior Member
R
Joined: Mar 2001
Posts: 16,523
Got a bit overzealous when I fixed the debugger not touching softswitches. Fixed in https://github.com/mamedev/mame/commit/4c67903fb1ed1ef141817791ddd83ce09cb0678e if you compile your own, or else it'll be in MAME 0.222 at the end of June.

Re: 8bit Apples - Apple I, II, /// and the 16 bit GS [Re: R. Belmont] #117397 06/01/20 10:50 AM
Joined: Feb 2014
Posts: 384
G
Golden Child Offline
Senior Member
Offline
Senior Member
G
Joined: Feb 2014
Posts: 384
Hi Arbee,

I saw the hlsl stuff which looks super neat and was keen to try it, but when NTSC is enabled in the hlsl filter under Ubuntu, the screen just goes black.

My integrated graphics probably doesn't have the horsepower to drive the hlsl filter, but had to try it anyway 8-)

Page 53 of 55 1 2 51 52 53 54 55

Who's Online Now
1 registered members (Praxis), 57 guests, and 2 spiders.
Key: Admin, Global Mod, Mod
ShoutChat Box
Comment Guidelines: Do post respectful and insightful comments. Don't flame, hate, spam.
Forum Statistics
Forums9
Topics8,783
Posts115,580
Members4,908
Most Online890
Jan 17th, 2020
Powered by UBB.threads™ PHP Forum Software 7.7.3