Previous Thread
Next Thread
Print Thread
Page 2 of 2 1 2
Re: compile error [Re: oddi] #108805
02/10/17 02:45 PM
02/10/17 02:45 PM
Joined: May 2008
Posts: 4,892
Germany
Q
qmc2 Offline
Very Senior Member
qmc2  Offline
Very Senior Member
Q
Joined: May 2008
Posts: 4,892
Germany
There is nothing to fix. Sorry. It works with latest MSYS2 as I said above.


A mind is like a parachute. It doesn't work unless it's open. [Frank Zappa]

We're searching for QMC2 translators and support for existing translations. Interested? See here!
Re: compile error [Re: oddi] #108806
02/10/17 03:44 PM
02/10/17 03:44 PM
Joined: Nov 2011
Posts: 165
O
oddi Offline OP
Senior Member
oddi  Offline OP
Senior Member
O
Joined: Nov 2011
Posts: 165
ok
tested 3 separate systems - 2 x win10x64 , win7 x64 ( not LINUX )

mamedev tools 20170205 - full updated

download clean copy of qmc2 r7934.

results :

msys2:
Code:
oddi@DESKTOP-A0234NI MSYS /c
$ cd /c/msys64/src/qmc2

oddi@DESKTOP-A0234NI MSYS /c/msys64/src/qmc2
$ make
lrelease data/lng/qmc2_de.ts
make: lrelease: Command not found
make: *** [Makefile:1461: data/lng/qmc2_de.qm] Error 127

oddi@DESKTOP-A0234NI MSYS /c/msys64/src/qmc2
$



for test
mingw64:

now compile fine !!! and i'm wonder oО

previously had a problem with qmc2 and then you do not believe me, but I was right.
Now - I'm again right.

3 different systems - one result -> qmc2 have problem !!!

and second problem : compile qmc2 with previous mamedev tools - tottaly crashed ( take libraries from this pack) !!!!!!

open NOTES - crashed
open PDF viewer - crashed
cache icons - crashed
that is

Last edited by oddi; 02/10/17 03:45 PM.
Re: compile error [Re: oddi] #108808
02/10/17 03:51 PM
02/10/17 03:51 PM
Joined: May 2008
Posts: 4,892
Germany
Q
qmc2 Offline
Very Senior Member
qmc2  Offline
Very Senior Member
Q
Joined: May 2008
Posts: 4,892
Germany
But that's a completely different error above. It can't find "lrelease". I'm not sure which package or path this is in. It *should* be in one of the paths of your $PATH variable.

My installation doesn't show any issues here. So I'm also right smile.

And you're confusing me when you say "now compile fine !!!" in between. Does it work for you or doesn't it?

Also, I see zero crashes here.


A mind is like a parachute. It doesn't work unless it's open. [Frank Zappa]

We're searching for QMC2 translators and support for existing translations. Interested? See here!
Re: compile error [Re: oddi] #108809
02/10/17 04:35 PM
02/10/17 04:35 PM
Joined: Nov 2011
Posts: 165
O
oddi Offline OP
Senior Member
oddi  Offline OP
Senior Member
O
Joined: Nov 2011
Posts: 165
Heheh :))
me too confused because i tested with different svn revisions smile
Now - with r7934 (the last).

with msys2 : not compile , see above .
with mingw64: compile fine

but problem with crash is stay :
i take qmc2.exe and all libraries for standalone installation .
All dlls i take from the last mamedev tools. start config from scratch and:

when open tab NOTES - qmc2.exe crashed
open PDF viewers - qmc2.exe crashed
start cached icons - qmc2.crashed.

here upload my build, see, may u found something.
http://www55.zippyshare.com/v/pELiRyY1/file.html

many tnx smile

Re: compile error [Re: oddi] #108810
02/10/17 05:56 PM
02/10/17 05:56 PM
Joined: May 2008
Posts: 4,892
Germany
Q
qmc2 Offline
Very Senior Member
qmc2  Offline
Very Senior Member
Q
Joined: May 2008
Posts: 4,892
Germany
OK, so it *builds* when you're using the right environment... good. I'm still not sure what you mean with "mingw64" vs. "msys2". You're supposed to use mingw64 from msys2.

Anyway, I can't help you with your crash though. There's probably some library conflict (or a missing one for QtWebKit which is dlopen()'ed?). It works fine with the official build (VC++). That's the only method allowed to report crashes on Windows smile.


A mind is like a parachute. It doesn't work unless it's open. [Frank Zappa]

We're searching for QMC2 translators and support for existing translations. Interested? See here!
Re: compile error [Re: oddi] #108814
02/10/17 06:57 PM
02/10/17 06:57 PM
Joined: Apr 2011
Posts: 287
B2K24 Online happy
Senior Member
B2K24  Online Happy
Senior Member
Joined: Apr 2011
Posts: 287
Maybe it's best to just stick with what's officially released wink

It's what I do and all is fine.

Re: compile error [Re: oddi] #108818
02/10/17 08:23 PM
02/10/17 08:23 PM
Joined: Nov 2011
Posts: 165
O
oddi Offline OP
Senior Member
oddi  Offline OP
Senior Member
O
Joined: Nov 2011
Posts: 165
pfffff troll !!


tnx Rene, thread closed.

Re: compile error [Re: oddi] #110682
08/29/17 11:19 AM
08/29/17 11:19 AM
Joined: May 2008
Posts: 4,892
Germany
Q
qmc2 Offline
Very Senior Member
qmc2  Offline
Very Senior Member
Q
Joined: May 2008
Posts: 4,892
Germany
FWIW, I've "fixed" the build-issues with the newer MAME-dev tools (SVN r8100+). Please carefully read the updated build instructions in our wiki!


A mind is like a parachute. It doesn't work unless it's open. [Frank Zappa]

We're searching for QMC2 translators and support for existing translations. Interested? See here!
Re: compile error [Re: oddi] #110730
09/05/17 03:32 PM
09/05/17 03:32 PM
Joined: Nov 2011
Posts: 165
O
oddi Offline OP
Senior Member
oddi  Offline OP
Senior Member
O
Joined: Nov 2011
Posts: 165
Hi Rene, i'm back to the front smile
Compile with QT5 , libraries it's differents from qt4.
Create standalone installation, maybe all it's fine, but i'm not sure , please check my setup and tell me if have any problem .

here upload build QMC2_x64_r8130.ZIP

http://www61.zippyshare.com/v/A8EK8kQR/file.html

Many tnx smile

Re: compile error [Re: oddi] #110733
09/05/17 04:20 PM
09/05/17 04:20 PM
Joined: May 2008
Posts: 4,892
Germany
Q
qmc2 Offline
Very Senior Member
qmc2  Offline
Very Senior Member
Q
Joined: May 2008
Posts: 4,892
Germany
I don't know if you have any problems wink , only when you use Qt 5 now, you can't simply go back to Qt 4 because of the changed ini-format.

It should work more or less fine with Qt 5, but it's not "official" yet, so if you see issues you're "on your own" at the moment. I try to keep Qt 5 support clean, but I can't promise always.

When Qt 5.10 will include QtWebKit officially (I get the impression it will), then this will be the right time to switch to Qt 5 completely.


A mind is like a parachute. It doesn't work unless it's open. [Frank Zappa]

We're searching for QMC2 translators and support for existing translations. Interested? See here!
Page 2 of 2 1 2

Moderated by  qmc2 

Who's Online Now
2 registered members (Aurel, Reznor007), 58 guests, and 3 spiders.
Key: Admin, Global Mod, Mod
Shout Box
Forum Statistics
Forums9
Topics8,566
Posts111,891
Members4,805
Most Online225
May 26th, 2014
Powered by UBB.threads™ PHP Forum Software 7.6.1.1
(Release build 20180111)
Page Time: 0.032s Queries: 14 (0.013s) Memory: 5.7215 MB (Peak: 5.9443 MB) Zlib enabled. Server Time: 2018-08-19 21:43:54 UTC