Previous Thread
Next Thread
Print Thread
TI99/4A ROMs Not Found! #110471 08/01/17 06:58 PM
Joined: Oct 2010
Posts: 12
S
swallis Offline OP
Member
OP Offline
Member
S
Joined: Oct 2010
Posts: 12
My "TI99/4A Home Comuter" ROMs used to work when I used MESS 0.140
They are all in: \MESS\roms\ti99_4a.zip

994agrom.bin 24,576 bytes
994arom.bin 8,192 bytes

I also have other TI99/4A ROMs in my zip file that I don't think are needed to start the TI99/4A:

bwg.bin 32,768 bytes
disk.bin 8,192
hfdc.bin 16,384
pcode_g0.bin 65,536
pcode_r0.bin 4,096
pcode_r1.bin 8,192
rs232.bin 4,096
spchrom.bin 32,768

I have tried MESS 0.188, 0,187, 0,175, 0.170, 0.165 and 0.160 from http://www.progettosnaps.net/messui/
These versions all do the same thing...
"TI99/4A Home Computer" is marked as unavailable, and
when I audit the roms it says "ti99_4a: Romset NOT FOUND".

Last edited by swallis; 08/01/17 06:59 PM.
Re: TI99/4A ROMs Not Found! [Re: swallis] #110472 08/01/17 07:29 PM
Joined: May 2004
Posts: 1,602
H
Haze Offline
Very Senior Member
Offline
Very Senior Member
H
Joined: May 2004
Posts: 1,602
D:\mame2017\master>mame64 ti99_4a -listroms
ROMs required for driver "ti99_4a".
Name Size Checksum
994a_rom_hb.u610 4096 CRC(ee859c5f) SHA1(a45245707c3dccea902b718554a882d214a82504)
994a_rom_lb.u611 4096 CRC(37859301) SHA1(f4e774fd5913b387a763f1b8de5524c54b255434)
994a_grom0.u500 6144 CRC(2445a5e8) SHA1(ea15d8b0ac52112dc0d5f4ab9a79ac8ca1cc1bbc)
994a_grom1.u501 6144 CRC(b8f367ab) SHA1(3ecead4b83ec525084c70b6123d4053f8a80e1f7)
994a_grom2.u502 6144 CRC(e0bb5341) SHA1(e255f0d65d69b927cecb8fcfac7a4c17d585ea96)

Re: TI99/4A ROMs Not Found! [Re: swallis] #110473 08/01/17 10:00 PM
Joined: Oct 2010
Posts: 12
S
swallis Offline OP
Member
OP Offline
Member
S
Joined: Oct 2010
Posts: 12
I wasn't sure if TI99/4A was currently broken or not.
I guess you can't use MESSUI64 to -listroms

Thank you.

Last edited by swallis; 08/01/17 10:05 PM.
Re: TI99/4A ROMs Not Found! [Re: swallis] #110474 08/01/17 10:55 PM
Joined: Apr 2006
Posts: 715
Tafoid Offline
Senior Member
Offline
Senior Member
Joined: Apr 2006
Posts: 715
I believe you can select the machine and right click and choose "Audit". That should tell you what is missing. MAMEUI used to be able to, anyway.




Re: TI99/4A ROMs Not Found! [Re: swallis] #110475 08/01/17 11:41 PM
Joined: Mar 2001
Posts: 16,421
R
R. Belmont Online Content
Very Senior Member
Online Content
Very Senior Member
R
Joined: Mar 2001
Posts: 16,421
It's working (and it's probably one of the most complete drivers in MAME). It's just the required ROMs were changed several years ago to represent the actual chips, which in turn means TI owners can use the MAME files to repair their hardware. ROMs can develop "bit rot" over 40+ years.

Re: TI99/4A ROMs Not Found! [Re: swallis] #110493 08/03/17 05:42 PM
Joined: May 2007
Posts: 549
M
mizapf Offline
Senior Member
Offline
Senior Member
M
Joined: May 2007
Posts: 549
Well, yes, 0.140 is some time away ... to catch up, you may want to have a look at http://www.ninerpedia.org/index.php?title=MESS_version_history

You can find the current ROMs on the FTP server of whtech. Or send me a PM.

Re: TI99/4A ROMs Not Found! [Re: swallis] #110501 08/04/17 02:50 AM
Joined: Oct 2010
Posts: 12
S
swallis Offline OP
Member
OP Offline
Member
S
Joined: Oct 2010
Posts: 12
I have the proper roms now, thanks for your help!


Who's Online Now
2 registered members (AJR, Luengo), 359 guests, and 3 spiders.
Key: Admin, Global Mod, Mod
ShoutChat Box
Comment Guidelines: Do post respectful and insightful comments. Don't flame, hate, spam.
Forum Statistics
Forums9
Topics8,734
Posts114,832
Members4,879
Most Online890
Jan 17th, 2020
Powered by UBB.threads™ PHP Forum Software 7.7.3