Previous Thread
Next Thread
Print Thread
Page 4 of 7 1 2 3 4 5 6 7
Joined: Mar 2002
Posts: 1,217
Likes: 2
H
hap Offline
Very Senior Member
Offline
Very Senior Member
H
Joined: Mar 2002
Posts: 1,217
Likes: 2
Thanks, it says the Z80 runs at 4.1MHz which makes the strange /7 frequency divider plausible.
30KB RAM total (15 SRAM chips of 2KB each)

Is this video yours?

You can indeed see the 15 SRAM chips, the chip next to the Z80 is probably the BIOS ROM. The 3 QFP are mentioned in the manual as "ATC"(?), I/O, and VRAM controller.

Joined: Aug 2015
Posts: 23
Likes: 1
H
Member
Offline
Member
H
Joined: Aug 2015
Posts: 23
Likes: 1
That's not my video but he is the one I asked about his Pro Wrestling cart.

Joined: Aug 2015
Posts: 23
Likes: 1
H
Member
Offline
Member
H
Joined: Aug 2015
Posts: 23
Likes: 1
What would be helpful in regards to getting the colors corrected?

Joined: Mar 2001
Posts: 16,840
Likes: 45
R
Very Senior Member
Offline
Very Senior Member
R
Joined: Mar 2001
Posts: 16,840
Likes: 45
Screenshots or video of running games would be the biggest help.

Joined: Aug 2015
Posts: 23
Likes: 1
H
Member
Offline
Member
H
Joined: Aug 2015
Posts: 23
Likes: 1
Gotcha I can do that.

Robbbert it looks like you got Sekigahara working correct? Did you get a chance to mess with the 8K dumps of Motocross yet to see if they work as well? No rush just mainly asking as in order to get gameplay video/pics to help with the emulation I'll need to reseat and resolder the chips and would like to make sure those dumps look good before I do that.

Joined: Aug 2004
Posts: 1,445
Likes: 6
Very Senior Member
Offline
Very Senior Member
Joined: Aug 2004
Posts: 1,445
Likes: 6
Sekigahara is now working after adjusting the keyboard reader. The earlier snap has been updated.

Additionally, I've got the colours working much better. Challenge Golf finally gets a blue sky.

I've now got Super Motocross running.

[Linked Image from messui.1emulation.com] [Linked Image from messui.1emulation.com]

I'll add Sekigahara and Super Motocross to the software list.

Is there anything else you have for us?

Joined: May 2004
Posts: 1,684
H
Very Senior Member
Offline
Very Senior Member
H
Joined: May 2004
Posts: 1,684
if you invert the polarity on the tape files, it detects the header, and loads a bunch of data into RAM, but seems to stop loading when it reaches another area, before the end of the tape. lots of strings in RAM, so it's definitely loading *something* valid off the tape, but not sure how much of it is valid, or why it needs the polarity inverting.

Joined: May 2004
Posts: 1,684
H
Very Senior Member
Offline
Very Senior Member
H
Joined: May 2004
Posts: 1,684
ah, you have to invert the polarity, then run it with the BASIC cart inserted, I was trying to get it to verify, before even trying it with the BASIC.

[Linked Image from mamedev.emulab.it] [Linked Image from mamedev.emulab.it]
[Linked Image from mamedev.emulab.it] [Linked Image from mamedev.emulab.it]

it still seems to stop loading before the end, but maybe it's meant to..

also if I do 'V' (verify) instead of 'L' it says checksum error immediately after trying to load the header still (which is weird because at that point it really doesn't have much to checksum)

it's some kind of graphing program, written in basic, I have no idea if it works properly.

Joined: Aug 2004
Posts: 1,445
Likes: 6
Very Senior Member
Offline
Very Senior Member
Joined: Aug 2004
Posts: 1,445
Likes: 6
Interesting. Verify would most likely be comparing the tape against the existing program in RAM (which isn't there), rather than just checking the checksums.

Since this is the first real tape we've ever had for this system, it's quite possible that the signal needs inverting in emulation. I'll assume that is so, and make the change.

Joined: May 2004
Posts: 1,684
H
Very Senior Member
Offline
Very Senior Member
H
Joined: May 2004
Posts: 1,684
in that case verify gives a checksum error near the point where it stops loading but the data continues.

if I do a list, there's clearly a complete basic program in there, so I guess the part being loaded at the time are variables stored with the basic program, which means maybe it isn't loading the very last part? but I'm not sure there's room in RAM to load anything more anyway.

but yeah if there are no other tapes to compare against, assume it needs inverting in the emulation .

Page 4 of 7 1 2 3 4 5 6 7

Link Copied to Clipboard
Who's Online Now
4 members (Revenant, will, AJR, 1 invisible), 23 guests, and 4 robots.
Key: Admin, Global Mod, Mod
ShoutChat
Comment Guidelines: Do post respectful and insightful comments. Don't flame, hate, spam.
Forum Statistics
Forums9
Topics8,993
Posts118,149
Members5,005
Most Online890
Jan 17th, 2020
Forum Host
These forums are hosted by www.retrogamesformac.com
Forum hosted by www.retrogamesformac.com