Previous Thread
Next Thread
Print Thread
QMC2 v0.194 released yet for macOS? #112475
02/03/18 01:00 PM
02/03/18 01:00 PM
Joined: Aug 2015
Posts: 24
A
azoreseuropa Offline OP
Member
azoreseuropa  Offline OP
Member
A
Joined: Aug 2015
Posts: 24
I could compiled it for macOS but have a problem. Is this one: https://svn.code.sf.net/p/qmc2/code/trunk qmc2-code

or this one:

http://wiki.batcom-it.net/index.php?title=Building_Qt_on_Mac_OS_X

And should I follow this:

http://wiki.batcom-it.net/index.php?title=QMC2_FAQ#Mac_OS_X and if it is then it need to update because it is outdate, I think??

Last edited by azoreseuropa; 02/03/18 01:16 PM.
Re: QMC2 v0.194 released yet for macOS? [Re: azoreseuropa] #112479
02/03/18 04:36 PM
02/03/18 04:36 PM
Joined: May 2008
Posts: 4,892
Germany
Q
qmc2 Offline
Very Senior Member
qmc2  Offline
Very Senior Member
Q
Joined: May 2008
Posts: 4,892
Germany

This is about compiling Qt on Mac OS X (and it's likely outdated). It's not related to QMC2 in particular.


That's what you need to do to compile QMC2. It's current and recently tested successfully.

Regarding your question in the subject: No, there's no official QMC2 0.194 yet. I'm in the middle of some major changes that need to be finished first. Anyway, the latest released version works fine with current MAME.


A mind is like a parachute. It doesn't work unless it's open. [Frank Zappa]

We're searching for QMC2 translators and support for existing translations. Interested? See here!
Re: QMC2 v0.194 released yet for macOS? [Re: azoreseuropa] #112481
02/03/18 10:10 PM
02/03/18 10:10 PM
Joined: Aug 2015
Posts: 24
A
azoreseuropa Offline OP
Member
azoreseuropa  Offline OP
Member
A
Joined: Aug 2015
Posts: 24
Thank you.

Re: QMC2 v0.194 released yet for macOS? [Re: azoreseuropa] #112487
02/04/18 06:06 PM
02/04/18 06:06 PM
Joined: Jul 2007
Posts: 213
California
M
Monotremata Offline
Senior Member
Monotremata  Offline
Senior Member
M
Joined: Jul 2007
Posts: 213
California
Or just build the SVN branch if you want to stay on the 'latest and greatest'. Its now v0.194, and builds with no trouble now that the OS requirement was changed. All you really need is the SDL2 and Qt 4.8.7 frameworks along with XCode, type 'make' and you're good to go. The wiki says after OS 10.10 you have to build Qt with home-brew, but I still have the frameworks installed on 10.13 and they work fine. You shouldn't have to edit anything, on my Qt installation, the g++-macx.conf file was already set to 10.6, and I didn't have to build without Phonon either.

Re: QMC2 v0.194 released yet for macOS? [Re: Monotremata] #112494
02/05/18 09:50 AM
02/05/18 09:50 AM
Joined: May 2008
Posts: 4,892
Germany
Q
qmc2 Offline
Very Senior Member
qmc2  Offline
Very Senior Member
Q
Joined: May 2008
Posts: 4,892
Germany
Originally Posted by Monotremata
The wiki says after OS 10.10 you have to build Qt with home-brew, but I still have the frameworks installed on 10.13 and they work fine.

Ah, that's good to know. Well, I just documented what I've tested. But I will re-add the official Qt 4.8.7 framework as an alternative to the wiki! The major advantage to home-brew is that it includes Phonon support then wink.

EDIT: FAQ section revised!

Last edited by qmc2; 02/05/18 10:03 AM.

A mind is like a parachute. It doesn't work unless it's open. [Frank Zappa]

We're searching for QMC2 translators and support for existing translations. Interested? See here!
Re: QMC2 v0.194 released yet for macOS? [Re: azoreseuropa] #112976
03/28/18 11:56 AM
03/28/18 11:56 AM
Joined: Jan 2009
Posts: 5
B
BlueLander Offline
Member
BlueLander  Offline
Member
B
Joined: Jan 2009
Posts: 5
When I follow the instructions in the FAQ, I get the following error after make PHONON=0:

Code
./qmc2_phonon.h:1:10: fatal error: 'phonon/abstractaudiooutput.h' file not found
#include <phonon/abstractaudiooutput.h>


I guess this has to do with Qt? The Qt installer linked in the FAQ won't install for me (High Sierra), so I installed Qt via the brew option.

I get this error whether I do make PHONON=0 or plain old make

Last edited by BlueLander; 03/28/18 12:08 PM.
Re: QMC2 v0.194 released yet for macOS? [Re: azoreseuropa] #113032
04/01/18 07:31 PM
04/01/18 07:31 PM
Joined: Jul 2007
Posts: 213
California
M
Monotremata Offline
Senior Member
Monotremata  Offline
Senior Member
M
Joined: Jul 2007
Posts: 213
California
I was just trying to build the latest SVN about 5 minutes ago and also just ran into that same error with the Phonon stuff not found. Also, its possible that my QT frameworks finally don't work anymore either but Im not sure. When I first tried it and hit make, it told me it couldn't find qmake and stopped right away (it worked fine for the 0.195 SVN last month?). Installed Qt4 with brew using the command in the wiki, which finally worked but yeah even putting make PHONON=0 Im hitting the 'file not found' error.

EDIT: Nevermind now it went away?? The first time I hit make, I wasn't thinking of that part and just used 'make'. It stopped at the first file not found error and thats when I redid it with make PHONON=0, and it still failed. After changing the Qt conf file versions to 10.6 (I always did it after QMC2 generated its own makefile and changed it there), I did a 'make distclean' and started over and this time its compiling, no PHONON errors or Mac version errors so far!

Last edited by Monotremata; 04/01/18 07:40 PM.
Re: QMC2 v0.194 released yet for macOS? [Re: azoreseuropa] #113039
04/02/18 07:15 AM
04/02/18 07:15 AM
Joined: May 2008
Posts: 4,892
Germany
Q
qmc2 Offline
Very Senior Member
qmc2  Offline
Very Senior Member
Q
Joined: May 2008
Posts: 4,892
Germany
Yeah, you always need to at least remove "Makefile.qmake" in order to recreate it, or run "make distclean".


A mind is like a parachute. It doesn't work unless it's open. [Frank Zappa]

We're searching for QMC2 translators and support for existing translations. Interested? See here!
Re: QMC2 v0.194 released yet for macOS? [Re: azoreseuropa] #113054
04/03/18 11:44 PM
04/03/18 11:44 PM
Joined: Jan 2009
Posts: 5
B
BlueLander Offline
Member
BlueLander  Offline
Member
B
Joined: Jan 2009
Posts: 5
It looks like my problem was not running make distclean after an earlier build attempt didn't finish for whatever reason. Did that and everything built fine blush

Last edited by BlueLander; 04/03/18 11:44 PM.

Moderated by  qmc2 

Who's Online Now
2 registered members (AJR, R. Belmont), 27 guests, and 1 spider.
Key: Admin, Global Mod, Mod
Shout Box
Forum Statistics
Forums9
Topics8,600
Posts112,408
Members4,821
Most Online283
Oct 11th, 2018
Powered by UBB.threads™ PHP Forum Software 7.6.1.1
(Release build 20180111)
Page Time: 0.024s Queries: 14 (0.008s) Memory: 5.6554 MB (Peak: 5.8671 MB) Zlib enabled. Server Time: 2018-11-21 03:37:23 UTC