Previous Thread
Next Thread
Print Thread
Page 1 of 2 1 2
Mac compile 0.201 fails #113869 08/30/18 12:32 PM
Joined: Sep 2000
Posts: 202
W
will Offline OP
Senior Member
OP Offline
Senior Member
W
Joined: Sep 2000
Posts: 202
Greetings, when trying to clean compile MAME 0.201 on my Mac it fails:

Compiling src/devices/machine/ie15.cpp...
Archiving liboptional.a...
make: *** [macosx_x64_clang] Error 2

Running 10.13.6 on a 2017 model iMac.
Is this a known issue? Any suggestions or fixes?


=will=
Re: Mac compile 0.201 fails [Re: will] #113870 08/30/18 12:43 PM
Joined: May 1999
Posts: 554
Carbon Offline
Senior Member
Offline
Senior Member
Joined: May 1999
Posts: 554
Hey will,

compiling works fine for me with a similar set-up.Redownload the source to make sure nothing happened there.

Re: Mac compile 0.201 fails [Re: will] #113872 08/30/18 01:32 PM
Joined: Feb 2004
Posts: 2,055
Vas Crabb Offline
Very Senior Member
Offline
Very Senior Member
Joined: Feb 2004
Posts: 2,055
You'll need to give us more detail if you want us to help you diagnose it:
  • OS version
  • Xcode version
  • Output of "clang --version" (without the quotes)
  • The actual error message


You need to search the output for the first place you see a line with "***" in it to find the error that caused the build to fail.

Re: Mac compile 0.201 fails [Re: will] #113873 08/30/18 06:24 PM
Joined: Jul 2007
Posts: 220
M
Monotremata Offline
Senior Member
Offline
Senior Member
M
Joined: Jul 2007
Posts: 220
Build of both MAME and NegaMAME 0.201 went without a hitch on my Mac Pro running 10.13.6 yesterday..

Re: Mac compile 0.201 fails [Re: will] #113874 08/31/18 01:02 AM
Joined: Sep 2000
Posts: 202
W
will Offline OP
Senior Member
OP Offline
Senior Member
W
Joined: Sep 2000
Posts: 202
macOS 10.13.6, Xcode 9.4.1
clang --version
Apple LLVM version 9.1.0 (clang-902.0.39.2)
Target: x86_64-apple-darwin17.7.0
Thread model: posix
InstalledDir: /Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin

Compiling 3rdparty/softfloat3/source/f128M_to_f16.c...
In file included from ../../../../../src/osd/modules/input/input_common.cpp:36:
In file included from /Library/Frameworks/SDL2.framework/Headers/SDL.h:38:
/Library/Frameworks/SDL2.framework/Headers/SDL_cpuinfo.h:63:5: error: 'HAVE_IMMINTRIN_H' is not defined, evaluates to 0
[-Werror,-Wundef]
#if HAVE_IMMINTRIN_H && !defined(SDL_DISABLE_IMMINTRIN_H)
^
Compiling 3rdparty/softfloat3/source/f128M_to_f32.c...
Compiling 3rdparty/softfloat3/source/f128M_to_f64.c...
Compiling 3rdparty/softfloat3/source/f128M_to_i32.c...
Compiling src/mame/drivers/wildpkr.cpp...
Compiling 3rdparty/softfloat3/source/f128M_to_i32_r_minMag.c...
Compiling 3rdparty/softfloat3/source/f128M_to_i64.c...
Compiling src/osd/modules/input/input_rawinput.cpp...
Compiling 3rdparty/softfloat3/source/f128M_to_i64_r_minMag.c...
Compiling 3rdparty/softfloat3/source/f128M_to_ui32.c...
1 error generated.
make[2]: *** [../../../../osx_clang/obj/x64/Release/osd_sdl/src/osd/modules/input/input_common.o] Error 1
make[2]: *** Waiting for unfinished jobs....
Compiling src/devices/bus/a2bus/corvfdc01.cpp...
Compiling 3rdparty/softfloat3/source/f128M_to_ui32_r_minMag.c...
Compiling 3rdparty/softfloat3/source/f128M_to_ui64.c...
Compiling 3rdparty/softfloat3/source/f128M_to_ui64_r_minMag.c...
Compiling 3rdparty/softfloat3/source/f128_add.c...
Compiling 3rdparty/softfloat3/source/f128_div.c...
Compiling 3rdparty/softfloat3/source/f128_eq.c...
Compiling 3rdparty/softfloat3/source/f128_eq_signaling.c...
Compiling 3rdparty/softfloat3/source/f128_isSignalingNaN.c...
Compiling 3rdparty/softfloat3/source/f128_le.c...
Compiling 3rdparty/softfloat3/source/f128_le_quiet.c...
make[1]: *** [osd_sdl] Error 2
make[1]: *** Waiting for unfinished jobs....

make: *** [macosx_x64_clang] Error 2


=will=
Re: Mac compile 0.201 fails [Re: will] #113875 08/31/18 12:43 PM
Joined: Sep 2000
Posts: 202
W
will Offline OP
Senior Member
OP Offline
Senior Member
W
Joined: Sep 2000
Posts: 202
So I figured out the issue is with SDL framework 2.0.8 which was recently updated.

Went back and replaced SDL framework with 2.0.7 from last year and was able to compile successfully.

Is there a bug with the updated frameworks or does MAME source for SDL need to be updated ?

Just thought I'd share. Thanks!


=will=
Re: Mac compile 0.201 fails [Re: will] #113879 08/31/18 02:31 PM
Joined: Mar 2001
Posts: 16,273
R
R. Belmont Offline
Very Senior Member
Offline
Very Senior Member
R
Joined: Mar 2001
Posts: 16,273
It's quite possible there's an incompatibility with 2.0.8, I'll investigate. Thanks for tracking it down!

Re: Mac compile 0.201 fails [Re: will] #114028 10/02/18 02:19 PM
Joined: Sep 2000
Posts: 202
W
will Offline OP
Senior Member
OP Offline
Senior Member
W
Joined: Sep 2000
Posts: 202
Any updates about the Mac compile issue with SDL 2.0.8? I'm sticking with 2.0.7 but was just curious if we should upgrade at some point.


=will=
Re: Mac compile 0.201 fails [Re: will] #114029 10/02/18 02:37 PM
Joined: Mar 2001
Posts: 16,273
R
R. Belmont Offline
Very Senior Member
Offline
Very Senior Member
R
Joined: Mar 2001
Posts: 16,273
Sorry, I will check that out. It got overshadowed by the whole Mojave thing.

Re: Mac compile 0.201 fails [Re: will] #114156 11/03/18 07:25 AM
Joined: Jul 2007
Posts: 220
M
Monotremata Offline
Senior Member
Offline
Senior Member
M
Joined: Jul 2007
Posts: 220
I just checked mine over here.. Ive had 2.0.8 installed since the end of June (thats the date my DMG was downloaded anyways) and have built every version of MAME since June 27th with it (including 0.203 the other day). Including the latest, thats 6 (Im guessing I updated SDL2 in June on MAME release day since it was the 27th). Running 10.13.6 here so you can rule that out along with SDL2.

Page 1 of 2 1 2

Moderated by  R. Belmont 

Who's Online Now
3 registered members (judge, Duke, Dam0), 146 guests, and 3 spiders.
Key: Admin, Global Mod, Mod
ShoutChat Box
Comment Guidelines: Do post respectful and insightful comments. Don't flame, hate, spam.
Forum Statistics
Forums9
Topics8,673
Posts113,788
Members4,852
Most Online418
Aug 14th, 2019
Powered by UBB.threads™ PHP Forum Software 7.7.3