Previous Thread
Next Thread
Print Thread
Page 2 of 2 1 2
Re: Mojave major video issues [Re: will] #114045
10/03/18 06:37 PM
10/03/18 06:37 PM
Joined: May 1999
Posts: 546
Luxembourg
Carbon Offline
Senior Member
Carbon  Offline
Senior Member
Joined: May 1999
Posts: 546
Luxembourg
OK, found the culprit: I replaced my BGFX folder with the one from the 0.202 distribution. Everything works now fine.

Sorry for the confusion.

Re: Mojave major video issues [Re: will] #114148
10/31/18 03:14 PM
10/31/18 03:14 PM
Joined: Jan 2007
Posts: 177
Turin, North Italy
M
MacBox360 Offline
Senior Member
MacBox360  Offline
Senior Member
M
Joined: Jan 2007
Posts: 177
Turin, North Italy
Hello,
I am using SDLmame on two Macs, one MacPro 2012 with a Radeon HD5870 and a MacMini 2011 with dedicated Radeon 6630M, both of them running OSX 10.13.6.
I have always compiled separately the source on both machines to be sure everything was optimized for the best experience.
However I was very disappointed about the performance of some games like Ridge Racer (and Rave Racer) that are running with a heavy stuttering (no matter about the video settings, it sucks both in soft rendering and metal/opengl rendering) but since there are other 3D games that instead are running smoothly I always thought it was a driver issue, that will be solved sometimes in the near future MAME releases.
Recently I have changed the GPU in the MacPro with one required by Mojave and the Ridge Racer performance was still worse as usual. Then I installed Moajave over existing High Sierra OSX and... miracle! Suddenly all the games of Namco System 22 were running smooth as silk with a steady, rock solid 60Hz refresh (same settings as before). This with the same (0.202) SDLmame binary and SDL 2.0.8 installed.
So it seems that if I want better SDLmame performance the Mojave install is mandatory but while on the MacPro is an easy task (a GPU swap is all I needed) on the MacMini this will not possible, a new machine is required.
Since now I built all the SDLmame leaving makefile options as default, but I wonder if there are some options I need to change before compiling to have the same good performance also under OSX 10.13, this would save me from purchasing a new MacMini (or at least one of the previous generation where the Mojave install is still possible).

Any suggestion will be greatly appriciated.

Re: Mojave major video issues [Re: will] #114149
10/31/18 04:13 PM
10/31/18 04:13 PM
Joined: Mar 2001
Posts: 16,070
USA
R
R. Belmont Offline
Very Senior Member
R. Belmont  Offline
Very Senior Member
R
Joined: Mar 2001
Posts: 16,070
USA
Note that the System 22 driver has been significantly optimized (and bugfixed!) for the next release; it used to run well under 100% even on my MacBook Pro and now runs 100% no problems. So before you upgrade (even though the new MacMinis are pretty tempting!) wait for that release.

Re: Mojave major video issues [Re: will] #114153
11/02/18 10:05 AM
11/02/18 10:05 AM
Joined: Jan 2007
Posts: 177
Turin, North Italy
M
MacBox360 Offline
Senior Member
MacBox360  Offline
Senior Member
M
Joined: Jan 2007
Posts: 177
Turin, North Italy
Well, after the last SDLmame release I have done other tests and I found that almost all drivers where 3D stuff is involved have a dramatic boost in speed under Mojave while under High Sierra (and previous OSes) they are sluggish.
This is true, for axample not only for System22 games but also for the Ultra64 based Midway games, now all of them are a very really enjoyable experience so for me the Mojave upgrade has been a big thumbs up!

I don't know exactly where the problem is because both OSX 10.13 and 10.14 were installed on my Macs from scratch so no other apps or settings were slowing down the machines, also the build of SDLmame was done with the exactly same compile options and the SDL library was absolutely the same, and so the Xcode version. This happens also with binary builds from other people like the ones available, for example, from sdlmame.lngn.net so I know for sure is not a problem of my compilers.
Also is not GPU brand related because I have experienced the same thing both with a nVidia GTX680 and a ADM HD7950.

I am quite sure that this performance degradation happened since a certain MAME version on, because I remember very well that Ridge Racer was running smoothly and at a certain point it becomes stuttering both on audio and video refresh.
I also regularly checked the forum to see if other users were experiencing the same issue but no one come out to talk about this so always thought it was a driver issue to be fixed in the future.

Well, it seems in the end it has been fixed by Apple :-) Of course the Windows version of SDLmame never suffered this problem, but the very strange thing is that on OSX it made no difference for metal/opengl/soft video acceleration setting, it was like somewhere there was an handbrake on the speed of those 3D games.

Last edited by MacBox360; 11/02/18 10:06 AM.
Page 2 of 2 1 2

Moderated by  R. Belmont 

Who's Online Now
3 registered members (Reznor007, 2 invisible), 124 guests, and 2 spiders.
Key: Admin, Global Mod, Mod
Shout Box
Forum Statistics
Forums9
Topics8,606
Posts112,517
Members4,828
Most Online296
Dec 5th, 2018
Powered by UBB.threads™ PHP Forum Software 7.6.1.1
(Release build 20180111)
Page Time: 0.038s Queries: 15 (0.019s) Memory: 5.6625 MB (Peak: 5.8374 MB) Zlib enabled. Server Time: 2018-12-16 15:55:42 UTC