Previous Thread
Next Thread
Print Thread
How to keep Ubuntu + xorg from getting keystrokes? #114401
12/07/18 12:03 PM
12/07/18 12:03 PM
Joined: Feb 2014
Posts: 150
G
Golden Child Offline OP
Senior Member
Golden Child  Offline OP
Senior Member
G
Joined: Feb 2014
Posts: 150
Hi all,

I was trying to get the apple2gs driver to reset with the default bindings of F12 = reset and CTRL = ctrl with OpenApple = LALT and it doesn't work with xorg. To xorg, CTRL+ALT+F12 means switch to virtual terminal 12 which drops me into a text screen and I have to hit CTRL+ALT+F2 to get back to my normal xorg session.

I tried switching reset to PgUp but that didn't help. CTRL+ALT+PgUp doesn't seem to work.

CTRL+OA+ESC is supposed to bring up the control panel but I couldn't get that to happen.

There's also CTRL+ALT keys that get grabbed to do things like move windows around (for example CTRL+ALT+NumPad0 will minimize your existing window).

It's also annoying to accidentally hit the windows key and have Ubuntu's search box come up.

I'm wondering if there's an easy way to give mame priority over these keystrokes.


Or is reset handling not working on the apple2gs driver? I was able to map Reset to C and then reboot the apple2gs with CTRL+C. This worked on mame196 (an old version I had handy) but not on mame204.

Re: How to keep Ubuntu + xorg from getting keystrokes? [Re: Golden Child] #114402
12/07/18 12:45 PM
12/07/18 12:45 PM
Joined: Mar 2001
Posts: 16,070
USA
R
R. Belmont Offline
Very Senior Member
R. Belmont  Offline
Very Senior Member
R
Joined: Mar 2001
Posts: 16,070
USA
The control panel sequence doesn't work yet, that's a carryover issue from the previous driver.

For the //e at least I find it's easier to do CTRL+F12 then hold down ALT, and even easier to do CTRL+F3 (MAME's universal reset button) and then hold down one or both ALTs (closed-apple reset lets you access the Control Panel).

Re: How to keep Ubuntu + xorg from getting keystrokes? [Re: R. Belmont] #114403
12/07/18 01:12 PM
12/07/18 01:12 PM
Joined: Feb 2014
Posts: 150
G
Golden Child Offline OP
Senior Member
Golden Child  Offline OP
Senior Member
G
Joined: Feb 2014
Posts: 150
Ok, I can reset the IIgs with F3 (Ctrl+f3 toggles Uneven Stretch) and then hit and hold right alt just after hitting f3 to get to the control panel menu. I have to remember to go to Partial Keyboard emulation or F3/shift+f3 won't work.

So shift+f3 = full reset and f3 = soft reset.

I still couldn't get CTRL+F12 to work for the IIgs reset.

Thanks RB for the workaround.


Moderated by  R. Belmont 

Who's Online Now
0 registered members (), 115 guests, and 2 spiders.
Key: Admin, Global Mod, Mod
Shout Box
Forum Statistics
Forums9
Topics8,606
Posts112,516
Members4,827
Most Online296
Dec 5th, 2018
Powered by UBB.threads™ PHP Forum Software 7.6.1.1
(Release build 20180111)
Page Time: 0.102s Queries: 14 (0.029s) Memory: 5.5940 MB (Peak: 5.7584 MB) Zlib enabled. Server Time: 2018-12-16 10:47:25 UTC