Previous Thread
Next Thread
Print Thread
Page 40 of 40 1 2 38 39 40
Re: Can't compile latest MAME? READ THIS THREAD [Re: Just Desserts] #115467 06/28/19 09:38 PM
Joined: Mar 2010
Posts: 129
S
Shoegazer Offline
Senior Member
Offline
Senior Member
S
Joined: Mar 2010
Posts: 129
Ah yes, got it. Thanks!

Re: Can't compile latest MAME? READ THIS THREAD [Re: Just Desserts] #115548 07/25/19 03:57 PM
Joined: Apr 2012
Posts: 187
B
Bavarese Offline
Senior Member
Offline
Senior Member
B
Joined: Apr 2012
Posts: 187
How is the state concerning Visual Studio? I really liked the debugger, but am unable to compile anything beyond 0.205 (from December 2018).

Currently, i work with Visual Studio 2017 (15.9.x) and a 'retargeted' 14.14 toolset (-> mimics a 15.7 compiler).
https://devblogs.microsoft.com/cppb...ion-msvc-toolsets-in-visual-studio-2017/

Are there alternatives to GDB?

I understand nobody wants to support Visual Studio here, so a slight nudge in the right direction would be very kind (like 'use VS2019 + commercial WinDBG').

Yeah, i'd even shell out a few hundred bucks for a semi-professional tool.

Last edited by Bavarese; 07/25/19 04:00 PM.
Re: Can't compile latest MAME? READ THIS THREAD [Re: Just Desserts] #115549 07/25/19 04:07 PM
Joined: Mar 2001
Posts: 16,300
R
R. Belmont Offline
Very Senior Member
Offline
Very Senior Member
R
Joined: Mar 2001
Posts: 16,300
Visual Studio using the LLVM/Clang compiler is the best way to both compile MAME and use the VS debugger. "make msllvm" I think is the magic.

Re: Can't compile latest MAME? READ THIS THREAD [Re: Just Desserts] #115557 07/28/19 10:39 AM
Joined: Apr 2012
Posts: 187
B
Bavarese Offline
Senior Member
Offline
Senior Member
B
Joined: Apr 2012
Posts: 187
Hmm... i think it should read
Code
make vsllvm

Do i need LLVM-7.1.0-win64.exe, the newer 8.x (only available as source) - or the one supplied by the Microsoft installer ("Clang C2 experimental") ?
Is it still Visual Studio 2017...?

My fellow countryman Rfka was also unable to build the solution, that's why i ask for a bit more details wink Thanks in advance.

Screenshot - mess.sln properties (VS 2017)
https://www.dropbox.com/s/lirblgiixwhvsr1/VS2017_Mess_platform_toolset.jpg?dl=0

Last edited by Bavarese; 07/28/19 11:13 AM.
Re: Can't compile latest MAME? READ THIS THREAD [Re: Just Desserts] #115793 09/02/19 01:15 AM
Joined: Aug 2004
Posts: 1,383
Robbbert Offline
Very Senior Member
Offline
Very Senior Member
Joined: Aug 2004
Posts: 1,383
Just a warning for those who build their own: GCC 9.2 is bugged and may not compile MAME. Roll back to an earlier version.

Page 40 of 40 1 2 38 39 40

Who's Online Now
3 registered members (zino, mixmaster, 1 invisible), 41 guests, and 3 spiders.
Key: Admin, Global Mod, Mod
ShoutChat Box
Comment Guidelines: Do post respectful and insightful comments. Don't flame, hate, spam.
Forum Statistics
Forums9
Topics8,683
Posts114,012
Members4,863
Most Online510
Aug 26th, 2019
Powered by UBB.threads™ PHP Forum Software 7.7.3