Previous Thread
Next Thread
Print Thread
Page 1 of 2 1 2
QMC2 Invalid Configuration #115872 09/10/19 03:11 AM
Joined: May 2013
Posts: 10
J
Jer Offline OP
Member
OP Offline
Member
J
Joined: May 2013
Posts: 10
Ever since Mame 0.212 I've been getting an 'Exit code=6 (invalid configuration) on QMC2 0.195 (windows x64). Same thing happens with Mame 0.213. QMC2 worked fine up until then. Tonight I re-installed QMC2 from scratch and re-did all the settings and I am still getting the same error. Any ideas?

Re: QMC2 Invalid Configuration [Re: Jer] #115885 09/10/19 11:24 PM
Joined: Apr 2011
Posts: 288
B2K24 Offline
Senior Member
Offline
Senior Member
Joined: Apr 2011
Posts: 288
You'll have to wait for an update from QMC2 and there's no ETA on that the last I've heard.

Re: QMC2 Invalid Configuration [Re: Jer] #115886 09/10/19 11:41 PM
Joined: Mar 2001
Posts: 16,389
R
R. Belmont Offline
Very Senior Member
Offline
Very Senior Member
R
Joined: Mar 2001
Posts: 16,389
Yeah, Rene is still recovering from a stroke. Everyone reading this please take care of yourself!

Re: QMC2 Invalid Configuration [Re: R. Belmont] #115899 09/11/19 07:56 PM
Joined: Feb 2007
Posts: 474
C
couriersud Offline
Senior Member
Offline
Senior Member
C
Joined: Feb 2007
Posts: 474
No problems here with 0.196 (SVN R8298): Ubuntu 16.04 and mame 0.213.

Originally Posted by R. Belmont
Yeah, Rene is still recovering from a stroke. Everyone reading this please take care of yourself!


Yes, how true. And don't push anything you'd like to do into the future. Do it now.

Re: QMC2 Invalid Configuration [Re: Jer] #115981 09/22/19 02:07 AM
Joined: Jun 2017
Posts: 26
MusicLovr Offline
Member
Offline
Member
Joined: Jun 2017
Posts: 26
195 and 196 are working fine, here, with 0.213 on Windows 10 x64. I suspect you have some corrupt cache. Have you tried "qmc2 -cc"? This will fix any number of strange errors, due to cache problems.

From Ultimate guide:

Arguments in detail:
...
-cc: When this CLI option is specified, all emulator caches will be cleared (removed) before the application actually starts up. This is useful whenever the emulator version doesn't change and QMC2 can't figure out that it's time to update the caches because of this (so this mainly applies to those users that are often updating their MAME installation from the public SVN repository).
...

Re: QMC2 Invalid Configuration [Re: Jer] #115992 09/23/19 03:23 AM
Joined: Jun 2017
Posts: 26
MusicLovr Offline
Member
Offline
Member
Joined: Jun 2017
Posts: 26
Correction: QMC2-mame -cc

Last edited by MusicLovr; 09/23/19 03:25 AM.
Re: QMC2 Invalid Configuration [Re: Jer] #116106 10/05/19 03:32 PM
Joined: May 2013
Posts: 10
J
Jer Offline OP
Member
OP Offline
Member
J
Joined: May 2013
Posts: 10
I figured out the problem. Artwork must be turned 'on' for it to work. Will not work if artwork is 'off' or artwork is partially 'off' (such as no bezels or only overlays, etc).

Re: QMC2 Invalid Configuration [Re: Jer] #116112 10/06/19 01:19 AM
Joined: Jun 2017
Posts: 26
MusicLovr Offline
Member
Offline
Member
Joined: Jun 2017
Posts: 26
Ah - a MAME error, caused by QMC2. I can confirm this. It seems MAME no longer supports the old artwork -use and -nouse_whateverartwork commands. It still does support -[no]artwork_crop / -[no]artcrop,

So, must have all artworks enabled, in QMC2, and turn off artwork with MAME video options, for individual machines, or no (or incorrect) artwork paths to turn off for all machines.

Perhaps you could register this problem on the bug tracker. It might help to make it evident to more users...

Last edited by MusicLovr; 10/06/19 01:20 AM.
Re: QMC2 Invalid Configuration [Re: Jer] #116403 11/12/19 04:47 PM
Joined: Mar 2007
Posts: 286
RColtrane Offline
Senior Member
Offline
Senior Member
Joined: Mar 2007
Posts: 286
I hope the developer is recovering well and we can have a new version soon. QMC2 is the only usable MAME frontend nowadays (with all due respect to other frontend developers out there) and the only one which has controls for all MAME settings in a clean/intuitive/organized way. All other frontends are a mess, most of them are incomplete or way too intricate to configure.

Last edited by RColtrane; 11/12/19 04:52 PM.
Re: QMC2 Invalid Configuration [Re: RColtrane] #116420 11/13/19 02:53 AM
Joined: Feb 2004
Posts: 2,093
Vas Crabb Offline
Very Senior Member
Offline
Very Senior Member
Joined: Feb 2004
Posts: 2,093
Originally Posted by RColtrane
I hope the developer is recovering well and we can have a new version soon.

I've said it before, I'll say it again: if you want a new version, the community will have to pick the project up. Rene already had a lot of stuff going on in his life before the health issues hit. Projects that rely on a single developer inevitably stagnate or die when the developer moves on.

Page 1 of 2 1 2

Moderated by  qmc2 

Who's Online Now
1 registered members (mfm005), 141 guests, and 0 spiders.
Key: Admin, Global Mod, Mod
ShoutChat Box
Comment Guidelines: Do post respectful and insightful comments. Don't flame, hate, spam.
Forum Statistics
Forums9
Topics8,721
Posts114,622
Members4,873
Most Online510
Aug 26th, 2019
Powered by UBB.threads™ PHP Forum Software 7.7.3