Previous Thread
Next Thread
Print Thread
Page 1 of 2 1 2
Joined: Jan 2009
Posts: 67
P
Procyon Offline OP
Member
OP Offline
Member
P
Joined: Jan 2009
Posts: 67
Hello. Since building 0.235, I find that I'm no longer able to run MAME in BGFX mode. SDL and OpenGl work fine. When I try to run with BGFX, I get:


Enter sdl_info::create
MESA-INTEL: warning: Performance support disabled, consider sysctl dev.i915.perf_stream_paranoid=0

X Error of failed request: BadDrawable (invalid Pixmap or Window parameter)
Major opcode of failed request: 149 ()
Minor opcode of failed request: 4
Resource id in failed request: 0x200000e
Serial number of failed request: 423
Current serial number in output stream: 428


I should note that even if I run the sysctl command, only the warning goes away, the error remains. I have made sure that I have the latest BGFX files in the right place. I have been able to use BGFX successfully on this laptop for several versions, this is a brand new experience for me. Any ideas on what I can try? For background, I'm on Ubuntu 21.04, using nvidia-driver-470. Thank you.

Last edited by Procyon; 09/04/21 01:36 AM.
Joined: Mar 2001
Posts: 16,807
Likes: 32
R
Very Senior Member
Offline
Very Senior Member
R
Joined: Mar 2001
Posts: 16,807
Likes: 32
The message says it's trying to use your Intel integrated GPU instead of your Nvidia discrete one. I'm not sure how to fix that.

Joined: Jan 2009
Posts: 67
P
Procyon Offline OP
Member
OP Offline
Member
P
Joined: Jan 2009
Posts: 67
Interesting. I double checked a few things on my system, video acceleration appears enabled in my browsers, I also ran:


~$ glxinfo
name of display: :1
display: :1 screen: 0
direct rendering: Yes
server glx vendor string: NVIDIA Corporation
server glx version string: 1.4


and "direct rendering" is a "Yes"... I'm going to rebuild to 0.234 and see if the problem persist. Thank you RB.

Joined: Jan 2009
Posts: 67
P
Procyon Offline OP
Member
OP Offline
Member
P
Joined: Jan 2009
Posts: 67
Can now confirm: rebuilding back to 0.234 allowed me to use BGFX mode. Will now build back to 0.235 and test.

Joined: Jan 2009
Posts: 67
P
Procyon Offline OP
Member
OP Offline
Member
P
Joined: Jan 2009
Posts: 67
OK, I've rebuilt MAME back to 0.235, updated the bgfx folder, and I am back to the same problem. So, 0.234 BGFX = working for me, and 0.235 BGFX = not working for me. Everything else is the same. RB, any way I can drill down deeper into this, possibly get you some debug information? Thanks.

Last edited by Procyon; 09/04/21 03:09 AM.
Joined: Apr 2006
Posts: 709
D
Senior Member
Offline
Senior Member
D
Joined: Apr 2006
Posts: 709
Did you tried it from the latest mame source? BGFX got some fixes.

git clone https://github.com/mamedev/mame.git

https://github.com/mamedev/mame/

Try it to see. For the 0.236 beta.

Some of the games screen didn't work right with the 0.235 released because of the BGFX changes. I thought maybe it did something to the Linux version to where it crash.

Last edited by Dullaron; 09/05/21 02:02 AM.

Windows 10 Home 64-bit / AMD Radeon RX 5700 XT / AMD Ryzen 7 3700X 8-Core 3.59 GHz / RAM 16 GB
Joined: Jan 2009
Posts: 67
P
Procyon Offline OP
Member
OP Offline
Member
P
Joined: Jan 2009
Posts: 67
Hi Dullaron, any branch in particular? I just tried doing a checkout master, pulling latest, and building that, but sadly no, it does not improve the situation.

Joined: Mar 2001
Posts: 16,807
Likes: 32
R
Very Senior Member
Offline
Very Senior Member
R
Joined: Mar 2001
Posts: 16,807
Likes: 32
The master branch, as of cbc2489, has all of the current post-0.235 BGFX fixes.

Joined: Jan 2009
Posts: 67
P
Procyon Offline OP
Member
OP Offline
Member
P
Joined: Jan 2009
Posts: 67
OK, so this just got a lot more interesting: I was able to reproduce the issue on a second separate laptop. I realized I had a laptop I was using to test out the Pop! OS distro on, and I know I had MAME running just fine with BGFX on that as well. Updated that to 0.235, rebuilt, and boom: BadDrawable. The systems are similar, but not identical:

OS_____Ubuntu_______Pop! OS
CPU____i7-10750H_____i7-6700H
GPU____GTX-1660 Ti___GTX-970M


And as before, the Pop! OS laptop can run just fine in OpenGL and SDL. Only having a problem with BGFX.

RB, I synced to commit ea3185a when I built master on the Ubuntu laptop, and still have the issue. I have just synced to fc79b73 on the Pop! OS laptop and am rebuilding now, but I suspect the results will be the same. Please advise. Thank you!

Last edited by Procyon; 09/05/21 05:26 AM.
Joined: Apr 2006
Posts: 709
D
Senior Member
Offline
Senior Member
D
Joined: Apr 2006
Posts: 709
Try this one over here at https://sdlmame.wallyweek.org/ There 3 installers there.


Windows 10 Home 64-bit / AMD Radeon RX 5700 XT / AMD Ryzen 7 3700X 8-Core 3.59 GHz / RAM 16 GB
Page 1 of 2 1 2

Moderated by  R. Belmont 

Link Copied to Clipboard
Who's Online Now
1 members (Bletch), 24 guests, and 2 robots.
Key: Admin, Global Mod, Mod
ShoutChat
Comment Guidelines: Do post respectful and insightful comments. Don't flame, hate, spam.
Forum Statistics
Forums9
Topics8,974
Posts117,891
Members5,001
Most Online890
Jan 17th, 2020
Forum Host
These forums are hosted by www.retrogamesformac.com
Forum hosted by www.retrogamesformac.com