First thanks for this incredible frontend. I'm on Linux and really appreciate it. Does QMC2 have anyway to specify -noautosave on a per-machine basis? I have "autosave 1" in my mame.ini and QMC2 is setup to read that file. If I uncheck it in the per-machine configuration menu, it removes "-autosave" from the command, but if there is already a ***.sta file in my -state_directory path then that state gets loaded regardless! The way I normally avoid this on the command line is to specify "-noautosave". How do you force "-noautosave" in QMC2? Thanks.