Previous Thread
Next Thread
Print Thread
Page 1 of 2 1 2
#123198 02/11/24 12:31 AM
Joined: Sep 2000
Posts: 480
Likes: 2
M
Senior Member
OP Offline
Senior Member
M
Joined: Sep 2000
Posts: 480
Likes: 2
So, it's been a few years since I asked this, so now seems to be as good a time as any to ask;

What options are available to a Mac OS user for a MAME Front end?

I'm currently using QMC2 (version 0.192... I understand a newer version was released, but I can't seem to find the Mac OS version of it)... It works fine, but I worry that a day will come that some future version of MAME will be incompatible with it, and I'd like to see what some of my other options might be...

I've also tried Negatron (v 0.100.1), and when I can get it to start up without locking up, it appears to work fine...

I've also been looking at pfeMAME, and Attract... The latter appears to be designed for cabinets, while the former appears unfinished, and cannot be opened... frown

*Sigh* I miss MAMETunes... shocked

So... Anyone have any recommendations?

Last edited by MAMEBase; 02/11/24 12:36 AM.

The following statement is true...
The preceding statement is false.
Joined: Dec 2014
Posts: 59
H
Member
Offline
Member
H
Joined: Dec 2014
Posts: 59

Last edited by Hairball; 02/11/24 12:42 AM.
Joined: Sep 2000
Posts: 480
Likes: 2
M
Senior Member
OP Offline
Senior Member
M
Joined: Sep 2000
Posts: 480
Likes: 2
Thank you for the recommendation!

I've taken a look at Erockus Arcade, and have added it to my lineup...

I do seem to be having a small problem though (and I'm pretty sure the solution will end up being a setting I missed);

When starting any game, I'm presented with a 'white screen' that appears to be the aspect ratio of the game that's attempting to start

I've compared my settings to the corresponding settings I have in my QMC2 setup, but I could have easily missed something...

Any suggestions?


The following statement is true...
The preceding statement is false.
Joined: Dec 2014
Posts: 59
H
Member
Offline
Member
H
Joined: Dec 2014
Posts: 59
I've never encountered that problem. Though I have on rare occasions start a game and all I get a black a screen, then have to force quit MAME, restart the game and it works just fine.

I don't use QMC2 so I'm not sure how it handles things.

Only thing I can think of is double check the settings in Erockus Arcade, maybe something in the Video and OpenGL tabs perhaps?

You could also go to Library/Application Support/mame and take out the mame.ini file and try it again. Erockus Arcade doesn't do anything with mame.ini but maybe there could some some sort of issue with it ? I'm not sure.

Last edited by Hairball; 02/13/24 04:40 AM.
Joined: Mar 2004
Posts: 698
Likes: 2
Senior Member
Offline
Senior Member
Joined: Mar 2004
Posts: 698
Likes: 2
I have recently added history.xml support to qmc2's git in case you would be interested in testing it.

Joined: Sep 2000
Posts: 480
Likes: 2
M
Senior Member
OP Offline
Senior Member
M
Joined: Sep 2000
Posts: 480
Likes: 2
@Hairball - Would you be willing to provide a screenshot, or perhaps a description of your Video and/or OpenGL settings, so I can compare, and contrast?

@belegdol - I'd be happy to test a newer version of QMC2... My problem is that previous releases came packaged on an image file, with an installer... My attempts to compile my own from source have been unsuccessful (which is why I'm still using 0.192...) Any help is appreciated...


The following statement is true...
The preceding statement is false.
Joined: Dec 2014
Posts: 59
H
Member
Offline
Member
H
Joined: Dec 2014
Posts: 59
VIdeo :
Rotate, Maximize Window, Keep Aspect, Center Horizontally and Center Vertically are on/selected. The rest are off.

Brightness 1.0
Contrats 1.0
Gamma 1.0
Pause Brightness 0.65
Integer ScaleX 0
Integer Scale Y 0
Beam Minimum Width 1.0
Beam Maximum 1.0
Beam Intensity 0
Flicker 0.00

Number of Screens 1
Video Driver auto
Video Type bgfx
Scale mode none
Render Driver opengl

Effect none
BGFX Backend metal
BGFX Screen Chains unfiltered
BGFX SHadow Mask slot-mask.png
BGFX LUT Texture none

Opengl:
VBO, PBO and GLSL Filter are on rest are off.
Prescale 1

All the shaders are none

Joined: Sep 2000
Posts: 480
Likes: 2
M
Senior Member
OP Offline
Senior Member
M
Joined: Sep 2000
Posts: 480
Likes: 2
Thank you, that appears to have done the trick!

I think my video type was set incorrectly... Once I set the video type to bgfx, things began to work as expected...


The following statement is true...
The preceding statement is false.
Joined: Dec 2014
Posts: 59
H
Member
Offline
Member
H
Joined: Dec 2014
Posts: 59
No probs. Awesome, glad you got it working.

Joined: Mar 2004
Posts: 698
Likes: 2
Senior Member
Offline
Senior Member
Joined: Mar 2004
Posts: 698
Likes: 2
Originally Posted by MAMEBase
@Hairball - Would you be willing to provide a screenshot, or perhaps a description of your Video and/or OpenGL settings, so I can compare, and contrast?

@belegdol - I'd be happy to test a newer version of QMC2... My problem is that previous releases came packaged on an image file, with an installer... My attempts to compile my own from source have been unsuccessful (which is why I'm still using 0.192...) Any help is appreciated...
I got rudimentary CI working, it should at least produce a working binary, not sure about the installer. The wiki being gone and not archived by the wayback machine is not exactly helpful.

Page 1 of 2 1 2

Moderated by  R. Belmont 

Link Copied to Clipboard
Who's Online Now
0 members (), 31 guests, and 5 robots.
Key: Admin, Global Mod, Mod
ShoutChat
Comment Guidelines: Do post respectful and insightful comments. Don't flame, hate, spam.
Forum Statistics
Forums9
Topics9,273
Posts121,387
Members5,064
Most Online1,283
Dec 21st, 2022
Our Sponsor
These forums are sponsored by Superior Solitaire, an ad-free card game collection for macOS and iOS. Download it today!

Superior Solitaire
Forum hosted by www.retrogamesformac.com